09-17-2017 02:58 PM
79 1234
tools
  1. captfbgnet's Avatar
    This problem was driving me nuts. I did find a solution though.

    Tried doing a factory which DID NOT work.

    What worked was disabling ipv6 on my router as others have mentioned.
    Wanted to also confirm it.
    Disabling ipv6 on my Win7 x64 network using Cisco router worked for me too. EDIT: Found out that the problem comes back after about a week. Need to re-boot router again for quicker speeds. Still don't have permanent solution.
    01-10-2015 09:05 AM
  2. AZgl1500's Avatar
    Not ignoring your WiFi problems, but my phone has never given me any WiFi issues ever.

    But, I exercise extreme control over the when, and the where it can work.

    I do this with one control app called MacroDroid.
    => * MacroDroid - Device Automation - Android Apps on Google Play


    The free version allows for 5 macros that can control a single selection. Even so, the free version can and does (on my wife's SGS5 phone) easily handle your problems.

    On her phone, I wrote 4 macros:

    Data OFF label
    • Trigger: Screen OFF
    • Action: disable MobileData


    Data ON label
    • Trigger: Screen ON
    • Action: Enable MobileData


    WiFi OFF label
    • Trigger: Screen OFF
    • Action: Disable WiFi


    WiFi ON label
    • Trigger: Screen ON
    • Action: Enable WiFi


    Those four simple macros have performed miracles with her phone's battery consumption.
    It idles along for days and days and does not need a charge. I looked at it yesterday 3 days off charge and it was at 84% battery. Her phone does not have any downloaded apps. All useless apps are turned off.
    One of these days, when her phone finally drops low enough, I am going to make a screen shot of how long it has been off charge. Going to be at a week more though....


    I use the Pro version of MacroDroid on my phone because I want more from it. The premium version can control multiple status points with one macro.

    So, on my phone, I have 2 macros to control the radios.
    Screen OFF and Screen ON.
    each of those will control both Wifi and DATA simultaneously and I get 3 days use per charge cycle.
    and that is with me using the phone quite a bit all thru the day looking at it helping folks like you on the forums.

    I do the normal telco calls, SMS stuff, emails, news sites apps, GPS mapping apps (my favorite topic) and more. I do not watch videos, nor do I play games with my phone. I just don't like games....

    It won't cost you anything...

    below is a screenshot of my phone, which most likely will better represent the use most folks give their S5 phone. My wife is the exception. she does not make outbound calls, she only takes them...
    Attached Thumbnails Wifi Slow on Galaxy S5 - Strange Problem, Please Help-2-days-18-hrs-battery-64-.jpg  
    01-10-2015 01:25 PM
  3. sushiguy732's Avatar
    I too have the same issue and found this post very valuable. Thank you OP.

    I tried disabling my ipv6 on my Verizon n/as routher and it still did not work. So my questions are;
    Does everyone have this issue?
    If I go to Big Red and swap my phone, would that be a viable solution?

    T.I.A.
    01-10-2015 06:29 PM
  4. sushiguy732's Avatar
    Also I removed my SIM card and all worked fine. Put it back in and kablooe.

    Posted via the Android Central App
    01-10-2015 06:52 PM
  5. gravitybear's Avatar
    note 4 here, same problems. Over 4gLTE everything works fine. However on some WiFi locations (at home especially) the wifi just does not work with apps. It works fine with webpages in the browser, but apps take forever to load (about 2-5 minutes to load one image on instagram or even google play, for instance.) Its weird though, on some wifi networks it works fine.

    Ive tried all kinds of stuff and researched everywhere and I just cant seem to fix it. The only fix seems to be replacing your router, but unfortunately I cant do that because I have Fios and you have to use their routers.2

    Ive tried:

    Disabling/enabling IPV6
    restarting router
    restarting phone
    forgetting network on phone
    logging out/in of apps
    disabling/enabling the mobile/wifi data option
    changing network channel on router
    updating router firmware

    anyone find a solution yet? driving us nuts.
    01-17-2015 12:42 PM
  6. Pianoman2013's Avatar
    I have Sprint's variant of the S5 (SM-G900P), and I am having the same wifi issues, but it only appears to be on my home network. When I am at home, the wifi is sluggish, but where I am noticing the biggest (and most frustrating) issue is with my Google Account syncing. When I am at home, it doesn't. I will receive an email hours after it appears on my tablet (Nexus 7 2013). My auto-backup of photos through Google+ will not register on the S5, but WILL on the tablet and the computer. In short: zero push notifications. When I am on LTE, everything syncs instantly; the same goes for my wifi at work. The only thing that I can gather from the posts is that ipv6 has something to do with it. When I am at home, I have an ipv4 and ipv6 address. At work and on public wifi networks I am only assigned an ipv4 address.

    I have a TC8305C router from Comcast, and I do not see any way to disable ipv6. I found this thread which is much older (2013) but this user seemed to have a similar problem (and since this is my first post, I cannot post the link). It was entitled "Bug: Samsung Galaxy S3 (+other Samsungs) broken in IPv6 WLAN networks (wifi driver ignores icmpv6)." Funny enough, my S3 never had this issue for the more than two years I had it.

    I have tried the factory reset, but the same problem exists, on my phone and my wife's (also S5). My network and tech knowledge is workable, but by no means extensive. I am good at following directions, so I am open to any suggestions.

    Thank you in advance.
    01-18-2015 02:22 PM
  7. djmaglioli's Avatar
    For anyone with this problem try disabling Google+ and if you're on Verizon try disabling Verizon's cloud app or any other equivalent services.
    01-22-2015 01:56 PM
  8. Allyson Seel-Sorenson's Avatar
    Holy crap...I think this just worked for me! Earlier in the week after 2 months of no issues with my new LG G3, my home wifi is barely running my apps. Other devices in the house are fine, including phones. I can get on FB or Instagram via Chrome and the desk top versions on my phone work fine, just no apps. I just trashed Google Plus and it seems to be running the apps! I hope this is the fix, thank you!
    01-22-2015 05:06 PM
  9. GS5_14580's Avatar
    I have same setup: GS5 KitKat, TWC Roadrunner Turbo, and ARRIS modem/router. I think I fixed it by disabling ipv6 on ARRIS modem.
    you have to uncheck "Enable DHCP (IPV6)" under DYNAMIC (IPV6) & uncheck "Enable Static IPV6" under STATIC (IPV6) on the WAN Setup tab, and also uncheck "Enable DHCP Server (IPV6)" under LAN SETTINGS (IPV6) on the LAN Setup tab. Make sure to click apply after changing each one, then "restart router" under utilities tab.
    Worked like a charm!
    01-25-2015 11:13 AM
  10. gravitybear's Avatar
    unfortunately that is one of the first things I tried based on the success of a few others... ipv6 was already disabled by default. I also tried enabling it (just in case). No luck.
    01-25-2015 11:18 AM
  11. Stackrat's Avatar
    To the OP and others:

    I have the same cablemoden (Arris - through TWC) and was having the same problem with my Galaxy S5 - slow access to google.com (regardless of browse used), facebook, google play, google maps, etc...). I was not experiencing this with any of my other android devices (Moto Droid RAZR MAXX, LG Spectrum, Galaxy Tab 3).

    The solution that worked for me was, under the "LAN Setup" tab, check the "Enable DNS Relay" box. For good measure, I also enabled the DNS Override and set them to 8.8.8.8/8.8.4.4. I don't know if it affects it, but I also have UPnP enabled.

    When I un-enable DNS relay, the problem comes back.

    Hope this helps.
    02-02-2015 09:32 AM
  12. djmaglioli's Avatar
    I thought I had fixed this issue unfortunately it never is that easy. So, I have the Verizon S5, a Netgear WNDR4300, and Arris modem. My issue is a little bit weirder than the others. Whenever I connect my GS5 to my home wifi it is not only slow on my phone but it slows everyone else on the network down. I'll connect my phone and boom suddenly the internet on my PC slows to a crawl. The up and down arrows on the wifi symbol on the phone are constantly lit up always sending and receiving information. I restart the phone and the wifi symbol goes back to normal for awhile and the wifi on all devices including the phone is quick and fast for around an hour until it slows down again and I have to disconnect it from the wifi in order for my other devices to work properly. Iv'e tried every solution listed within this thread and beyond but I'll ask does anyone have any other ideas how to fix this. I'm hoping the 5.0 update for the GS5 brings a much needed fix but, since this issue has been a problem since 4.3 on the GS5 its unlikely.
    02-02-2015 04:58 PM
  13. djmaglioli's Avatar
    Thank You I had tried the Wif analyzer before and it said all of my channels were fine and MAC filtering last I checked was off, now before I say this I'll knock on every piece of wood I can find in the house but, I did the second part of Verizon's lollipop update yesterday and I've had absolutely no issues with Wifi at all so far today

    Edit: Well it returned, but it doesn't seem as bad as it was. It still making the phone unusable and slowing down my entire network, but I guess I'll either get it replaced or just have to live with it until either Google or Samsung gets their head out their *** and fixes it.
    02-03-2015 11:06 AM
  14. socalsx's Avatar
    I have same setup: GS5 KitKat, TWC Roadrunner Turbo, and ARRIS modem/router. I think I fixed it by disabling ipv6 on ARRIS modem.
    you have to uncheck "Enable DHCP (IPV6)" under DYNAMIC (IPV6) & uncheck "Enable Static IPV6" under STATIC (IPV6) on the WAN Setup tab, and also uncheck "Enable DHCP Server (IPV6)" under LAN SETTINGS (IPV6) on the LAN Setup tab. Make sure to click apply after changing each one, then "restart router" under utilities tab.
    Worked like a charm!
    THIS! Finally after months of slooow wifi on Google Play, Instagram, etc (basically any app) I finally have my wifi performance back.

    It started after upgrading to 4.4.4 so I tried everything: full wipes (cache, dalvik, etc), reinstalling the ROM and finally gave up, using my data to its limit. Finally I upgraded to 5.0 lollipop on my verizon S5 and while somewhat better, still had the issue! This actually worked! screw whoever decided that ipv6 will gimp a phone like this
    02-05-2015 02:12 PM
  15. sushiguy732's Avatar
    I was had the same exact problem and no one could answer me. I'll even go so far as to say that if you take out the SIM card, your wifi will work fine.

    I traced it back to my network setup in my house. I have the Verizon fios router, couple switches and a second Dlink router configured as a switch (no wifi or DNS). Seemed to be an issue with the Dlink as every time I powered it off my phone worked perfectly.

    In the end, I replaced the Dlink with a $20 linksys / cisco switch and no more issues.

    Posted via the Android Central App
    02-05-2015 04:18 PM
  16. Ben EV's Avatar
    I was having the same trouble with all of my Samsung devices on my router (netgear ac1900). I am using att uverse. I managed to fix the problem by switching my router over to an access point which immediately made Facebook and all other apps run normally. It appears is an issue when a router is plugged into whatever ISP device you are using is not forwarding is port (I.E access point)
    02-05-2015 05:54 PM
  17. gravitybear's Avatar
    THIS! Finally after months of slooow wifi on Google Play, Instagram, etc (basically any app) I finally have my wifi performance back.

    It started after upgrading to 4.4.4 so I tried everything: full wipes (cache, dalvik, etc), reinstalling the ROM and finally gave up, using my data to its limit. Finally I upgraded to 5.0 lollipop on my verizon S5 and while somewhat better, still had the issue! This actually worked! screw whoever decided that ipv6 will gimp a phone like this
    I really feel like this has to be the fix for me because your symptoms are exactly the same as mine. However I do have IPV6 disabled and all of my apps are still very slow. Did you perhaps change anything else at the same time?
    02-05-2015 07:51 PM
  18. djmaglioli's Avatar
    I think I finally fixed my issue. I disabled the Play Store's auto update function and the Google App's auto sync options. I did this three days ago and I've had no wifi issues since.
    02-08-2015 06:45 PM
  19. Vilmantas Klinavicius's Avatar
    Thanks, worked for me, just disabled/re-enabled bluetooth.
    02-14-2015 01:20 PM
  20. ColeCPA's Avatar
    I have the same exact problem Airman1947 describes in his original post. I have to switch and sign into my guest network in order to get Facebook and Instagram photos and videos to load. This makes me crazy as some other apps like Google Hangouts won't work right while on the guest network. Besides, I do not want to have to keep signing into my guest network every time I want to use social media apps. I kept reading the replies to this thread and I am not sure you've found a solution to the problem yet. Have you??? I get so frustrated with this phone. My husband has an S4 and he doesn't have the problem at all. None of our other equipment, which includes 3 laptops, several tablets and another cell phone, does it. Using wifi in Airplane mode does work, too, but I could miss out on calls and text using that mode.

    Do I really have to just switch back to an old modem to fix it, or has anyone found another solution? We recently purchased a Belkin (which has the guest access option; our old Linksys didn't) and I would like to keep us on the same modem, however, this is driving me nuts.
    02-20-2015 12:26 PM
  21. gravitybear's Avatar
    Cole - I would hesitate to get a new router because it is a crap shoot. I got a new router and I am still having the same problem. The fact that we have been unable to diagnose the actual problems indicates that any new router you buy may (or may not) work.

    Also Cole, have you tried the following?:

    Disable IPV6 in your router (some have had success with this)
    Disable wifi security (if this works, see the post from simone moro to enable security with a static IP for your phone in this link: http://forums.androidcentral.com/sam...ml#post4238492 )
    Disable Download booster (settings/more networks)
    Disable smart network switch (in wifi advanced settings)
    Connect to router on the "guest network" (if your router has that setting available - this is a feature on newer routers)
    02-21-2015 04:36 PM
  22. timralex's Avatar
    To the OP and others:

    I have the same cablemoden (Arris - through TWC) and was having the same problem with my Galaxy S5 - slow access to google.com (regardless of browse used), facebook, google play, google maps, etc...). I was not experiencing this with any of my other android devices (Moto Droid RAZR MAXX, LG Spectrum, Galaxy Tab 3).

    The solution that worked for me was, under the "LAN Setup" tab, check the "Enable DNS Relay" box. For good measure, I also enabled the DNS Override and set them to 8.8.8.8/8.8.4.4. I don't know if it affects it, but I also have UPnP enabled.

    When I un-enable DNS relay, the problem comes back.

    Hope this helps.
    This seems to be the answer. It's fixed the issue for me so far.

    I've been dealing with this issue for so long. So annoying. Many thanks.
    02-22-2015 01:41 AM
  23. Ssilverhaze's Avatar
    I thought I had fixed this issue unfortunately it never is that easy. So, I have the Verizon S5, a Netgear WNDR4300, and Arris modem. My issue is a little bit weirder than the others. Whenever I connect my GS5 to my home wifi it is not only slow on my phone but it slows everyone else on the network down. I'll connect my phone and boom suddenly the internet on my PC slows to a crawl. The up and down arrows on the wifi symbol on the phone are constantly lit up always sending and receiving information. I restart the phone and the wifi symbol goes back to normal for awhile and the wifi on all devices including the phone is quick and fast for around an hour until it slows down again and I have to disconnect it from the wifi in order for my other devices to work properly. Iv'e tried every solution listed within this thread and beyond but I'll ask does anyone have any other ideas how to fix this. I'm hoping the 5.0 update for the GS5 brings a much needed fix but, since this issue has been a problem since 4.3 on the GS5 its unlikely.
    Exactly the same here, just got the s5 coming from a note 2, my girlfriends s3 works flawlessly with my home wifi as did my note 2 but the s5 screws everything up.
    The s5 disconnects my NAS server from the network, wich really makes me angry because i use XBMC in combination with Yatse remote over wifi -_- and just doesn't load what it has to in all the apps eg. browsing, facebook, app store and so on.
    i'm going to try the tips given on this thread, will update soon
    02-23-2015 09:59 AM
  24. Ssilverhaze's Avatar
    Third ****** reply i'm typing here, I can't post links because I don't have 10 posts...................
    Here I go again:
    I tried removing the sim card, that didn't work, then I went looking for the settings as mentioned above but couldn't find them the only notable settings I found can be seen here:

    postimg .org/image/6js8n0oc1/

    Tried forcing "dhcp server" - no luck so now i'm out of options.
    I'll go try the s5 at a friends wifi tonight and tomorrow i'll go back to the shop I got this from.
    And wow look at that I have to reboot my computer because my pc doesn't have an ip anymore! great phone! they should use the s5 in the army to disrupt enemy communications ffs

    Edit: been an half hour had to reset my modem because my pc couldn't connect to the network anymore not sure if this has anything to do with the dhcp settings but 1 thing is for sure the s5 is a phone from hell
    02-23-2015 10:35 AM
  25. Ssilverhaze's Avatar
    Called my isp and they told me to switch to 5ghz (if router supports it for anyone else) and that fixed everything
    02-23-2015 05:22 PM
79 1234

Similar Threads

  1. Strange Battery Usage Stats Lollipop
    By belodion in forum Google Nexus 5
    Replies: 17
    Last Post: 09-09-2016, 04:52 AM
  2. Have I bricked my Nexus 7?
    By TheCelestial in forum Google Nexus 7 Tablet (2012)
    Replies: 4
    Last Post: 02-24-2015, 08:52 AM
  3. HTC Desire 610 Voicemail notification problem
    By Emibonin in forum HTC Desire 610
    Replies: 1
    Last Post: 12-09-2014, 10:37 AM
  4. Nook app keeps stopping since Lollipop install. any info on fix?
    By Dennis Scullin in forum Android 5.0 Lollipop
    Replies: 2
    Last Post: 11-20-2014, 09:02 PM
  5. Replies: 3
    Last Post: 11-20-2014, 05:33 PM
LINK TO POST COPIED TO CLIPBOARD