01-26-2017 01:31 PM
43 12
  1. Derek Karnes's Avatar
    I voided my (useless) warranty and installed MOAR. Fixed all the problems and gave me a hundred tweaks, too. You can find it on the XDA_Developers forum. Not for the faint of heart.
    04-13-2015 08:43 AM
  2. steve4271's Avatar
    I had this issue as well.

    HTC One M7 running Android 5.02 on T-Mobile.

    I tried B Diddy's suggestion:"Go to Settings>Wi-fi, tap Menu>Advanced, and uncheck "Scanning always available."

    but this was already unchecked. Based on some of the other responses, I realized that there could be apps I recently installed that had the power to do this.

    Sure enough I checked the settings in Xfinity WiFi app and it does!

    If you are a Comcast/Xfinity customer and have the Xfinity WiFi app, go to Settings (left menu) and uncheck "Automatically choose best connection".

    Restart your phone.

    Since I did this, the problem has gone away.

    Thanks, droids!
    leehardballer12 likes this.
    05-30-2015 05:42 PM
  3. Derek Stevens4's Avatar
    i have the sprint samsung galaxy s4 and when i turn off my wifi it turns back on 2 seconds later please help me
    06-07-2015 11:27 AM
  4. Manuel Valdez's Avatar
    Same problem. Just got it this morning and it has so far ruined my day... need as much help as you

    Sorry can't offer you help. xD
    Galaxy note 3 on Android 5.0
    06-27-2015 04:13 AM
  5. STINGRAY86's Avatar
    This was my problem! Thanks. Avast says any update after 4.4.4 is buggy.

    06-27-2015 10:09 AM
  6. STINGRAY86's Avatar
    just forgot. Check first any anti-theft settings in your apps. That was the problem with avast.
    just fixed mine also. After the 5.0 update it started. The avast app states there are issues with anything past 4.4
    so i turned off the anti-theft for now. Thanks again!
    06-27-2015 10:14 AM
  7. Javier P's Avatar
    just fixed mine also. After the 5.0 update it started. The avast app states there are issues with anything past 4.4
    so i turned off the anti-theft for now. Thanks again!
    Glad it helped. Welcome to the forums!
    06-28-2015 05:15 PM
  8. Knuckelhed's Avatar
    Much thanks for this insight. I was having the same issue. Being an avast user and disabling Anti-theft settings fixed the issue. Being unable to turn off wifi was killing my batter. Again, thank you.
    06-29-2015 03:38 PM
  9. Tebzido's Avatar
    Thanks, Avast was the cause.
    10-22-2015 05:10 AM
  10. CloneSolutions's Avatar
    The problem is neither from android phone nor mobile/wifi carrier.
    One or more apps may have permission to turn wifi or data on/off.
    The solutions is to go in Settings/App and verify each app to see which one(s) has permission to connect to wifi/data.
    I did examine apps on my Android (4.4.2) phone. Boom Beach Game App was responsible for Wifi/data to keep switching on.

    The Solution:

    Force Stop the App causing the problem. In my case I Force Stop Boom Beach App.

    Note: There is no need to uninstall the app. Just Force Stop.


    11-09-2015 11:36 PM
  11. Superradliz's Avatar
    Try settings>more settings>mobile networks>automatic connections> then uncheck connection optimizer. Hope this helps. You probably resolved this by now
    This worked for me! Thx
    11-11-2015 11:48 PM
  12. Dhsarji's Avatar
    Just forgot. Check first any anti-theft settings in your apps. That was the problem with Avast.
    Thanks it worked after taking off Avast anti theft
    06-20-2016 01:26 AM
  13. Papa Joel's Avatar
    It worked! Thank you for your suggestion.
    08-31-2016 09:36 PM
  14. CEStanley's Avatar
    I found a workaround for Samsung's lacking control of the WiFi on my S5. Turn off WiFi and restart. When it comes back up, WiFi is off and does not scan.
    01-21-2017 05:11 PM
  15. CEStanley's Avatar
    In the Galaxy S5 WiFi, it is Samsung. Turn off WiFi and restart the phone. When it comes back up, WiFi will be off and not scanning.
    01-21-2017 05:13 PM
  16. CEStanley's Avatar
    My phone keeps turning WiFi on and connecting when I turned it off. Is there a setting I'm missing to make it honor my choice?
    01-21-2017 06:44 PM
  17. CEStanley's Avatar
    On my S5, if I turn off WiFi and restart my S5, the WiFi stays off.
    01-21-2017 06:45 PM
  18. anuj3212's Avatar
    Turn off the phone.
    Once the phone has completely shut down, press and hold Volume, Home, and Power buttons at the same time.
    Wait until the Samsung logo appears before releasing the Power button.
    Once the Android logo shows up, release the two other buttons.
    Wait for the Recovery menu to appear (may take up to a minute).
    Go to wipe cache partition option using the Volume buttons, then press Power button to confirm.
    Wait for the device to wipe the cache partition
    Once the cache has been deleted, Reboot system now option will then be highlighted.
    Press Power button again to confirm the reboot.
    01-26-2017 01:31 PM
43 12

Similar Threads

  1. Wifi problem
    By spridell in forum Samsung Galaxy Note Edge
    Replies: 5
    Last Post: 03-27-2015, 10:02 PM
  2. Replies: 41
    Last Post: 03-09-2015, 09:18 AM
  3. How do I turn this dictionary option off?
    By AlphaVictor87 in forum HTC One M8
    Replies: 1
    Last Post: 11-23-2014, 07:07 AM
  4. Live Weather Lock Screen with Location Off
    By varunaX in forum Samsung Galaxy Note 4
    Replies: 4
    Last Post: 11-21-2014, 03:40 PM
  5. Why won't my S5 accept calls?
    By ShirleyP13 in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 11-21-2014, 12:17 PM