01-26-2017 01:31 PM
43 12
tools
  1. japark's Avatar
    My phone keeps turning WiFi on and connecting when I turned it off. Is there a setting I'm missing to make it honor my choice?
    BrunoIsNotHere likes this.
    11-21-2014 10:42 AM
  2. B. Diddy's Avatar
    Is it turning on even while the phone is asleep? Or is it turning on as soon as you wake the phone up again?

    Go to Settings>Wi-fi, tap Menu>Advanced, and uncheck "Scanning always available."
    BrunoIsNotHere likes this.
    11-21-2014 11:15 AM
  3. japark's Avatar
    That option does not appear in WiFi -> menu -> Advanced

    WiFi turns itself on whenever I turn it off.
    BrunoIsNotHere likes this.
    11-21-2014 11:25 AM
  4. B. Diddy's Avatar
    This is always a bit difficult to figure out, since different devices can have different menu options. How about any kind of wi-fi optimizer? If there's one available, turn it off.
    11-21-2014 12:49 PM
  5. japark's Avatar
    Nope. Stsndard galaxy s5, Sprint, kitkat 4.4.4 .
    BrunoIsNotHere likes this.
    11-21-2014 01:00 PM
  6. ab304945's Avatar
    Go to settings>more connections> mobile networks>connections optimizer and uncheck it. See if that helps

    Posted via the Android Central App
    Superradliz likes this.
    11-21-2014 01:34 PM
  7. japark's Avatar
    Not checked.
    11-21-2014 02:32 PM
  8. Javier P's Avatar
    There are some apps that can do that. I read a similar problem a time ago and the culprit was Avast.

    If you have the patience you can check any possible culprit going to settings - apps and have a look at the permissions. It should have one saying "connect and disconnect from WiFi".
    Knuckelhed and TxHaas like this.
    11-21-2014 02:58 PM
  9. Javier P's Avatar
    Just forgot. Check first any anti-theft settings in your apps. That was the problem with Avast.
    B. Diddy and STINGRAY86 like this.
    11-21-2014 03:05 PM
  10. MrJK's Avatar
    Try settings>more settings>mobile networks>automatic connections> then uncheck connection optimizer. Hope this helps. You probably resolved this by now
    12-04-2014 07:16 PM
  11. colyn1353's Avatar
    That option does not appear in WiFi -> menu -> Advanced

    WiFi turns itself on whenever I turn it off.
    The correct path with the GS5 is settings-WiFi-tap the 3 dots in the upper right then pick advanced-then untick always allow scanning..
    12-04-2014 08:22 PM
  12. Kelly Kearns's Avatar
    I thought Sprint included a WiFi app like AT&T does.
    12-04-2014 10:31 PM
  13. japark's Avatar
    The correct path with the GS5 is settings-WiFi-tap the 3 dots in the upper right then pick advanced-then untick always allow scanning..
    I have tried every setting I can find. Nothing seems to work. I can turn WiFi off, but it will be back on in less than a minute, particularly if I am doing anything which involves data.
    younggreenanne likes this.
    12-05-2014 06:26 AM
  14. Kelly Kearns's Avatar
    Is there no Sprint "smart WiFi" app that comes installed on the phone?
    12-05-2014 09:15 AM
  15. japark's Avatar
    Is there no Sprint "smart WiFi" app that comes installed on the phone?
    I don't see such an app. Why would that help?
    12-06-2014 09:15 AM
  16. Kelly Kearns's Avatar
    I don't see such an app. Why would that help?
    It wouldn't help, it causes problems, like turning on WiFi or turning it off, and ignoring the settings you have.

    Most carriers, Sprint, Verizon and AT&T include them.

    Who is your carrier?
    12-06-2014 12:53 PM
  17. Derek Karnes's Avatar
    I, too, have this problem since the update. The problem, I think, is that Quick Connect won't stay off. Even if you kill it, turn it off, force stop it... it keeps coming back, and as soon as it does, the WIFI turns on. I made the mistake of going through Samsung support who talked me into a Factory reset, but the problem still persists.
    12-07-2014 10:15 PM
  18. japark's Avatar
    I wouldn't help, it causes problems, like turning on WiFi or turning it off, and ignoring the settings you have.

    Most carriers, Sprint, Verizon and AT&T include them.

    Who is your carrier?
    Sprint.
    12-08-2014 05:26 AM
  19. tcn9315's Avatar
    I recently switched from another carrier where I was using a Samsung Galaxy S5 with Lolipop and when I switched I got the same phone and updated it and was having the same issue of WiFi not cutting off. I had turned off the connection optimizer and everything and I could turn off WiFi but in a matter of a few minutes it would be back on and it was frustrating as all get out. I think I have found a fix and I did these simple steps and have been on the mobile network ever since but I can cut WiFi on and off when I want to now.

    Start your phone in Safe Mode. To do this restart your phone and when the Samsung logo comes up hold down the volume button. Once it boots (it should say Safe Mode in the bottom left corner) go to Settings>More Networks>Mobile Networks>Connections Optimizer. Once in the connection optimizer if it shows to be off turn it on and then back off or if it is on just turn it off. After doing this restart the phone in normal mode. This worked for me and I hope it will work for ya'll as well.
    japark likes this.
    02-27-2015 01:29 PM
  20. japark's Avatar
    I recently switched from another carrier where I was using a Samsung Galaxy S5 with Lolipop and when I switched I got the same phone and updated it and was having the same issue of WiFi not cutting off. I had turned off the connection optimizer and everything and I could turn off WiFi but in a matter of a few minutes it would be back on and it was frustrating as all get out. I think I have found a fix and I did these simple steps and have been on the mobile network ever since but I can cut WiFi on and off when I want to now.

    Start your phone in Safe Mode. To do this restart your phone and when the Samsung logo comes up hold down the volume button. Once it boots (it should say Safe Mode in the bottom left corner) go to Settings>More Networks>Mobile Networks>Connections Optimizer. Once in the connection optimizer if it shows to be off turn it on and then back off or if it is on just turn it off. After doing this restart the phone in normal mode. This worked for me and I hope it will work for ya'll as well.
    I tried that and so far it seems to have solved the problem. Thanks!

    Update. This helps but does not prevent WiFi from turning itself on.

    The only way I can turn it off and keep it off is with MacroDroid. You can create a macro which will turn off WiFi immediately when it turns on, effectively keeping it off.
    02-27-2015 06:50 PM
  21. Derek Karnes's Avatar
    Sent my phone back to Samsung 3 times. The first time they did a factory reset, the second time replaced. .. something. .. the third time the entire motherboard. Problem remains. Samsung says it has to be a sprint problem, so i took advantage of sprint's open period of sign up for equipment protection this month and will take it to the repair shop tomorrow.
    03-13-2015 10:11 PM
  22. Derek Karnes's Avatar
    Repair guy hung his head in sadness when I told him the problem. He said all the flagship phones are having the problem - root the phone and flash a custom rom, he can't fix it.
    I am appalled.
    03-14-2015 03:57 PM
  23. BR34KF4ST's Avatar
    i think lollipop has a bug that after you switch off flight mode it auto turns on wifi and i also notice that wifi connects slower compared to kitkat.any fix?

    Posted via the Android Central App
    03-15-2015 02:27 AM
  24. japark's Avatar
    Repair guy hung his head in sadness when I told him the problem. He said all the flagship phones are having the problem - root the phone and flash a custom rom, he can't fix it.
    I am appalled.
    I think the problem is that the phone companies want you to use WiFi instead of the cellular network. Phones now come with "WiFi calling" which is another way to switch traffic from the cellular network to a WiFi network.

    Have you noticed that your Internet provider doesn't try to prevent you from using the network, but your phone provider is constantly trying to find ways to limit your usage?
    03-15-2015 09:59 PM
  25. Derek Karnes's Avatar
    I think the problem is that the phone companies want you to use WiFi instead of the cellular network.
    I have them fooled, then. My only internet at home is a sprint Wi-Fi modem
    03-15-2015 10:10 PM
43 12

Similar Threads

  1. Wifi problem
    By spridell in forum Samsung Galaxy Note Edge
    Replies: 5
    Last Post: 03-27-2015, 10:02 PM
  2. Replies: 41
    Last Post: 03-09-2015, 09:18 AM
  3. How do I turn this dictionary option off?
    By AlphaVictor87 in forum HTC One M8
    Replies: 1
    Last Post: 11-23-2014, 07:07 AM
  4. Live Weather Lock Screen with Location Off
    By varunaX in forum Samsung Galaxy Note 4
    Replies: 4
    Last Post: 11-21-2014, 03:40 PM
  5. Why won't my S5 accept calls?
    By ShirleyP13 in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 11-21-2014, 12:17 PM
LINK TO POST COPIED TO CLIPBOARD