1. TheEms55's Avatar
    Alright, so I'm using a Verizon (SM-G900V) Galaxy S5 under a T-Mobile SIM. All cellular services work perfectly fine. Whenever I try to tether data/hotspot using the service in the Settings app, I get the message "Mobile Number not found."

    I recently was under Verizon services, and data tethering worked without any problem. Now that I'm on T-Mobile, tethering does not work at all. Tethering IS included in my T-Mobile data plan. I'm assuming this has to do with the application itself, yet I have tried other tethering apps to no avail.

    Does anyone have the answer or some insight?
    Thank you!
    11-28-2014 10:19 PM
  2. Rukbat's Avatar
    A TMobile store with techs (not all of them have tech support) will probably be able to tell you why - and maybe what to do to get it working.
    11-28-2014 11:23 PM
  3. AZgl1500's Avatar
    Most likely it will involve the APNs, one of them is most likely incorrect.


    I just reactivated a 4 year old Galaxy S and had to go through Tech Support.

    They had me enter a whole mess of *#12345 type numbers to access internal hidden menu items.
    Then we walked thru the complete setup, 1 step at a time.

    Took about 1.5 hours but they got it done.

    You have to call them from a different phone though.
    11-28-2014 11:33 PM

Similar Threads

  1. Tab Pro 12.2 won't turn back on
    By john23b in forum Samsung Galaxy Tab Pro 12.2
    Replies: 4
    Last Post: 01-20-2019, 10:31 PM
  2. Rmhd this year of kit kat update and Verizon security update
    By filmsquad in forum Droid RAZR MAXX HD
    Replies: 3
    Last Post: 12-03-2014, 02:43 PM
  3. stock recovery for tabpro 8.4 on 4.4.2
    By mashhud1 in forum Samsung Galaxy Tab Pro 8.4
    Replies: 3
    Last Post: 12-02-2014, 09:11 PM
  4. Replies: 2
    Last Post: 11-29-2014, 01:13 AM
  5. Can anyone help me with some Galaxy S4 Software problems?
    By Alex Mclane in forum General Help and How To
    Replies: 2
    Last Post: 11-29-2014, 12:23 AM
LINK TO POST COPIED TO CLIPBOARD