1. Justin DiNardi's Avatar
    Hey guys--

    I've been experiencing this problem for a while, and am now beginning to believe that it is not an issue of my SD card, but is an issue with the card reader in the phone itself... anyhow.

    My galaxy S5 fails Mount/Read/Write to any SD ever since I downloaded an OTA update (I do not believe that this pertains to the Android OS, but it was a Verizon update in it's own). afterwards, my phone failed to read the SD card.

    I was able to remove the SD card, place it in my PC and backup the files to the PC hard drive- formated the card, and tried to return it to the phone, though it continues to fail the mounting process.

    it will attempt to mount, then note that it is blank
    or
    it will attempt to mount, and say it is safe to remove
    or
    it will attempt to mount, and say it is blank, or the file structure is not supported
    or
    it will attempt to mount, and mention that the card is damaged.

    meanwhile, the card reads fine in my card reader on my PC.

    I caved, and bought a new card; the phone imediately gives me the same issue as above.

    I'm begining to believe that the OTA update may have corrupted the internal reader, however I am unable to find any consensus in forum browsing.

    has anyone experienced this issue in the past?

    your help is greatly appreciated!!!!

    Small update-

    before the OTA update, I was running a 64GB Sandisk class 10 card (which will no longer run).
    The card I bought to replace it was another 64 GB Sandisk class 10; again, it didn't even give it a chance to mount.

    however, I did just place my 1gb lesser class card in, and it read fine..

    would there be any reason why the S5 will no longer read a 64GB card? I mean, the second card was BRAND NEW and failed..
    12-05-2014 04:08 PM
  2. SpookDroid's Avatar
    Have you tried formatting it using ExFAT format? Or FAT32? (I'm not sure if you can format a 64GB card with FAT32 though...)
    12-05-2014 04:24 PM
  3. Justin DiNardi's Avatar
    I did just do that, and to no avail.

    here's another strange thing... I gave the 64GB card to my friend who also has a galaxy S5; it mounted on his phone without issue. I formatted it in his phone, and tried again in my S5, and no luck. mounted back into his phone without issue.

    both phones have the same OTA verizon update logs...

    so, I did a system reset on my phone itself- tried again with the 64GB card, and still no luck.

    I'm really confused as to why my phone will mount my 1 and 16 gb cards, but it will NOT mount either of my 64GB cards, even though my friends S5 will...
    12-05-2014 05:42 PM
  4. SpookDroid's Avatar
    Ummm... strange indeed :S But that might qualify for a warranty replacement if you can prove to them that your card works on other phones (which shouldn't be difficult at all).
    12-08-2014 10:28 AM

Similar Threads

  1. Replies: 4
    Last Post: 02-22-2016, 05:16 AM
  2. Why does my keyboard always load so slow whenever it tries to open?
    By albinoblacksheep in forum Ask a Question
    Replies: 2
    Last Post: 12-08-2014, 05:52 PM
  3. Replies: 18
    Last Post: 12-07-2014, 07:05 AM
  4. Replies: 5
    Last Post: 12-05-2014, 08:22 PM
  5. how to get rid of flip board
    By currentdroiduser in forum Samsung Galaxy Note 4
    Replies: 2
    Last Post: 12-05-2014, 04:01 PM
LINK TO POST COPIED TO CLIPBOARD