1. hjuliad's Avatar
    I tried to download an app on my Galaxy S5, but an error popped up that said "Google Play content is disabled for this domain. Please contact your domain administrator for more information." I don't know what that means and I've never had this problem before with any other apps.

    Is there a way I can disable the domain administrator to download the app? I've tried clearing data and caches on Google Play, restarted my phone, and updated Google Play, but that didn't work.

    Please help.
    12-08-2014 07:04 PM

Similar Threads

  1. Replies: 9
    Last Post: 12-13-2014, 03:21 PM
  2. Replies: 2
    Last Post: 12-11-2014, 02:29 AM
  3. Looked at Sticky have Question on best method to use
    By unklsckness in forum General Carrier Discussion
    Replies: 1
    Last Post: 12-08-2014, 08:32 PM
  4. How do I stop back ground mobile data in MOTO E?
    By Srinath J1 in forum Ask a Question
    Replies: 1
    Last Post: 12-08-2014, 07:20 PM
  5. Replies: 0
    Last Post: 12-08-2014, 04:44 PM