1. Ian Wood's Avatar
    It does it intermittently, and I suspect it's because the whole phone is lagging - too many little background things running I suppose.

    First, do others have this problem? Does anyone have more than a hunch as to whats going on?

    Second, assuming it's the lag problem (making a single press lag so long it seems like a long press), what are some strategies for clearing out less necessary tasks the phone is doing?
    12-16-2014 11:06 PM
  2. Tahoe916's Avatar
    I had this problem for awhile on both my s5 and tab s. I finally got so fed up I uninstalled a lot of my less important apps which showed as running in the background even after a restart. It's gone away, I figure one or more of the apps was lagging the system. It's really annoying that so many apps run in the background when you don't need them to, and no way for most of them to disable that behavior. You can use application manager in settings or a task killer program to find the apps that do this, reboot first and give it a little time.
    12-17-2014 01:44 AM
  3. Ian Wood's Avatar
    Thanks Tahoe, that's more or less what I figured. It's a bit sad that OS lag affects the measured time the home button is held down! And especially annoying that the google app itself seems to lag badly, so I can almost never go direct to the home screen from there ):

    Anyway, I found a temporary work-around for anyone else who runs into this: if you tap the task switcher button first, then the home button I found it goes to the home screen every time -- it lags getting to the task switcher (:
    12-18-2014 06:46 PM
  4. mary beth hale's Avatar
    Try disabling SVoice . That affects use of the home button. Long press on the home button should open Google Now. With SVoice disabled, the home button responds immediately. (for me)
    BerryBubbles likes this.
    12-18-2014 11:33 PM
  5. BerryBubbles's Avatar
    Hi!
    My home key always launches 'Google Now' with a long press.
    If I tap the home key, I'm fine, but if I linger, Google Now pops up.
    That's how it's setup (T-Mobile Carrier).
    It doesn't happen to me as much as when I first purchased the phone.
    I must be getting better at tapping versus pressing.

    Oh...Mary Beth beat me to the Google now, but I didn't know about the SVoice...Thanks!
    12-18-2014 11:39 PM
  6. kingkiller2's Avatar
    Stated happening to my phone and a friend's phone recently after the 4.4.4 update. Ready to run our phones over then chuck them at the AT&T store.
    02-11-2015 04:45 AM
  7. ryetronics's Avatar
    A simple restart fixed this on my AT&T 4.4.4.
    02-11-2015 06:56 AM
  8. sapperguy's Avatar
    I'm having the same intermittent issue. Already diabled S Voice and will try the quick tap instead of my normal tap to see if that helps. Wasn't a problem until a few days ago when I did (what I assume to be) the 4.4.4 update. I'm not that tech savvy so I don't know how to see if that's the update I'm running lol.
    02-11-2015 02:06 PM
  9. jjacobs's Avatar
    Having this same problem where when I use the home button to close out an app it will open a new search window instead. Different from the double press opening up a google now search.
    02-17-2015 09:00 PM
  10. Howard Benson's Avatar
    Posted on another site.... Try removing battery for 10 minutes... Mine was constantly going to Google Voice etc but this seemed to stop that. Alot of other peeps are having same problem in other threads.

    Posted via the Android Central App
    02-18-2015 07:53 AM
  11. PDXGlenn's Avatar
    I have AT&T Galaxy S5 and noticed this issue after updating to 4.4.4. I and others have fixed this by doing a "cold" reboot. Remove battery for at least one minute. Put battery back in, start up the phone and presto! Should take care of the problem. I don't believe that SVoice has anything to do with this. However, I have read that with SVoice activited by a double tap on on the Home Key, normal connection to the home page is slowed a few milliseconds, but this is not related to the issue under discussion in this forum. SVoice can be disconnected from the Home Key in the app's settings. Then SVoice is launched directly through the app only rather than using the Home Key as a shortcut.
    02-19-2015 03:54 PM
  12. Mpilot's Avatar
    I figured it out! Its something within the google search engine. If you change it to Bing, Yahoo, etc.....it reverts the home button back to home instead of Google search. Its a new function by google to find apps and songs quicker. For example, when it pops up if you type the first letter of an app, it will allow you to select it from there instead of searching through your pages. It was annoying at first but since I now know what its doing...its kind of cool. If it still annoys you, just switch search engines. When the search page pops up for Google, you can even scroll to the bottom, click on settings, and adjust when that search screen pops up. I hope this helps!
    02-26-2015 08:21 PM
  13. ZacAndre's Avatar
    Don't touch the screen click the home button and it will go home barely touching the screen and clicking the home button and it will go to Google I know it works with s5 don't know with other phones
    jjacobs likes this.
    02-28-2015 08:50 PM
  14. Jeremy Blakely's Avatar
    Don't touch the screen click the home button and it will go home barely touching the screen and clicking the home button and it will go to Google I know it works with s5 don't know with other phones
    03-02-2015 01:28 PM
  15. Jeremy Blakely's Avatar
    I had the same problem with my S5. I fixed it by trying a "hard boot". All you do is take the battery out while the phone is still on, then reinsert it.
    03-02-2015 01:30 PM
  16. Micah Livingston's Avatar
    I think I've got it. Next time it pops up, go to settings-phone search-and unclick all the buttons. Worked so far for me when nothing else did.
    03-04-2015 05:03 PM
  17. Tiffani Hatcher's Avatar
    Disable the app that says, "google." It's the search app. It's a blue square with the letter "G". Once it's disabled you will no longer have that issue. To disable simply hold down the app icon and move towards the top to "disable app". Works like a charm!
    03-07-2015 02:02 PM
  18. Brad Vandehei's Avatar
    I powered off, removed the battery for a minute and rebooted. Works great ... nothing easier. This way you don't have to disable the app if you use it.
    03-10-2015 10:50 AM
  19. HelloMegs's Avatar
    The only way to fix it permanently is to go into your app manager in your phone settings, scroll down to the Google app and then tap "uninstall updates". This will revert the Google app back to factory settings and you won't have to worry about that Google Now crap popping up when you hit your home button.
    03-12-2015 09:16 PM
  20. jjacobs's Avatar
    This is correct. You can touch somewhere on the screen and the home button and the search window pops up. Usually I am hitting the very edge of the screen and pressing the home button so the search pops up. If I am paying attention and just push the home button the search does not launch. Which is good as my next fix involved a hammer.
    03-15-2015 01:29 PM
  21. sirmaru's Avatar
    Thanks. That worked for me as well - just a simple restart and my Home button works again.
    03-16-2015 12:23 PM

Similar Threads

  1. Can we still move apps to SD card or no?
    By JnEricsonx in forum General News & Discussion
    Replies: 7
    Last Post: 12-26-2014, 10:10 AM
  2. Out of stock?
    By Gsxr151 in forum Samsung Gear S
    Replies: 18
    Last Post: 12-20-2014, 07:49 PM
  3. Replies: 0
    Last Post: 12-16-2014, 10:49 PM
  4. why are my videos uploading sideways on Instagram?
    By JaviEcko in forum Ask a Question
    Replies: 0
    Last Post: 12-16-2014, 10:34 PM
  5. Replies: 0
    Last Post: 12-16-2014, 10:14 PM
LINK TO POST COPIED TO CLIPBOARD