1. bigdog5's Avatar
    Turn off the Google app TalkBack, the icon is a big HAND orange and white colors. This app is causing an echo when you use your Galaxy S5. Problem was, you can't hear the echo yourself, but the person you talk to will complain about an echo. I would get the echo when I went to speakerphone, but other owners may have this issue on regular speaker too, I don't know, but just turn off the TalkBack app, it's interfering.

    Message to Verizon and Google, YOUR CUSTOMERS ARE TIRED OF BUYING PHONES WITH LOADED DOWN GARBAGE APPS. What is this? A PC? Time is money in this world and your customers should not have to waste their time working the bugs out of a $500 dollar phone.
    12-25-2014 02:26 PM
  2. mary beth hale's Avatar
    Thanks for the info. I was having the echo problem.
    12-26-2014 06:15 PM
  3. MobilrolaX's Avatar
    Bigdog5 (or anyone)- Can you explain exactly how to do this?

    My friend suddenly has the same S5 echo problem (caller hears echo when speakerphone is used). We went in the menus to "Settings" - "Accessability" and see that Talkback is off, but the problem remains.
    01-18-2015 05:25 PM
  4. bigdog5's Avatar
    Bigdog5 (or anyone)- Can you explain exactly how to do this?

    My friend suddenly has the same S5 echo problem (caller hears echo when speakerphone is used). We went in the menus to "Settings" - "Accessability" and see that Talkback is off, but the problem remains.
    I pull down the black notification area at the top. Then click the gear for Settings then Applications then Application Manager. Slide over to "ALL" and find Talkback. Click on that in the list and that gives you options for the App. Uninstall I think is the option. Some only give you Turn Off as the option.
    I also removed many other apps first, but Talkback was the last one before it finally worked. I found out on another friend's phone, it wouldn't work until I did a full restart. Turn off, turn on. Then it worked for him.
    01-18-2015 11:52 PM
  5. qbnkelt's Avatar
    Turn off the Google app TalkBack, the icon is a big HAND orange and white colors. This app is causing an echo when you use your Galaxy S5. Problem was, you can't hear the echo yourself, but the person you talk to will complain about an echo. I would get the echo when I went to speakerphone, but other owners may have this issue on regular speaker too, I don't know, but just turn off the TalkBack app, it's interfering.

    Message to Verizon and Google, YOUR CUSTOMERS ARE TIRED OF BUYING PHONES WITH LOADED DOWN GARBAGE APPS. What is this? A PC? Time is money in this world and your customers should not have to waste their time working the bugs out of a $500 dollar phone.
    Thanks for this information. I've found an annoying slight echo on speaker. Now I can fix it.

    Sent from my gorgeous sexy white BEAST of a Note 4 ❤
    01-19-2015 05:11 AM
  6. Mary Fry's Avatar
    BigDog5 Thank you for the fix! It worked! I have a new (2 weeks) phone and this echo just started yesterday....Do you know if this "talkback" is something that I need? Or what the heck it is for. I hope it just stays working with this app off.
    02-04-2015 04:48 PM
  7. bigdog5's Avatar
    Glad it worked for you. It's an app to help people with disabilities use their phone.
    02-05-2015 10:55 AM
  8. trixied's Avatar
    THANK YOU for saying that to Verizon!! I spent 2 hours at Verizon store over this echoing issue with my brand new S6. They tried to sell me a bluetooth box to put on my visor in my car...., then they had me talk with someone in India on the phone with a bad connection, who couldn't solve my problem (of course)...., and I finally left with them telling me to "contact the manufacturer"!! I said, "that's why I came to you! I bought this phone cash from you 2 days ago!!" Anyway, I just deleted that TalkBack program, and will make a call in a bit to see if it works. (I can't call anyone now because I've called everyone and their mother over the last two hours, and I don't want to bother anyone!) Thumbs down to Verizon, grrr!
    05-05-2015 03:01 PM
  9. andoc's Avatar
    HELP!!!!!

    I have a Samsung Galaxy S5. Disabled the Talkback icon. Hasn't fixed the speakerphone echo problem for the person receiving on the other end of the call.

    Also, in the last 48 hours, even my regular calling when I hold the phone to my ear to call someone has started producing an echo for the person receiving when they speak.

    What the $@#% is going on????

    Samsung sort this out please

    Any help greatly appreciated. Cheers
    07-06-2016 05:23 PM
  10. andoc's Avatar
    UPDATE:

    Noticed if I take it out of it's INCIPIO protective case - the new echo on the normal talking disappears for the person receiving ... however ....

    Even with the TALKBACK App disabled the speakerphone echo still persists???

    And of course... the new echo problem with the case on still persists???

    HELP!
    07-06-2016 05:44 PM
  11. andoc's Avatar
    Anyone?
    07-09-2016 05:35 PM
  12. Eric Starr's Avatar
    I cannot find anything labeled "Talkback" under App Manager. Tons of other stuff I'll never use though... I have a Samdung S5 Galaxy phone, and the speakerphone is practically unusable. Every time I use it, the person on the other side complains about "echo" and poor sound. I did remove the "Otter" case that came with the phone, it improved the sound but not by much. Am really thinking of changing phones now, as I really need the speakerphone for my work. I refuse to consider anything Apple, so I don't know what else to do. This was my first "smart" phone, but as a phone, it is the worst cell I have ever had. Any ideas? I hate this thing!
    10-12-2016 10:22 AM
  13. GlenStaker's Avatar
    When you went to Application Manager, did you scroll across to "ALL" ??? There are 4 tabs, DOWNLOADED , SD CARD, RUNNING and ALL
    01-24-2017 05:02 AM
  14. csf56's Avatar
    I have struggle with this problem on my "wired headset " only. The other side hears their voice ECHO, sounds good on my end. The handset or speaker do NOT have this echo issue.

    The only viable solution I have found is to turn the speaker volume down. The other side echo goes away, unfortunately I now have a hard time hearing in the lower volume setting.


    Not a perfect solution.
    02-10-2017 05:34 PM
  15. N6a6ta6s's Avatar
    Solved echo problem. The battery on my galaxy s5 was slightly swollen, pushing the cover out. If you look at the back cover there is a gasket or seal whichever. The battery pushing out keeps it from sealing. So just get a new battery.
    03-31-2017 12:31 PM

Similar Threads

  1. Replies: 4
    Last Post: 02-18-2015, 01:47 PM
  2. Are there any Android App Development Tutorials online?
    By Aarictue in forum Android App Inventor
    Replies: 1
    Last Post: 12-27-2014, 10:49 AM
  3. Samsung s5 no easy mode icon in settings
    By driller212 in forum Android 4.4 KitKat
    Replies: 0
    Last Post: 12-25-2014, 01:28 PM
  4. How do you screen shot on a Samsung Galaxy Ace Style
    By Mary Reid in forum Ask a Question
    Replies: 2
    Last Post: 12-25-2014, 01:16 PM
  5. Can I text with my Samsung Galaxy S Tablet?
    By momkarbo in forum Samsung Galaxy Tab S 10.5
    Replies: 1
    Last Post: 12-25-2014, 12:21 PM
LINK TO POST COPIED TO CLIPBOARD