1. TheMassDestructer's Avatar
    Hi, My Samsung Galaxy S5 (SM-G900i) rooted, has encountered a problem. Every time I plug it in to the computer it picks it up... but comes up as "SAMSUNG_Android" rather than "Leo(Galaxy S5)" and I can't access the files. It doesn't even show up in "My Computer". Please help I've been trying to fix this problem for 4 hours! Thanks, Leo.
    Update: I just recently tested the cable with my brothers S4, it seems to pick his phone up and everything... So I have a really good feeling it has nothing to do with the 2.0 Cable.
    Update: Don't worry! I figured it out. It was quite simple actually. All I had to do was do a hard reset.
    12-28-2014 06:36 AM
  2. Golfdriver97's Avatar
    Welcome to the forums. Have you updated the drivers for your PC? Drivers can be found on Samsung's website.
    12-28-2014 09:22 AM

Similar Threads

  1. How do I get his unknown notification icon to go away?
    By miguelmaracas in forum Ask a Question
    Replies: 10
    Last Post: 12-29-2014, 11:09 PM
  2. Replies: 3
    Last Post: 12-28-2014, 06:20 PM
  3. How do I recover my password on my Galaxy S4 mini?
    By gkari in forum Ask a Question
    Replies: 5
    Last Post: 12-28-2014, 12:44 PM
  4. Why is my Samsung S4 bottom bar missing?
    By joosey in forum General Help and How To
    Replies: 1
    Last Post: 12-28-2014, 02:34 AM
  5. Why is my Galaxy S4's battery so bad?
    By JVDang in forum Hardware Hideaway
    Replies: 3
    Last Post: 12-28-2014, 02:01 AM
LINK TO POST COPIED TO CLIPBOARD