1. voodooshama's Avatar
    Hello everyone, struggling with this right now. My wife & I both have Galaxy S5's, each have tablets & my son has iPad, also have a laptop that all connect to WIFI to internet no problem - EXCEPT MY GALAXY S5. I don't understand what is going on. I have gone into my router, can see the phone there in the list of connected devices. Checked to see if the phone was blockedIt seems that my wifi on my phone is connecting to the router, then off, then on, then off. Sometimes it connects for like 10 seconds, then I can open a page, then it wont go again.

    Is there a way I can go into my application manager on the phone & force stop the wifi or delete the cache on the wifi? it is clear that the issue is on the S5's end.

    PLEASE somebody help! Thanks in advance.
    02-09-2015 01:52 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Did your S5 recently update to Lollipop? There's a common glitch involving the Smart Network Switcher. Go to Settings>Wi-fi, tap Menu>Advanced, and turn off Smart Network Switch.
    02-09-2015 02:54 PM
  3. CMwojno's Avatar
    I am having the same issue described, but the 'Smart network switch' is off. I have also tried forgetting the connection and re-entering the password and ID, nothing is working. This is an S5 issue as it say's it connects to multiple wifi's but I am not getting access to the internet. I previously did not have any issues. I only recently questioned my inability to gain internet access.
    04-09-2015 01:36 PM
  4. Johnny Chan1's Avatar
    I have the same issue after the Lolipop 5 upgrade. It was working fine before the upgrade. Forgetting the connection and re-connect doesn't help. I tried static IP setup and it doesn't work as well. Even tried wipe the cache partition and it didn't work out as well.
    04-24-2015 09:59 PM
  5. memomz1's Avatar
    Had the same problem- connected to wifi but couldn't connect to Internet- and this fixed it: go to settings - select Backup and reset - select Reset settings - this will not remove data or apps but you will need to reconnect to wifi with your password. Verizon and Samsung couldn't help me and as a last resort I was going to factory data reset it which removes everything... glad I chose the other option. Good luck!
    andsoweflow, luiswatts and Spin57 like this.
    04-28-2015 02:00 AM
  6. Kamrud's Avatar
    You are my Hero! That was really getting irritating.
    08-09-2015 10:33 AM
  7. Justin Coleman2's Avatar
    Had the same problem- connected to wifi but couldn't connect to Internet- and this fixed it: go to settings - select Backup and reset - select Reset settings - this will not remove data or apps but you will need to reconnect to wifi with your password. Verizon and Samsung couldn't help me and as a last resort I was going to factory data reset it which removes everything... glad I chose the other option. Good luck!
    I am having the same trouble, but I don't have the option of reset settings.
    09-21-2015 09:20 PM
  8. HookUp31's Avatar
    I solve it by changing to static ip but changing the last three digits of the ip #. There was a conflict with two devices using the same ip and none of them worked.
    10-22-2015 04:34 PM
  9. brackenmakay's Avatar
    It could have been a router issue. Maybe you just have an old router and may need to update. I had the same issue but I fixed it by restarting my phone and it worked afterwards. Also it helped for me to disable Mobile data before accessing wifi.
    10-23-2015 02:44 PM
  10. luiswatts's Avatar
    Thank you I tried everything. This worked.
    11-20-2015 01:50 PM
  11. snawaf01's Avatar
    same thing if u solve the issue pls let me know
    i bout this new router setup
    its working my pc and brothers phones all are connect but mine its an samsung s5
    (I don't have the option of reset settings.)
    01-02-2016 07:02 AM
  12. bennerebe's Avatar
    Having the same problem. I also do not have the option to just "reset settings". I was having some other issues and just did a factory reset 5 days ago... me thinks it's time for a new phont
    01-04-2016 08:54 AM
  13. crumb's Avatar
    I solve it by changing to static ip but changing the last three digits of the ip #. There was a conflict with two devices using the same ip and none of them worked.
    This was my problem. I just needed to set the router to give me a static ip address.
    01-05-2016 05:52 AM
  14. bdnremtp's Avatar
    Reset settings worked for me, I had to reboot the phone first though.

    Posted via Android Central App
    01-06-2016 11:11 PM
  15. Spin57's Avatar
    Thank you memomz1, this worked perfectly for me. You rock!!
    02-09-2016 11:10 PM
  16. Madhu Akash's Avatar
    if u r using a usb wifi device first go to network and sharing center and click on wifi adapter and then click properties then click on configure and ill see and wireless mode on down click on that and change it to IEEE 802.11B DO NOT CHANGE TO ANY OTHER SETTINGS
    02-12-2016 10:08 PM
  17. anacortesjim's Avatar
    Having the same problem. I also do not have the option to just "reset settings". I was having some other issues and just did a factory reset 5 days ago... me thinks it's time for a new phont

    I had this issue on my work G5 and my personal G5. My data charges were costing me a fortune since I couldn't connect with WIFI. They would connect to networks, but with no internet connectivity.

    It ended up being a problem with Chrome. I had to update Chrome on both phones with latest updates and the issue stopped.

    You can go to Google Play, click on horizontal lines on top left, then "my apps and games". You will see a button to update all and you should click that. You will have to click update on each window that pops up then and when you are done your phone should be fixed.

    I'm surprised that Verizon seems to have no idea about this common issue.
    05-20-2016 10:31 AM
  18. Viital The Gamer's Avatar
    Thanks!! I do not know how to thank you cause today i dropped my phone accidentally and was super scared cause it would have been my third broken phone
    07-14-2016 01:49 AM
  19. humagwa's Avatar
    No, the previous is not my response. I meant to ask if the factory reset did work or not. I am having the same problem of wifi connection without internet access.
    09-22-2016 09:45 AM
  20. rvvagabond's Avatar
    FYI, reset settings did the trick for me. Problem started right after the most recent Samsung update.
    12-11-2016 01:19 PM

Similar Threads

  1. How to use two wechat apps on one phone
    By kaptanp3 in forum Android Apps
    Replies: 6
    Last Post: 04-15-2016, 06:31 AM
  2. problem i want help please
    By HairCare Doha in forum Samsung Galaxy S3
    Replies: 4
    Last Post: 02-09-2015, 11:01 PM
  3. Replies: 3
    Last Post: 02-09-2015, 11:10 AM
  4. How do I fetch data from a server into an app?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 02-09-2015, 12:52 AM
  5. Replies: 0
    Last Post: 02-09-2015, 12:04 AM
LINK TO POST COPIED TO CLIPBOARD