1. V301's Avatar
    I recenetly just bought the Galaxy S5 and its working great. But for some reason when I try to add the twitter widget to the home screen or any of the screens I get the message "application not installed." This is only happening with twitter. I've tried uninstalling and re-installing the app but same message. I did a factory reset as well but no luck. The application itself works if I go through the app itself. Any clue how to reslove the issue?
    02-17-2015 09:40 AM
  2. SpookDroid's Avatar
    Is your app installed on your phone or on the SD Card? If the latter, that might be the problem (widgets won't work if the app is installed in SD Card).
    02-17-2015 12:12 PM
  3. V301's Avatar
    Just checked and not installed on the SD card.
    02-17-2015 01:12 PM
  4. V301's Avatar
    No one else has this issue? Or that no one has a solution?
    02-19-2015 09:03 AM
  5. ntvtxn's Avatar
    SD storage would've been my first suggestion, but you confirmed that's no the problem.

    Found a list of possible solutions at Hovatek blog. Credit goes to them.

    • Reboot the phone: Rebooting the Android phone could help clear OS errors that might have occurred.
    • Check the SD card for errors and fix if required ( See How to fix / repair corrupt memory card, SD card or USB drive ).
    • Format the SD card: In extreme cases, move the contents on the memory card to a different location then format it.
    • Wipe the phone: In extreme cases, wiping the phone could resolve this issue. You could either do a factory reset under Settings or data / factory reset in recovery mode.
    • Ensure to uninstall unneeded apps to create space. Uninstall any apps you don’t need. (See this experimental post on How to increase primary partition (internal storage) on an MTK (like Tecno) Android )
    • Double-check the apk file: Check to be sure the apk file was properly copied / downloaded and is the correct size.
    • Reset permissions: Try resetting app permissions (Settings > Apps > All > Menu key > Reset application permissions )
    • Uninstall any previous versions on the same app currently installed on the Android phone.
    • Change Installation location: You could toggle application install location between phone memory, SD card and automatic.
    • Ensure that the SD card in not mounted / connected to a PC
    • Avoid installing unsigned apks or changing apk file names prior to installation.


    Hope one of these solves the problem.
    02-19-2015 09:14 AM
  6. randomdude's Avatar
    No one else has this issue? Or that no one has a solution?
    i'm having the exact same issue. can't figure it out.
    02-19-2015 09:46 AM
  7. randomdude's Avatar
    SD storage would've been my first suggestion, but you confirmed that's no the problem.

    Found a list of possible solutions at Hovatek blog. Credit goes to them.

    • Reboot the phone: Rebooting the Android phone could help clear OS errors that might have occurred.
    • Check the SD card for errors and fix if required ( See How to fix / repair corrupt memory card, SD card or USB drive ).
    • Format the SD card: In extreme cases, move the contents on the memory card to a different location then format it.
    • Wipe the phone: In extreme cases, wiping the phone could resolve this issue. You could either do a factory reset under Settings or data / factory reset in recovery mode.
    • Ensure to uninstall unneeded apps to create space. Uninstall any apps you don’t need. (See this experimental post on How to increase primary partition (internal storage) on an MTK (like Tecno) Android )
    • Double-check the apk file: Check to be sure the apk file was properly copied / downloaded and is the correct size.
    • Reset permissions: Try resetting app permissions (Settings > Apps > All > Menu key > Reset application permissions )
    • Uninstall any previous versions on the same app currently installed on the Android phone.
    • Change Installation location: You could toggle application install location between phone memory, SD card and automatic.
    • Ensure that the SD card in not mounted / connected to a PC
    • Avoid installing unsigned apks or changing apk file names prior to installation.


    Hope one of these solves the problem.
    can you tell me how i can change the installation location?
    02-19-2015 09:51 AM
  8. Otieno Wycliffe's Avatar
    i also have the same issue with my tecno p5s. android version kit kat 4.4. the sim tool kit app is completely dead. if you touch it a message of APP IS NOT INSTALLED pops up. eve the mobile network setting is empty. i rebooted the phon but no help. i tried flashing it but it cannot be flushed. please help.
    07-16-2015 04:22 AM
  9. Stratman71's Avatar
    Knowing this is an old thread, this solution may help others that stumble on it through a search like I did. As the above post stated:

    "Change Installation location: You could toggle application install location between phone memory, SD card and automatic."

    Easy way to do this For rooted users: Using the free version of Link2sd on the play store, select menu, settings, and under "native a2sd" change the default storage location from automatic to internal. Tada!
    10-03-2015 08:50 PM
  10. sschatz's Avatar
    I made an application with one more permission and when some clientes decided to downgrade the app this message appears "application not instaled" .
    If I upgrade the app with some other version that contains the same permissions or more permissions, no problem.
    So the problem is that Android don't let the application be installed with less permissions, at least in my Samsumg Galaxy Tab Lite.


    I hope this could help someone..
    11-17-2015 05:22 AM
  11. boss6000's Avatar
    I've unchecked using name space option in supersu, that's work again!!
    02-24-2017 03:17 AM

Similar Threads

  1. Replies: 1
    Last Post: 02-19-2015, 02:10 AM
  2. Can't access the Recovery I installed!
    By CrazycopsCP in forum Samsung Galaxy S3 Rooting, ROMs, & Hacks
    Replies: 4
    Last Post: 02-18-2015, 10:39 AM
  3. Why is my Google Play store hanging?
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 02-18-2015, 10:03 AM
  4. Replies: 0
    Last Post: 02-17-2015, 08:56 AM
  5. Replies: 0
    Last Post: 02-17-2015, 06:11 AM
LINK TO POST COPIED TO CLIPBOARD