09-10-2016 07:08 AM
28 12
tools
  1. _cmx_'s Avatar
    Is anyone else having this issue? I use ##3424# and get the option to set Qualcomm USB Settings and enable DM + Modem + ADB. I then plug in the usb cable to the pc and it does not connect to the phone on any of the ports. Adb does not show the device or anything. If I enable MTP + ADB, then adb shows the device fine and the mtp shows the card + phone just fine. Is there something else that needs to be done to enable DM for Lollipop 5.0?
    Mohammed Ahmed17 likes this.
    02-21-2015 09:28 PM
  2. Rukbat's Avatar
    For adb to work, you have to be in Download mode. Starting in normal mode shows MTP, which is not what adb is looking for. From power off, Volume Down+Home+Power. When you get to the next screen you have a choice of canceling or going into download mode. Go into download mode.

    Type

    adb devices

    on the PC's command line in the adb folder, and you should see a phone listed.
    02-22-2015 01:11 AM
  3. _cmx_'s Avatar
    Well, ADB works fine in the MTP + ADB mode already. What I'm trying to do is get access to the diagnostic port for CDMA Workshop access.
    02-22-2015 07:12 AM
  4. Rukbat's Avatar
    It's been so long since I had a CDMA phone that I don't recall how CDMA Workshop accesses the system, but if adb can access it, then the port is working, so try Odin mode.
    02-22-2015 11:53 PM
  5. _cmx_'s Avatar
    It uses the diagnostics port. When you enable DM + MODEM + ADB in the qualcomm settings. Usually the phone has 3 drivers that are loaded into the control panel device manager. 1 listed under modems, 1 is listed for the ADB connection and 1 is listed under ports for the diagnostics mode driver. Just when I enable DM + MODEM + ADB, none of them connect to the pc at all. I'd assume there is some new protection inside Android 5.0 Lollipop that is disabling them.
    02-23-2015 12:54 PM
  6. yo29570's Avatar
    Hi,

    i have the same issue with my sm-g900f samsung S5. I enable this port to work with xcal or NiXt. Currently i'm stuck after upgading to lollipop.
    If you have more info about it, please share. thanks

    regards
    02-27-2015 09:49 AM
  7. _cmx_'s Avatar
    Unfortunately I haven't found out the issue, I'm thinking about downgrading back to 4.4.4 as I've read somewhere that this is possible.
    03-01-2015 05:30 PM
  8. Jedimaster_Z's Avatar
    Has anyone found a way to enable Diagnostic ports on Lollipop 5.0 on the Galaxy S5 ? after the update this feature does not work.
    03-03-2015 01:56 PM
  9. yo29570's Avatar
    i contact samsung support that ask me to send back my phone to a shop (which i know by the way) that will send it back to factory... i'm abroad and i need it for my work. They also told me that they will solve this issue in the future (which i doubt; the guy on the phone did not have any clue about my request) Samsung support as bad as usually...

    normally to enable this DM port, you can access the menu with *#9090#. now it says DIAG config : not support

    also you can access the configuration, doing the following :

    Type: *#0011# to enter Service Mode
    Once in Service Mode, do the following:
    Tap the menu button and tap Back
    Tap the menu button again and select "Key Input" and enter an upper case Q and press OK
    Tap the menu button again and select "Key Input" and enter 4 zeroes (0000) and press OK
    Wait 5 to 15 seconds. You'll see the Main Menu
    Choose option [2]: UE SETTING & INFO
    Choose option [1]: SETTING
    then [9] next page
    [1] diag control

    but still, no access anymore. maybe you have more chance
    parin likes this.
    03-04-2015 11:42 AM
  10. _cmx_'s Avatar
    I ended up downgrading the phone back to 4.4.2 and the diagnostics port works fine. Just no more lollipop
    03-06-2015 12:32 PM
  11. Francpos's Avatar
    What version of 4.4.2 exactly? I'm trying to get back my diagnostic port too on the same phone, and I just cant get it it seem
    03-07-2015 09:02 PM
  12. amotab's Avatar
    I DID IT!

    in fact i did two things don't know which one worked. i had samsung galaxy s5 sm-g900w8 on lollipop 5.0
    after *#0808# i selected dm+modem+adb but nothing showed up in computer using windows 7
    tried all combination but nothing worked.
    then i did these two steps and it showed up and i was able to unlock it using furious gold
    1. put in recovery mode by holding vol up + home button and power on
    from the menu choose "enable cp"
    phone will start
    2. while phone is connected via usb to computer, go to *#0808# and select the option and press "reboot"

    when it reboots, your pc will recognize it

    i think first step is not necessary but i can't confirm as i don't have another phone to test

    let us know if it helped. thanks


    EDIT: first step is the real step. did with one more phone and worked fine
    04-28-2015 05:26 PM
  13. yo29570's Avatar
    sorry for my late answer. My csc is SEB and i went back on the previous version
    PDA : G900FXXU1ANJ1
    CSC : G900FOXX1ANJ2
    04-28-2015 05:43 PM
  14. yo29570's Avatar
    i also did that 2 days ago. I ended up by upgrading with the last available lollipop version for my CSC (SEB) because i wanted to try this CP logging which was not available on 4.4.2
    PDA : G900FXXU1BOC7
    CSC : G900FOXX1BOC2

    i did the same procedure that you applied and it also worked, i was able to log RF logs with NiXT and Xcal using DM+RMNET+MODEM
    04-28-2015 05:46 PM
  15. Esfera's Avatar
    Thanks Amotab... you solution it´s works fine... now unlock N910F and G900F with lollipop 5.0.1 and not problem.

    Very thanks
    05-06-2015 12:32 PM
  16. paras patel2's Avatar
    If you phone not support *#9090#
    then go to refectory reset mode by parsing home+volum up +power
    then enable the cp mode. Now you can unlock the phone
    06-10-2015 01:10 PM
  17. nwphone's Avatar
    I do not see that option in recovery mode 'enable cp mode' I've got SM-900T. Please advise.
    06-21-2015 04:11 PM
  18. sdarfp's Avatar
    I have S5 sm-g500v with lolipop. No codes work when dialed such as *#0808# are there instructions on how to enable rmnet+dm+modem mode ?
    06-22-2015 05:28 PM
  19. Kee Bre's Avatar
    I have the same problem as sdarfp ... any news on a fix please? thank you.
    06-23-2015 02:14 PM
  20. Douglas Funkler's Avatar
    Actually, the first step about cp_logging is the key to the problem.
    By the way, you helped me a lot.
    Thanks, amotab!
    09-20-2015 11:31 PM
  21. simonwu1's Avatar
    I have exactly the same phone with Lollipop 5.0. But when I get into recovery mode, I don't see "enable cp".

    Any help is appreciated.

    Thanks,

    Simon
    10-06-2015 10:45 AM
  22. ThePcMacGuy's Avatar
    Samsung Galaxy S5 SM-G900P Sprint lollipop 5.0 BOG1
    I enabled CP Loging in Recovery mode once it rebooted
    in dialer use ##366633# / ##3424# <> Enable DM Mode <> DM Mode gets enabled.
    now it works fine
    Now i was able to do domestic unlock with new cert
    12-01-2015 02:56 PM
  23. tdbone1's Avatar
    i have sm-g900r7 (C-Spire galaxy s5) on lollipop
    with stock recovery and rom i power off
    vol+up+home and boot to recovery.
    i see "Enable CP Logging" so i select it and reboot to system
    on dial pad i enter *#0808# and i then select "DM+MODEM+ADB" and all works perfect

    when i flash TWRP 2.8.6 kltespr i have NO option to "Enable CP Logging" so i boot to home screen
    on dial pad i enter *#0808# and menu works and i see "dm+modem+adb" so i select
    IT DOES NOT WORK
    i dial ##366633# and i see "Enable DM Mode" is check on already.
    in settings>about i select "Build Number" 8 times and it enables secret developer options
    in settings>developer option usb debugging is enabled.
    still does not work.

    only way for Diagnostic Mode to work is with stock recovery and select enable cp logging in stock recovery menu

    there has to be a way to enter a command in twrp to enable cp logging and reboot.
    if not twrp can i enter command in adb or terminal emulator?

    thanks and this is important as i think the note 4 and galaxy s5 use that enable cp logging in the stock recovery menu.
    with twrp no option
    01-15-2016 01:49 AM
  24. hoon531's Avatar
    Thank you. I had same problem and I did everything like downloading new samsung Drivers, power recycle on phone
    and computer and factory reset. Nothing worked until I tried this..
    03-05-2016 07:26 PM
  25. URVISH GANDHI's Avatar
    can you help me with unlocking g900A using chimera?
    08-30-2016 12:41 PM
28 12

Similar Threads

  1. Can I download apps on my laptop then transfer to my tablet?
    By AC Question in forum Ask a Question
    Replies: 4
    Last Post: 03-01-2015, 09:46 AM
  2. Will a factory reset downgrade from Lollipop to KitKat?
    By AC Question in forum Ask a Question
    Replies: 5
    Last Post: 02-25-2015, 11:49 PM
  3. Replies: 1
    Last Post: 02-23-2015, 12:53 AM
  4. Why don't Large .wav files appear when I connect to a pc?
    By dboundscpa in forum Motorola Droid Turbo
    Replies: 1
    Last Post: 02-22-2015, 01:34 AM
  5. Is anyone having issues with the Lollipop upgrade?
    By Myrna Rivera-Plotsky in forum Android 5.0 Lollipop
    Replies: 1
    Last Post: 02-21-2015, 08:45 PM
LINK TO POST COPIED TO CLIPBOARD