1. MThomas1981's Avatar
    Not sure how to go about fixing this, but ALL the apps I had "moved to SD Card" are now toast.

    App manager lists the entries as filenames, the icons are semitransparent generic android icons, it tries but fails to load the apps and google play says its not installed.

    The data is all on the SD card so i'd like them all back, it seems the OS (when it updated) simply forgot them when it optimized my apps for lollipop.


    You HAVE to move apps to the SD card cuz these phones come with next to no built in storage. What a screwup.

    I manually updated google play services and restarted the phone four times. I had to uninstall a chat app and it took fifteen minutes.
    After that fourth restart, all my apps appear to have been reinstated.

    Thank god, I don't know what i'd do if I lost my boom beach.

    Can anyone explain what happened?
    03-28-2015 10:05 AM
  2. systemofadown1's Avatar
    Rukbat can better explain this
    I'll give it a go
    when you move apps to the SD card you're only moving a little bit of that app data to the SD card not the entire app. when you updated that caused the trouble.
    ironass likes this.
    03-28-2015 10:53 AM
  3. ironass's Avatar
    See #2.4 of S5 Lollipop Update Problems - Dummies Guide written last year.
    systemofadown1 likes this.
    03-28-2015 01:13 PM
  4. Rukbat's Avatar
    See #2.4 of S5 Lollipop Update Problems - Dummies Guide written last year.
    Or just move the apps back to the phone, update, then move them to the SD card.

    (The update assumes - since that's how Android is written - that it has to save all apps in internal storage. It doesn't save symlinks to blocks on the SD card, since that's a trick that Android isn't supposed to see [but it's how apps can be "moved" to the card].)
    ironass and systemofadown1 like this.
    03-28-2015 04:03 PM
  5. tanamarn's Avatar
    This is an old thread, but I've had this problem in the past and recently found a solution.
    Go into Setting / Storage and unmount the SD card. This may take quite a while so be patient. After its finally unmounted, mount the SD card again. Then restart your phone. The apps on the card will initially still be grayed out, but will change to clickable links within a minute.
    I've had this problem with the last few upgrades, but it's worked for the last two. I hadn't figured a solution for the one previous to those two and reinstalled all the apps!
    01-08-2016 01:41 PM
  6. Princess_Ways's Avatar
    I did this and my apps aren't even gray on the screen. And my SD card says no apps. What do I do? ๐Ÿ˜ข๐Ÿ˜ข๐Ÿ˜ข๐Ÿ˜ข๐Ÿ˜ข๐Ÿ˜ข๐Ÿ˜ข
    07-23-2016 01:26 PM
  7. Princess_Ways's Avatar
    I did that and my apps aren't gray on my screen and My SD card says no apps
    what do I do? ๐Ÿ˜ข ๐Ÿ˜ข ๐Ÿ˜ข ๐Ÿ˜ข ๐Ÿ˜ข
    07-23-2016 01:27 PM
  8. Princess_Ways's Avatar
    So what do we do about it?
    07-23-2016 01:29 PM
  9. Daniellesamis's Avatar
    So what do we do about it?
    Did you go to Storage and mount the sd card again. It took many attempts to unmount, like the above commenter said it would - and suddenly all the apps were gone. After I mounted it again I restarted, maybe a couple of times, then the apps were all back. I had to arrange my icons a bit, but it was all fixed. Thanks. I hope it works for you soon Princess_ways.
    07-24-2016 03:22 AM
  10. Stacey Canavan's Avatar
    I've bought g3 for my birthday month ago and there hasn't been a day I didn't have a problem! Finally I thought I got everything under control moved apps to formatted SD card to have more space and set everything to be happy as its all been gone! What the hell is going on with this... Android??? Have no patience left any more!!! Can anyone tell me please what to do not to have problems all the time with this android endless updates, which only makes everything worse and how to get back my apps ?? Please!?
    11-08-2016 12:38 PM
  11. galfaqih's Avatar
    tanamarn is right on. Just got the latest update which lost the link to all apps on the SD card. I unmounted the SD card, waited for confirmation, remounted the SD card and restarted the phone. It took a few minutes for all the links to be restored, but they were.

    Kudos and thanks to tanamarn! That saved me a ton of time!
    02-28-2017 06:50 AM
  12. awr1090's Avatar
    I didn't have your specific upgrade but am assuming this issue has to do with android still not just your particular upgrade. mthomas1981 said sym links aren't updates with upgrade so I'm thinking that is the issue. I tried ejecting desk but android kept restarting. I found a solution with app "rescan SD card!". I hope this helps someone!
    10-03-2017 01:09 PM

Similar Threads

  1. How can I fix my bricked device?
    By AC Question in forum Samsung Galaxy Tab 2
    Replies: 2
    Last Post: 04-09-2015, 01:15 PM
  2. How do I retrieve encrypted files off sd card after factory reset?
    By AC Question in forum Samsung Galaxy S5
    Replies: 3
    Last Post: 03-28-2015, 05:05 PM
  3. Why is my nexus 5 taking so long to charge?
    By AC Question in forum Ask a Question
    Replies: 4
    Last Post: 03-28-2015, 02:10 PM
  4. How can I get my tablet out of erase mode after reset?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 03-28-2015, 10:40 AM
  5. Replies: 1
    Last Post: 03-28-2015, 10:32 AM