1. AC Question's Avatar
    Tried to Root my Samsung S5 but used the wrong firmware SM-G900L.. fail. It's now stuck and won't boot up. I have tried to remove battery and try to enter recovery mode but not luck. I read online that it's probably best to put it back to stock but there are a few firmwares for my model and as i can't get into my phone i don't know which one to try so i have no idea what was installed on it Anyone got an idea of how i can find out what was on it?
    04-14-2015 04:55 PM
  2. Moshe Barash's Avatar
    Go to sammobile.com and search for your model number, when you have located your phone on the website look for the latest firmware and download it, then flash it via Odin.
    04-14-2015 05:00 PM

Similar Threads

  1. Galaxy Tab 3 won't start/charge
    By tonyzz_mad in forum Samsung Galaxy Tab 3
    Replies: 7
    Last Post: 10-12-2015, 09:22 AM
  2. Replies: 3
    Last Post: 04-20-2015, 11:17 AM
  3. Replies: 1
    Last Post: 04-18-2015, 04:56 PM
  4. Replies: 1
    Last Post: 04-14-2015, 07:04 PM
  5. How do I delete large SMS threads?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 04-14-2015, 04:25 PM
LINK TO POST COPIED TO CLIPBOARD