02-25-2016 05:09 AM
30 12
  1. Tacosalex's Avatar
    I got my new Samsung Galaxy S5 yesterday, and have loved it so far, except I realized rather quickly that I couldn't sign in to any of my games using my Google account. Looking into the problem, I tried other games, but nothing seemed to work. Upon opening the Google games app, I realized that this wasn't a simple issue. The top area of the sidebar on the app that is usually used to switch between accounts was solid gray instead. All the sections including settings and excluding help & feedback either did not open or displayed the loading icon forever until I moved on to another section. I tried turning the app on and off, clearing cache, deleting data, but none of those worked either. My phone is a SM-G900M running Android 5.0 Lollipop.
    Aashiquesanthosh likes this.
    05-30-2015 05:32 PM
  2. B. Diddy's Avatar
    Are you on the latest version? Mine is on 3.0.11.
    05-31-2015 01:25 AM
  3. Tacosalex's Avatar
    05-31-2015 08:47 AM
  4. B. Diddy's Avatar
    How about Google Play Services? I'm on 7.5.71.
    05-31-2015 05:59 PM
  5. Tacosalex's Avatar
    Yes I am on 7.5.71 as well. I just tried to access the Google play games settings from the Google Settings and that failed as well with an infinite loading loop. I also tried multiple hard resets with no success.
    05-31-2015 06:09 PM
  6. Tacosalex's Avatar
    I managed to downgrade both Google Play Services and Google Play Games to an earlier version, and they seemed to work together fine, except no other google apps worked. Upon re-update, the same problems reoccur.
    05-31-2015 08:54 PM
  7. Bent Linde's Avatar
    Same problem here.
    06-01-2015 12:46 PM
  8. B. Diddy's Avatar
    Grrr. I'm stuck, sorry. Let Google know about this on this page: https://support.google.com/googlepla...#topic=3364260. Click on Contact Us at the upper right.
    06-01-2015 02:10 PM
  9. Tacosalex's Avatar
    I already spoke with a specialist there and they told me to come here. They said that Google Play Games was out of their scope.
    06-01-2015 04:36 PM
  10. B. Diddy's Avatar
    Huh. Well, I guess we should feel flattered. I'll keep an eye out for a solution.
    06-01-2015 07:05 PM
  11. Tacosalex's Avatar
    I just talked to them again. They asked me to send in a bug report and there should be a solution within a few days. They have some specialists working on it. For future reference, they also told me that https://productforums.google.com/forum/#!home;lang=en is usually a better place to send people for specific product support.
    06-01-2015 07:08 PM
  12. B. Diddy's Avatar
    I'm glad there might be some movement on this.

    I've historically found the Google Product Forums to be not that helpful, unfortunately. There are often lots of threads where seemingly no one with any Google affiliation checks in or responds. Maybe it's changed.
    06-01-2015 07:32 PM
  13. Borys Quiroga's Avatar
    I'm having same exactly same problem with my GALAXY S5 SM-G900M. I'll be looking for info.
    06-05-2015 04:04 PM
  14. Tacosalex's Avatar
    After exchanging over ten emails with several google support technicians, they gave up and sent me the following email:

    "From reviewing what you've told me here it sounds like there's a problem with your device that's affecting the performance of Google Play.
    I recommend contacting your device manufacturer, since they're best equipped to provide device-specific support in this case.
    That being said, be sure to let the support team know that the issue persisted through multiple FDR's and you may need your operating system reinstalled."

    I'm going to talk to them tomorrow and keep everyone here up to date on what happens with this issue, as it seems it is not as localized as I thought.

    I would be interested to see if this is a certain problem with the vendor or any specific spec, so here is a link to the place I bought my phone from. If anyone with this problem sees any similarities, please note them so that we can identify the problem better.
    Samsung Galaxy S5 SM-G900M 4G LTE 16GB Black (Factory Unlocked) - ThePowerSellers
    I am running Android 5.0 with T-Mobile.
    06-05-2015 09:46 PM
  15. AlvaroSoliz94's Avatar
    Hey guys. I got the same problem here. And it seems it's a general issue among users who have the SM 900M model. I am really upset that Google is not taking this bug seriously. I don't really think this is a manufacturer matter. Take a look to the Play Store. Lots of complains about his issue, including mine. Hope to see updates soon and maybe good news. Thanks buddy.

    Posted via the Android Central App
    06-06-2015 12:47 AM
  16. B. Diddy's Avatar
    If it's a general issue among users of the SM-900M model, then it really is a device issue rather than a Google issue. Google puts out the basic Android code, and the manufacturers modify it for their devices. So if a particular device is having problems, it's due to the manufacturer's tinkering, not Google.
    06-06-2015 02:16 AM
  17. Ricardo Paes's Avatar
    I had the same problem after a recent Play games App update.
    The only way to fix it was to revert the app to the previous version.
    06-06-2015 03:56 AM
  18. JohnnyStormy's Avatar
    I use a galaxy s5 SM-G900F and i have the same issue after the update. Everything was fine before.
    06-07-2015 07:23 AM
  19. Tommaso Di Fant's Avatar
    Same here with a SM-G900F, any updates?
    06-07-2015 02:00 PM
  20. Tacosalex's Avatar
    I talked to Samsung Product Support, however they could offer me no help on the G900M model since it is an international device. After going to the vendor, they still have no suggestions, except for me to just return the phone. The only other option I can see to pursue is to get the OS reflashed, which is also a huge hassle. Sorry for everyone here looking for a solution; this seems like an unfixable issue.
    06-10-2015 02:35 PM
  21. deadbloke's Avatar

    I'm using a Galaxy S5 SM-G900F and was having the same problem as you. I went into Settings / About Device / Software Updates and installed the latest and it's working now. Note: this is the updates to OS / System (whatever you call it) rather than updates you install through the play store - it was a problem with the phone rather than with the app (or at least was solved by upgrading the phone rather than the app...)

    Just a heads up in case that can solve your problems as well.

    Good luck!
    06-10-2015 06:19 PM
  22. Tacosalex's Avatar
    I tried to get a software update for my phone, but it said that no updates were available. I am returning my phone today. Does anyone know if all model M's have this problem, or is it specific to only a few?
    06-11-2015 09:48 PM
  23. Xsandreasx's Avatar
    Same problem with my galaxy s5
    No solutions?
    06-14-2015 05:35 AM
  24. Alex Serrano1's Avatar
    I HAVE A S5 G900m and solve the problem , I can DOCUMENT ?
    07-31-2015 08:25 AM
  25. Jabangy's Avatar
    I have sm-g900m and mine wont work either bought her from btc in the bahamas and have two freinds same thing we believe it a samsung isue
    09-04-2015 12:07 AM
30 12

Similar Threads

  1. why has Google play stopped working
    By js238836@gmail.com in forum Ask a Question
    Replies: 1
    Last Post: 05-31-2015, 01:38 AM
  2. Replies: 1
    Last Post: 05-30-2015, 05:09 PM
  3. Why isn't Google Play Games working?
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 05-30-2015, 03:16 PM
  4. Replies: 0
    Last Post: 05-30-2015, 12:43 PM