12-04-2016 12:32 PM
31 12
tools
  1. bmcc93's Avatar
    Whenever I turn on my Galaxy S5 I get a message that says "unfortunately, NetworkSystemProvider has stopped" and neither the wifi nor my 3g access will work correctly. The device says it is connected to the internet, but no apps will connect properly. When I turn wifi off and try to use my mobile data connection it does not work either. Any help would be much appreciated.
    06-08-2015 07:28 PM
  2. daveed4309's Avatar
    The same thing happened to my phone around the same time you posted. I'm at sprint now and they are recommending a hard reset but also there was a girl who walked in right behind me and she got the same message as me. We were both prompted to restart and then after the restart nothing was working.
    06-08-2015 08:01 PM
  3. Amanda Jackson2's Avatar
    Same thing with me!! ugh!
    06-08-2015 09:00 PM
  4. cbs2015's Avatar
    Same issue. My phone auto restarted and it's own and hasn't worked since. It all started about 730 pm CST. Any known solutions?
    06-08-2015 09:35 PM
  5. Bodlar Danger Leben's Avatar
    Same problem here! What the ****? I've tried shutting down and pulling the battery and it still does the same thing. Yep after that update my phone wont connect to anything.
    06-08-2015 10:37 PM
  6. nela_runner's Avatar
    Me too!

    My phone auto reset and after than nothing works. Can't connect to Network/Wifi, can't make calls/texts. I spent an hour with support and did a rest and nothing. Over a day and nothing.
    06-09-2015 12:35 PM
  7. KlcQueeN's Avatar
    I did a reset and changed my SIM card and still have the same issue. I can only connect on wifi
    06-09-2015 05:28 PM
  8. Kanotari's Avatar
    I uninstalled my most recent update by going to settings > application manager, then finding the problem app (mine was Sprint Zone) and selecting 'uninstall updates'. My phone (Galaxy S5) is working now after having this issue.
    07-22-2015 10:53 AM
  9. hitechNana's Avatar
    Do NOT do a reset of your phone or clear it completely!
    Do NOT lose all your stuff!

    If none of the recommendations on here do not work, they didn't work for me, do this!

    I was up all night troubleshooting my phone, determined not to 1. Lose everything 2. Take it to Sprint who would just reset it and wipe it clean..

    Soooo after trying all the things everyone said and still getting the error message
    "networksystemprovider" has stopped, I thought about what I was doing when my phone said it needed to restart. That message popped up several times and finally it restarted against my wishes.

    I was talking to my kids, one via KiK and the other through FB, soooo I went into my apps and deleted them both.

    This time when my phone rebooted, it did a quick reactivation and I was finally able to access the Internet and all my other applications!

    I believe this is a type of virus, even though my Lookout didn't detect it.
    Anyway, try it 1st!

    I am so relieved!
    Hope it works for you, too!
    11-12-2016 09:58 AM
  10. Sarah2016's Avatar
    I just tried what hitechNana recommended and that worked. I was on Facebook when I first got the error. I couldn't uninstall it via the Play Store with no internet, but was able to go into Application Manager and uninstalled it there. I initially tried both wiping the cache partition and uninstalling updates of Sprint Zone per other suggestions online and neither fixed the issue.
    11-12-2016 02:06 PM
  11. Marmarmar's Avatar
    I was having this problem and, on the advice of this forum, I uninstalled Facebook from my phone (then re-installed) and now it's working again. I wouldn't have thought to do that without this. THANKS SO MUCH. You saved my phone and weekend!
    11-12-2016 03:32 PM
  12. deelowday's Avatar
    Made an account just to say that hitechNana is a lifesaver. Facebook Messenger seemed to have been my problem app. I uninstalled it, restarted, and now my phone works again!
    11-12-2016 05:00 PM
  13. Tiribulus's Avatar
    What if you can't use your phone because the message makes everything unresponsive and will not go away? How was anybody able to even try this fix is the question. The phone is unusable.
    11-13-2016 08:22 AM
  14. Tiribulus's Avatar
    "... I went into my apps and deleted them both. !
    How were you able to do this? The message comes up instantly upon logging onto the phone. I tap ok and it's back a half a second later. Nothing else can be done while it's on the screen. I can wrestle it into into restarting during that half second after tapping ok and that's it.
    This is a Sprint Galaxy S6 running a rooted image of Lollipop5.1 with a Teamwin recovery partition.
    Any help would be magnificently appreciated.
    11-13-2016 08:52 AM
  15. Tiribulus's Avatar
    I managed to get Facebook and it's messenger uninstalled over almost an hour in between tapping ok on the error message and no change. Restored all apps from a SmartSwitch backup and still no difference. I'm greeted with the error upon logging on "Unfortunately, NetworkSystemProvider has stopped." and can't do anything else.
    11-13-2016 09:34 AM
  16. tinfoilhatguy's Avatar
    Chiming in to say I'm getting this as well as of 11/13/16. Phone randomly rebooted in my pocket (heard the Sprint chime), when it finished rebooting, the phone was borked. Running a Sprint Note 4, not an S5 though. No facebook messanger app installed. Tried removing sprint zone updates, no good.
    11-14-2016 01:39 AM
  17. Tony Santiago1's Avatar
    Same here, Sunday 11/13/2016, some time after 2PM it happened. Tried just about everything I could while still tapping ok for the popup to go away for a half second....nothing worked. Sad part is, even after a factory reset, still have this issue!
    11-14-2016 09:18 PM
  18. tinfoilhatguy's Avatar
    Some people have reported that it is caused by a failed app update, usually sprint zone or facebook messanger. Is there a quick way to force all apps to reinstall. Also, I work for Sprint customer care (nothing in my docs at work), and none of my callers are experiencing the issue. My phone is rooted, is this the case with others (yes, rooting is against the TOS for Sprint)?

    edit: i have an idea. What app actually brings up the dialog box that notifies us the app has stopped? as a temporary work around, maybe disabling it or its notifications could resolve the issue.


    second edit: I have package disabler pro, and disabled networksystemprovider and rebooted. I feared that i might soft-brick my phone, but it's working now. No more pop-ups. I have no idea what networksystemprovider is, or what it does though, so try at your own risk.
    11-15-2016 12:44 AM
  19. jdawg1771's Avatar
    tinfoilhatguy,

    Set up and account on here to say thanks. I'm not saying it's the "right" way to fix it, but as it seems I still have full functionality without it, I too disabled the NetworkSystemProvided service and...Ta Da!...no more pop ups. My hope is that Sprint figures out what went wrong since it happened to quite a few people over the last 72 hours, but for now, this will suffice.

    For what it's worth, I'm using a rooted Note 4 with stock rom and TWRP recovery. Nothing to fancy. I tried rebooting, wiping cache and dalvik cache, uninstalling SprintZone update, restoring a previous NAND backup, factory reseting, and a full OS wipe with a NAND restore all to no avail. I also do not have Facebook Messenger installed so that wasn't going to work for me either. Anyways, just wanted to say "Thanks for the suggestion". Back up and running now.
    11-15-2016 07:55 AM
  20. Cody Munholland's Avatar
    It is happening for me as well. Do I need to be rooted to disable this service? The options are greyed out for me to disable.
    11-15-2016 04:31 PM
  21. jdawg1771's Avatar
    I wasn't able to do it just from the on board Application Manager. I downloaded "Package Disabler Pro (Sumsung)" from the Play Store and used it to disable the service. My Note 4 is rooted but the developer claims that root is not necessary to use the app.
    11-16-2016 07:22 AM
  22. tinfoilhatguy's Avatar
    I don't know if it's because I disabled networksystemprovider, but now i'm having real issues. Calls that come in drop immediately. Seem to have trouble with outgoing calls, they seem to connect when the phone still says dialing, then the call drops. Text messages take 60 seconds or more to go out, and I get copies of the same text sent to me over and over and over and over. Either way, this error infuriates me. I suspect Sprint did it deliberately to ensure people upgrade on black Friday. I'm probably going to end up cancelling service instead.


    edit: and cody, I needed as jdawg said, I needed package disabler pro. If you're having too much trouble adding it from your phone, you can also push it to your phone through a computer web browser by going to the google play store on your computer and selecting to install it, then choosing the device to send it to.
    Spacey09 likes this.
    11-17-2016 09:34 PM
  23. Spacey09's Avatar
    Some people have reported that it is caused by a failed app update, usually sprint zone or facebook messanger. Is there a quick way to force all apps to reinstall. Also, I work for Sprint customer care (nothing in my docs at work), and none of my callers are experiencing the issue. My phone is rooted, is this the case with others (yes, rooting is against the TOS for Sprint)?

    edit: i have an idea. What app actually brings up the dialog box that notifies us the app has stopped? as a temporary work around, maybe disabling it or its notifications could resolve the issue.


    second edit: I have package disabler pro, and disabled networksystemprovider and rebooted. I feared that i might soft-brick my phone, but it's working now. No more pop-ups. I have no idea what networksystemprovider is, or what it does though, so try at your own risk.
    I set up an acct to say Thank you so much, I also have a rooted note 4, that restarted itself to this annoying message. I was doing everything to try and remove that pop up message/fix network provider and your advice worked. Although I wiped my phone in twrp (not the smartest thing to do)but I am wondering if I apply nandroid backup if that screen will return. Lol I really just wanted to say Thank you so much, I was really flipping out and this temp fix def was brilliant on your part. Thanks again.
    11-20-2016 07:53 AM
  24. jdawg1771's Avatar
    Thought I'd jump back on here to let you know that what you're experiencing is happening to me as well, Tinfoilhatguy. Your symptoms are exactly as I'm seeing so I'd say that disabling this has caused it. It's made my phone way more functional than it was when the error first started popping up, so I still feel it was a valid temp fix. My intent in the next few days is to flash a stock rom, test, and if functional, attempt to re-root. We'll see how it goes.The fact that reverting to a previous NAND backup after a complete OS wipe leads me to believe there's more at work here than first thought though.
    Spacey09 likes this.
    11-21-2016 03:17 PM
  25. Spacey09's Avatar
    Jdawg1771---Thanks for your update,I am still having major issues as well, the disabler got rid of the annoying message, i enabled it again system network provider and i now have no texts send or receive, calls are sketchy, no email etc. I am going to flash a different rom as well, so thanks for putting this on here. I am going nuts trying to fix. Then I am going to call sprint and I think we should be compensated this is ridiculous. Thanks again for your status.
    11-22-2016 02:14 PM
31 12

Similar Threads

  1. Has any one switched a device from T-Mobile to AT&T?
    By Jim Nielsen in forum Ask a Question
    Replies: 1
    Last Post: 06-11-2015, 10:02 AM
  2. Replies: 3
    Last Post: 06-10-2015, 02:40 PM
  3. The mic has disappeared from my keyboard, how can I get it back?
    By David Hall13 in forum Samsung Galaxy S3
    Replies: 2
    Last Post: 06-09-2015, 03:46 PM
  4. Why does my Samsung S6 Bluetooth sync has the music volume very low?
    By gotrice8 in forum Samsung Galaxy S6 edge
    Replies: 3
    Last Post: 06-09-2015, 11:25 AM
  5. Replies: 1
    Last Post: 06-08-2015, 06:28 PM
LINK TO POST COPIED TO CLIPBOARD