1. THX1141's Avatar
    I bought my S5 in January and the Samsung Link app has never worked. When I tap on "get started" after opening the app, the screen goes black momentarily and then returns to the same screen.
    06-10-2015 09:31 PM
  2. itguyjax8430's Avatar
    I bought my S5 in January and the Samsung Link app has never worked. When I tap on "get started" after opening the app, the screen goes black momentarily and then returns to the same screen.
    Welcome to Android Central!

    Have you tried opening your Galaxy Apps store to see if there is an update? Also try going in to your settings, applications, all apps, go to the app and clear the data to reset it.
    06-12-2015 02:50 PM
  3. THX1141's Avatar
    Thanks but it's already up-to-date and clearing the data did not fix the issue.

    One of the reviews on the Galaxy Apps store also says that they're having the same problem.
    06-14-2015 07:47 PM
  4. Kenneth Bousquet's Avatar
    Same problem, there is a update for optimization but it won't update says network error. Was working last month.

    Posted via S5 Active
    07-01-2015 03:07 PM

Similar Threads

  1. OWA not working
    By hayley888 in forum Verizon Samsung Galaxy S4
    Replies: 9
    Last Post: 08-18-2015, 02:55 PM
  2. Facebook app installed but not working.
    By Usuf Ahmed in forum Android Apps
    Replies: 7
    Last Post: 06-15-2015, 02:40 PM
  3. Side tab that is not a multi window tab
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-12-2015, 02:34 PM
  4. Replies: 1
    Last Post: 06-11-2015, 07:38 PM
  5. Replies: 1
    Last Post: 06-10-2015, 10:52 PM
LINK TO POST COPIED TO CLIPBOARD