1. AC Question's Avatar
    I have a Galaxy S5 which never had an issue connecting to my home Belkin n600 Play Wi-Fi router until my wife swapped from an iPhone to a Galaxy S5 too. Now only one of our S5 phones will connect to the Wi-Fi router at once, the other phone gets to 'obtaining ip address' but won't connect.

    If you turn my phone off my wifes will connect and if you turn hers off my phone will connect but never both at the same time. When I hand an S5 and she had an iPhone both would connect at the same time.

    This is a real pain as you think you're on Wi-Fi but you're unwittingly burning through your data allowance!
    06-12-2015 02:54 AM
  2. dadathepanda's Avatar
    That's a weird issue, did you try forgetting the network on both phones and reconnect it? Also, you may want to reset the router, or at least, reboot

    Posted via the Android Central App
    06-12-2015 01:28 PM
  3. AXEL314's Avatar
    Yea definitely try rebooting your router. Anytime I have wifi issues, that pretty much corrects 99% of my problems, hah.

    Posted via the Android Central App
    06-13-2015 02:06 PM
  4. deke40's Avatar
    The wife and I both have S5s with a Netgear router and have had no problems connecting at the same time.

    Posted via the Android Central App
    06-13-2015 03:56 PM
  5. kaicho's Avatar
    Check your router for the range of IP addresses that can connect..ie have enough IP addy to connect all your devices.

    Old rocker on Tapatalk
    06-13-2015 06:08 PM

Similar Threads

  1. How can I get my Galaxy S6 microphone working?
    By AC Question in forum Samsung Galaxy S6
    Replies: 1
    Last Post: 06-17-2015, 04:17 PM
  2. Replies: 4
    Last Post: 06-12-2015, 02:47 PM
  3. Why does the screen say no picture selected?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-12-2015, 07:55 AM
  4. Replies: 1
    Last Post: 06-12-2015, 02:26 AM
  5. Replies: 0
    Last Post: 06-12-2015, 02:22 AM
LINK TO POST COPIED TO CLIPBOARD