1. WSAD's Avatar
    I didn't use my phone much, only about 1 hour SOT per day and I only turn on Wi-Fi when I needed, the rest of time I always keep it off, but today I checked my battery status and saw this

    Did my Wi-Fi always on?-screenshot_2015-05-16-15-07-32.jpg

    As you can see, my Wi-Fi bar show a straight blue the whole time even when Wi-Fi is off. It didn't make any sense.

    Anyone know wht happened to my Wi-Fi and how to fix it?
    06-21-2015 05:40 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Go to Settings>Wi-fi, tap Menu>Advanced, and turn off "Scanning Always Available"
    06-21-2015 06:13 AM
  3. WSAD's Avatar
    I already turned it off a long time ago.
    06-21-2015 06:25 AM
  4. Javier P's Avatar
    I think it's just a glitch in the battery stats after Lollipop. My phone does the same sometimes and I haven't found a reason or a fix.
    06-21-2015 06:51 AM
  5. WSAD's Avatar
    I think it's just a glitch in the battery stats after Lollipop. My phone does the same sometimes and I haven't found a reason or a fix.
    Did this hapened on Kitkat?
    I don't know much about Kitkat because I updated my phone to Lollipop right after I bought it.
    06-21-2015 07:30 AM
  6. B. Diddy's Avatar
    Also, does it go away after a reboot?
    06-21-2015 07:55 AM
  7. Javier P's Avatar
    No. For me that happened just after Lollipop. For others reasons I've wiped the cache partition a couple of times after the update and it didn't change anything. I've checked my battery stats now and after being on mobile for a couple of hours the WiFi bar is on all the time. I sort of gave up trying to fix or even understand that glitch
    06-21-2015 08:31 AM
  8. WSAD's Avatar
    Also, does it go away after a reboot?
    Yeah, after I restart my phone the wifi bar is gone (I didn't use wifi at that time) but just 1 or 2 hour later it turn blue again (I still didn't use wifi) and problem remain.
    Maybe it's Lollipop bug like Javier P said
    06-21-2015 12:13 PM
  9. Javier P's Avatar
    I checked again. I left the phone on airplane mode for the night, you can see the gap in the cellular signal. And the WiFi bar is on all the time.
    Attached Thumbnails Did my Wi-Fi always on?-1434969497067.jpg  
    06-22-2015 05:38 AM
  10. WSAD's Avatar
    Thanks Javier P, now I know it's not just me having this issue, but why Samsung didn't fix it?
    06-22-2015 07:07 AM
  11. oneeyecarpenter's Avatar
    I've posted in other threads on this issue, but what worked on my HTC m9, nougat 7.0, was to toggle Extreme Battery Saver on then off again. I tried everything imaginable too, at first.
    Another idea that struck me, was what I did after updating to nougat. I had to Reset All App Preferences, in the app manager. This is like one step below a Factory reset. It takes time to readjust all permissions later, and not just user land apps, but system too. This is definitely something to do after a bad ota update.
    12-27-2017 04:54 PM

Similar Threads

  1. Replies: 1
    Last Post: 06-23-2015, 10:08 AM
  2. Replies: 4
    Last Post: 06-21-2015, 07:50 AM
  3. Replies: 1
    Last Post: 06-21-2015, 06:46 AM
  4. How can I take my note 3 out if safe mode
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-21-2015, 06:20 AM
LINK TO POST COPIED TO CLIPBOARD