Yesterday 01:29 PM
32 12
tools
  1. BigBoi2U's Avatar
    I didn't start having this problem until i loaded an app called "CLEAN SWEEP, and " Whats APP".. does any one of these apps change some properties that are hard to find that now makes any of my pictures i download from my messaging app, or camera go straight to "MY FILES" instead of showing in MY GALLERY like they used to do. I have deleted the old download folder to see if it wold start a new one , and it did, but still is not showing up in my gallery, just my files. the only pics showing up in my gallery are the ones on my sd card. can some one please help us out here.. galaxy s5 owner
    06-25-2015 02:55 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Use a file manager app and look at a directory on Internal Storage that has images, and make sure there isn't a file called ".nomedia" anywhere. Check any of the parent directories as well. .nomedia instructs the system to ignore all media files in that directory and all subdirectories, when scanning for files to add to the Gallery, Music, and Video databases.
    thecomicbookandme likes this.
    06-25-2015 03:13 PM
  3. Rukbat's Avatar
    1. The pictures don't "go to" either My Files or Gallery. Neither of those apps has its own data folder.

    2. ALL media files, other than those that are hidden (file name starts with a dot) or have a .nomedia file (notice that's a hidden file) hiding the folder they're in (or hiding a folder in that folder and the picture is in that second folder, and so on down the line with nested folders) should be picked up every time you start or restart the phone, or run an app like Rescan Media.

    In addition to what B. Diddy said, copying files to the phone doesn't make Media Scanner rescan. Downloading files from your messaging app may not either. Download a file that you can see in My Files but not in Gallery. Restart the phone. See if it shows up in Gallery. If it does, it's because your texting app doesn't run a media scan if you download what might be a media file (scanning slows the phone a bit during the scan). Running Rescan Media will fix that if it's important for a downloaded file to appear in Gallery before the next restart. (Gallery doesn't show media files, it shows files found by Media Scanner - slight difference.)

    3. If the app you're referring to is Clean Master, uninstall it. Also uninstall anything else you have from Cheetah Mobile. They write Windows apps for Android - and that's like dropping window glass on rocks because dropping steel on them doesn't break the steel. Clean Master is a perfect example of not understanding how Android works, and if a company doesn't understand the environment, 42 years of system design experience tells me that they're not writing apps that have been developed, they just throw in code that does something (that, in the case of Clean Master shouldn't be done), for some reason I can't fathom. (It's not like the free app doesn't do anything, and they're making a fortune from people switching to the paid version.)
    06-25-2015 06:25 PM
  4. GT1313's Avatar
    Hi there,

    I am also having this problem. Until recently, I am able to view pictures stored both in my device memory and SD card. Now, only those in the SD card shows up.

    Recently installed are apps from synology (DS file, DS Cloud, etc).

    I have check and there is no .nomedia file in those folders. I am using Note Edge.

    Please help.

    Thanks,
    GT.
    07-03-2015 03:54 AM
  5. devmau53's Avatar
    Ok i managed to fix this problem on my galaxy s5 running stock EE lollipop. All of my internal memory items stopped showing in gallery and the only way i could get them to show was to move the items to sd card but after a bit of reading and thinking i fixed it by going to>my files>phone memory then pressing the 3 dots on top right>settings>show hidden files>tthen go back to phone memory and delete the file called ".nomedia". Then i opened gallery and everything was showing up again. Hope this helps as i just signed up to pass on this info. Thanks for reading and good luck
    thecomicbookandme likes this.
    07-06-2015 06:54 AM
  6. Marius Andrei Stan's Avatar
    So, i've tried everything you said in those steps and nothing.the .nomedia files are keep showing. I cant use any media rescan apps. Does anybosy now which is the service responsable for media scan? I'm using a samsung A3. Thx
    07-27-2015 06:16 AM
  7. devmau53's Avatar
    Try plugging your phone into a pc and showing hidden files that way and delete the .nomedia file. Good luck
    08-04-2015 12:54 PM
  8. IMANUT46's Avatar
    I don't have a PC, only a smartphone. I have ES file Explorer, but using the Search function, I can't find any file called. NOMEDIA. How do I find it, and open it if I have it? Thanks

    Verizon Samsung Galaxy S5 Lollipop 5.0
    08-11-2015 01:13 PM
  9. naresh bathula's Avatar
    Search the .No media file in any of ur folder and rename it . and create dummy folder same name.move the files to dummy folder and delete the first renamed folder.I think it's eorks

    Posted via the Android Central App
    08-11-2015 02:11 PM
  10. IMANUT46's Avatar
    Search the .No media file in any of ur folder and rename it . and create dummy folder same name.move the files to dummy folder and delete the first renamed folder.I think it's eorks

    Posted via the Android Central App
    I can't find a nomedia file. That's the problem. Any other suggestions?

    Verizon Samsung Galaxy S5 Lollipop 5.0
    08-11-2015 06:00 PM
  11. thecomicbookandme's Avatar
    devmau53 solved it for me.
    Go to my files app and choose device storage. Select the three dots in upper right corner. Select settings. Check box marked "Show hidden files". Scroll down through all the files in device storage. At the bottom you will find the hidden files. They start with a dot. One may be dot no media. Delete all these files, even if.no media isn't there.
    I had about four of these files, including .no media. I just deleted
    .no media, but it didn't help. Went back and deleted all the hidden files starting with a dot, and it worked.
    Good luck.

    Yea, heavy and a bottle of bread.
    Sharon Jeon and Shmoox like this.
    08-13-2015 04:45 PM
  12. TwoPs's Avatar
    Thankyou for this info. Couldn't find Nomedia in devise storage. Nomedia was in my SD storage.
    Just a tip to check there also!
    12-15-2015 05:31 PM
  13. TwoPs's Avatar
    Look in your SD card file
    12-15-2015 05:32 PM
  14. chrisg750's Avatar
    Hello, I am having the same issue. I have opened My Files on my phone and I see the image and video files in the DCIM folder. On My Files, I went to Settings> Show hidden files. I went back to My files and deleted anything that had the .nomedia file. Nothing happened. My Files still shows that my images and videos are still there and are still accounted for on memory count, but the images show just as a previous post on my Gallery. I've also tried rebooting the phone after doing this process. I also tried deleting data and cache from the camera, gallery and memory storage in Application settings. I feel like I've tried almost everything. I KNOW the images are still there, but they refuse to open. Any help would be so appreciated. Thank you!
    12-17-2015 11:40 AM
  15. chrisg750's Avatar
    Ok i managed to fix this problem on my galaxy s5 running stock EE lollipop. All of my internal memory items stopped showing in gallery and the only way i could get them to show was to move the items to sd card but after a bit of reading and thinking i fixed it by going to>my files>phone memory then pressing the 3 dots on top right>settings>show hidden files>tthen go back to phone memory and delete the file called ".nomedia". Then i opened gallery and everything was showing up again. Hope this helps as i just signed up to pass on this info. Thanks for reading and good luck
    Please help if possible!
    12-17-2015 11:42 AM
  16. can3gxw's Avatar
    It could be a permissions issue on the folder itself.

    Do you have access to a computer? Here is what I would try next:

    1) Connect your phone to a computer
    2) Open file explorer on your computer and find the DCIM folder with your pictures and videos
    3) MOVE the entire folder (not just the files) - take the WHOLE DCIM folder and move it somewhere on your computer
    4) Once it's gone, snap a picture with your phone (or take a short video) and see if your gallery will open it properly.
    5) If the photo opens in step #4, using your computer's file explorer copy JUST the JPG and MP4 files back from the computer to the phone (to the same DCIM folder that the photo/video that you just took is stored). DO NOT MOVE THEM - leave a copy on your computer "just in case"
    6) Once they're all copied, try opening your gallery - they should all be there (fingers crossed for you!)
    12-17-2015 01:16 PM
  17. Shmoox's Avatar
    devmau53 solved it for me.
    Go to my files app and choose device storage. Select the three dots in upper right corner. Select settings. Check box marked "Show hidden files". Scroll down through all the files in device storage. At the bottom you will find the hidden files. They start with a dot. One may be dot no media. Delete all these files, even if.no media isn't there.
    I had about four of these files, including .no media. I just deleted
    .no media, but it didn't help. Went back and deleted all the hidden files starting with a dot, and it worked.
    Good luck.

    Yea, heavy and a bottle of bread.
    OMG thanks so much dude. I was panicking!
    12-26-2015 12:47 PM
  18. chrisg750's Avatar
    Has anyone tried backing up and then restoring from the backup?

    I tried everything above, and images still do not show up on gallery. =(
    12-26-2015 01:08 PM
  19. chrisg750's Avatar
    double post sorry
    12-26-2015 01:45 PM
  20. chrisg750's Avatar
    It could be a permissions issue on the folder itself.

    Do you have access to a computer? Here is what I would try next:

    1) Connect your phone to a computer
    2) Open file explorer on your computer and find the DCIM folder with your pictures and videos
    3) MOVE the entire folder (not just the files) - take the WHOLE DCIM folder and move it somewhere on your computer
    4) Once it's gone, snap a picture with your phone (or take a short video) and see if your gallery will open it properly.
    5) If the photo opens in step #4, using your computer's file explorer copy JUST the JPG and MP4 files back from the computer to the phone (to the same DCIM folder that the photo/video that you just took is stored). DO NOT MOVE THEM - leave a copy on your computer "just in case"
    6) Once they're all copied, try opening your gallery - they should all be there (fingers crossed for you!)
    I appreciate your response. So I followed all the above steps. After step 3, I took the picture and it did open the photo properly which in turn re-created the DCIM folder on the phone. I then copied all of the files from the DCIM folder on my computer back onto the newly created DCIM folder on my phone. No images showed up on either Windows Photos nor Gallery on my phone. Same problem still going on. The last thing I did was backup my phone with Smart Switch. I will try restoring it from the backup and hope that it may work. I don't know what else to do at this point =/

    Any other ideas would very appreciated! Thanks again.
    12-26-2015 01:45 PM
  21. Alkatic's Avatar
    I have the same problem, and I was really happy that I found the nomedia file on my SD card as you suggested.... however coming back to Gallery, still no sign of photos (specifically only from the Camera, the rest [screenshots, downloads, WhatApp etc. are all there]).
    I can only open them in My Files.
    Anyone has any update on this, please?
    If yes, could you let us know? I tried everything suggested here, but no luck so far.
    01-14-2016 03:34 PM
  22. HFLDev's Avatar
    Fixed it
    Just go to ure file manager . Scroll down and look for file "no media." And delete it
    03-31-2016 10:42 PM
  23. marcosbeltre5's Avatar
    maybe you need to export all the files in your card like you do with contacts
    03-31-2016 11:03 PM
  24. Louise Peart's Avatar
    Hi this is super important!
    Last night I deleted some files such as my whatsapp and snapchat photos on my internal memory.
    I tried all sorts of app and I retrieved the files back but there's no content in them at all
    Is there anything I can do to get my photos back?
    05-28-2016 09:36 AM
  25. Tanveer Bajwa's Avatar
    To copy your files on SD card and see them in gallery
    connect your cell phone with usb cable to your pc
    select file transfer on your mobile once connected to pc(it will ask on your cell phone screen)
    Open your sd card
    go to DCIM
    go to camera
    Paste all your photos here
    you will see your files in gallery once the photos are pasted
    PS;Do not copy the pics in any folder under Camera,just paste them in Camera folder,do not create any subfolder.
    01-05-2017 08:46 PM
32 12

Similar Threads

  1. Music on Moto g is not playable.
    By AC Question in forum Ask a Question
    Replies: 7
    Last Post: 06-26-2015, 07:17 PM
  2. Samsung not charging after i found it covered in condensation
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 06-25-2015, 04:56 PM
  3. Anfroid on Windows 435
    By rajukhadka19782 in forum Ask a Question
    Replies: 1
    Last Post: 06-25-2015, 03:22 PM
  4. Replies: 1
    Last Post: 06-25-2015, 03:16 PM
  5. How can I perform an sd card format on my tablet?
    By Tricia_Needs_Help in forum General Help and How To
    Replies: 2
    Last Post: 06-25-2015, 03:03 PM
LINK TO POST COPIED TO CLIPBOARD