1. Amanda808's Avatar
    I use the swipe lockscreen which works fine when selected, but after a few days it randomly turns off and goes to no lockscreen.

    I also discovered tonight that my phone turned off my do not disturb mode. I've tried googling, but no one else seems to have this problem.
    07-13-2015 11:47 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Do you have any of the Smart Lock functions turned on, like Trusted Faces or On Body Detection?
    07-14-2015 01:32 AM
  3. Amanda808's Avatar
    No. I've turned them all on at some point while learning how to use my new phone but ultimately (I believe) I turned everything else off.
    07-24-2015 12:02 AM
  4. B. Diddy's Avatar
    Go to Settings>Security>Smart Lock​, and make sure all of them are turned off.
    07-24-2015 01:23 AM
  5. Amanda808's Avatar
    Smart lock is greyed out and I can't select. I'd assume that means nothing is selected?
    07-24-2015 01:25 AM
  6. B. Diddy's Avatar
    Probably. Go to Settings>Security>Trust Agents, and see if Smart Lock is turned on or off there. Try turning that on, then go back to the Smart Lock menu and make sure all of that is turned off.

    Try also wiping the cache partition, which won't erase any personal data: http://support.t-mobile.com/docs/DOC-10404
    07-24-2015 12:10 PM

Similar Threads

  1. Writing data to sd card
    By GWraith in forum Legacy Android & Other OS's
    Replies: 6
    Last Post: 07-15-2015, 08:09 PM
  2. Replies: 1
    Last Post: 07-14-2015, 01:48 AM
  3. Replies: 1
    Last Post: 07-14-2015, 01:46 AM
  4. Replies: 1
    Last Post: 07-14-2015, 01:43 AM
  5. How to fix my touchscreen?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-14-2015, 01:40 AM
LINK TO POST COPIED TO CLIPBOARD