1. can3gxw's Avatar
    Here's what I know (running a GS5 on Bell Canada)

    1) About 4 months ago, I took advantage of a "free unlock day" courtesy of SamMobile. They use a 3rd party unlocker, and basically just kept filling their account with credits so everyone that tried could use THEIR credits to purchase the unlock. It was software based, no unlock code provided.

    2) Ran through the steps, and unlock was "successful"

    3) Have no friends that use anyone other than Bell. Didn't want to spend any money and buy a SIM from another carrier just to "test"

    4) Came across the re-launch of Public Mobility here in Canada (they were bought out by Telus) and they were kind enough to send me a free SIM.

    5) Arrived today, plopped it in my phone, started up, get "no service". 3 solid bars of signal and the phone "about" service just showed "no service", etc... Tried taking a screenshot but for whatever reason it lied when it said "saved". NO ERRORS about "foreign SIM" appeared.

    6) Would it make sense to assume that this DOES INDICATE that I am unlocked, but since I don't have service on this SIM yet, I obviously can't connect to their network (although I am getting a solid signal).

    TIA!
    Gregg
    09-09-2015 11:33 AM

Similar Threads

  1. Why won't my Droid Turbo unlock through ADM?
    By manazoni1989 in forum Motorola Droid Turbo
    Replies: 1
    Last Post: 09-09-2015, 10:40 AM
  2. Replies: 0
    Last Post: 09-09-2015, 10:02 AM
  3. Why aren't I able to see my Play Store app in my XT1033 menu?
    By AC Question in forum Google Play Store
    Replies: 1
    Last Post: 09-09-2015, 09:13 AM
  4. Replies: 0
    Last Post: 09-09-2015, 07:20 AM
  5. Replies: 0
    Last Post: 09-09-2015, 06:01 AM
LINK TO POST COPIED TO CLIPBOARD