1. AC Question's Avatar
    I accidently dropped my phone in the toilet and wuickly retrieved it. After a short time, i took it appart and put it into rice and left it for a day. When i tried to turn the phone on, it worked but wouldnt charge. I put it back in the rice but now its stuck on factory mode and says 'UDC START'. What do i do?
    03-11-2016 11:59 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! There may not be much you can do--it's likely due to water damage on the motherboard. Rice isn't a guaranteed fix--this technique might be better: http://forums.androidcentral.com/amb...e-got-wet.html
    03-11-2016 11:01 PM

Similar Threads

  1. Why can't I double tap to like on any app?
    By AC Question in forum Samsung Galaxy S6
    Replies: 9
    Last Post: 03-23-2016, 06:36 PM
  2. Replies: 7
    Last Post: 03-14-2016, 06:14 PM
  3. Replies: 2
    Last Post: 03-11-2016, 11:26 PM
  4. restoring deleting voice mail on Galaxy 5.
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 03-11-2016, 11:21 PM
  5. samsung pay hates me
    By chriscw81 in forum Samsung Galaxy S7 edge
    Replies: 14
    Last Post: 03-11-2016, 09:35 PM