1. robertantohi's Avatar
    So, i just did a software update today through kies. Version is still 5.0, so no M.
    My problem is, that downloads from google play, chrome and in general are now awfully slow- barely even 1 MB/s on wi-fi, whereas before they were 10 MB/s+
    This is strange, because i ran multiple speed tests on ookla mobile app and it showed a solid 80 mbps up & down speed ALTHOUGH sometimes it would start off very slow at 1mbps and then go up towards the end.
    I tried wiping cache partition, no luck.
    Tried setting router thingy to static, no luck either.
    Tried using an old router, that won't do either.
    Any ideas?
    03-26-2016 03:19 PM
  2. Rukbat's Avatar
    Connect to your router using a browser. Set it to use AES encryption, not TKIP or TKIP+AES. Reboot it (just pull the power, wait 15 seconds and plug it back in.) You'll have to forget that connection and connect again. If that fixes it, you'll have to reset the connections for all other computers connected to that router. (Some routers have a different idea of what "TKIP" means than others.)
    03-26-2016 07:32 PM

Similar Threads

  1. Replies: 2
    Last Post: 04-16-2016, 07:32 PM
  2. Software Updates.
    By naresh bathula in forum Samsung Galaxy S5
    Replies: 27
    Last Post: 04-03-2016, 03:40 AM
  3. key lights problem
    By Sandipann in forum Ask a Question
    Replies: 1
    Last Post: 03-31-2016, 11:40 AM
  4. S7 problems
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 03-26-2016, 02:57 PM
  5. Wi-fi slow on G900F( Samsung galaxy s5) after update.
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 03-26-2016, 02:42 PM