1. Pallavi_android's Avatar
    I bought my s5 recently.. everything else is fine. Except it won't charge properly. When the charger is plugged it shows the charging sign but the phone only charges when it's not in use or turned off. If im using the phone while its charging the charging extremely slow to the point that the battery percentage actually drains. Even when the phone is off the charging is really slow. Since i imported the phone i cannot use it's warranty.
    Im really worried about this because i bought it very recently. Please help!
    04-21-2016 10:12 PM
  2. BergerKing's Avatar
    Did you buy it new, or used? Have you tried a different charger block or cable? What is the charge rating on the charger you are using?

    Having had an S4, before, I know from experience that you need a good 2A charger to charge efficiently. I've had bad cables that connected, but charge ever-so-slowly. And asked if the device was used prior, because a battery could be the culprit if it was used by someone else.
    04-21-2016 10:49 PM
  3. Pallavi_android's Avatar
    Yeah its new.. out of the box. I first used a different charger to charge the phone.. could it have caused anything, damage on the usb port? The charger in the box is a 2A charger. But no luck with that too (with both chargers that is.. different cables, different adapter)
    04-21-2016 11:36 PM
  4. sayf777's Avatar
    What is the charger rating that you used (input and output?

    In most cases it shouldn't be an issue.

    How long does it take to charge to full when off?

    Since it charges slowly even when off it doesn't seem to be an OS issue (process running in background).

    Still try different cables if you have more, did it come with a 2.0 or 3.0 cable?

    Another thing is if you are able to, use a friends S5 battery to test it out.



    Posted via the Android Central App
    04-22-2016 03:27 AM
  5. Pallavi_android's Avatar
    Charger ratings of the adapter out of the box
    Input - 100-240V, 0.5A
    Output - 9V,1.67A or 5V, 2A

    It came with a 2.0 cable. Which i now think may not be a problem.

    Well it took about 5-6 mins to gain 1% charge (while its off; ) like i said the battery still drains while charging while using the phone (without the phone getting considerably hot).

    My s3 had similar problem a few years ago.. and the problem solved when i changed the usb port. That's why ive been thinking if it could be a problem. I don't know about the battery though. It also it a brand new one.
    04-22-2016 05:36 AM
  6. Pallavi_android's Avatar
    Also i checked with a 3rd cable... its the same.
    04-22-2016 05:39 AM
  7. Segads's Avatar
    hello there, im curently testing some chargers with my phone and tablet ( lg g flex 2, nvidia sheild tablet k1) . Is not finish yet but im testing every day with differnet cables..

    http://forums.androidcentral.com/bat...ighlight=anker

    let me know what do you guys think
    04-22-2016 08:34 AM
  8. sayf777's Avatar
    Since it's prob not the os or a cable/charger I'm inclined to agree that it may be the usb port:/

    As a last ditch effort I'd say back up whatever you need to amd factory reset. Worth a try

    Posted via the Android Central App
    04-22-2016 09:24 AM

Similar Threads

  1. a question about charging port durability
    By person1001 in forum Samsung Galaxy S7 edge
    Replies: 5
    Last Post: 04-24-2016, 06:36 AM
  2. My galaxy s5 charges extremely slowly
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-22-2016, 02:22 PM
  3. How do I reinstall the icon for Facebook on my home page?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-22-2016, 04:52 AM
  4. My phone is massively overheating?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-21-2016, 11:01 PM
  5. How can I display my group title? Galaxy s5
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 04-21-2016, 09:45 PM
LINK TO POST COPIED TO CLIPBOARD