1. Connoian's Avatar
    I recently bought 2 s5s off ebay to refurb, both have no or slow mobile data connectivity issues. 1 was on vodafone, calls only works with 3g/2g auto connect selected, and the mobile data does not connect, and very rarely shows the H+ symbol. The second one shows H+ but the mobile data either runs slow, or says connection to server lost. I have installed 6.0.1 unbranded marshmallow os on them both. I have tried many troubleshooting tips, but alas none of them have worked. Any tips would be appreciated.
    06-04-2016 06:05 PM
  2. ironass's Avatar
    Which country and network are you attempting to use them on?
    06-04-2016 08:06 PM
  3. chirantha7777's Avatar
    I recently bought 2 s5s off ebay to refurb, both have no or slow mobile data connectivity issues. 1 was on vodafone, calls only works with 3g/2g auto connect selected, and the mobile data does not connect, and very rarely shows the H+ symbol. The second one shows H+ but the mobile data either runs slow, or says connection to server lost. I have installed 6.0.1 unbranded marshmallow os on them both. I have tried many troubleshooting tips, but alas none of them have worked. Any tips would be appreciated.
    Suffering from the same issue too SM-G900FD in Sri Lanka with UAE firmware installed. I did however manage to get rid of the Slowing down issue by disabling DC-HSDPA. Internet is fast but it does still drop the connection from time to time for no apparent reason. Its something to do with the modem of the phone I guess

    Edit : Noticed that just before 3G drops out the phone tries to use 4G which is weak and falls back to 3G.. Just then connectivity stops and 3G restarts.
    06-05-2016 06:22 AM
  4. can3gxw's Avatar
    Sounds like firmware on a phone that's not meant to be used on different carriers.
    06-05-2016 01:42 PM
  5. Connoian's Avatar
    Giffgaff on 02 and in the uk.
    06-07-2016 09:59 PM
  6. Connoian's Avatar
    Also I bought an S5 neo G903f off ebay which was hard bricked, i installed lollipop 5.1.1 with Odin V3 11.1, successfully, but it still wont start after logo just an endless blank screen. It says efs failed to mount invalid argument. The ADB is disabled plus no CWM is available for G903F and the twrp image thing i have no idea about. Is it knackered? Thanks in advance.
    06-07-2016 10:04 PM
  7. Connoian's Avatar
    How do i fix it. Thanks in advance.
    06-07-2016 10:08 PM
  8. ironass's Avatar
    Giffgaff on 02 and in the uk.
    giffgaff are a U.K. MVNO on the O2 network and are known for throttling their data speeds. See... 4G Speed Throttling... Seriously?? and Throttling of customers transfer speed - unlimited 3G. Try borrowing another carrier's sim card and check the data rate. Also ensure that you are using the correct giffgaff APN settings for the S5 and that you are on, say, the U.K. unbranded firmware.

    Also I bought an S5 neo G903f off ebay which was hard bricked, i installed lollipop 5.1.1 with Odin V3 11.1, successfully, but it still wont start after logo just an endless blank screen. It says efs failed to mount invalid argument. The ADB is disabled plus no CWM is available for G903F and the twrp image thing i have no idea about. Is it knackered? Thanks in advance.
    If you have bought a phone with a missing or corrupt, "/efs", file then I am afraid you are screwed as this file contains important, unique, information about the phone including, among other things, its IMEI #. Without it the phone will not connect to a network or, in some cases, even boot up. See, Getting to know your EFS folder on Samsung Devices
    Laura Knotek likes this.
    06-08-2016 04:29 AM
  9. Connoian's Avatar
    Ive noticed its usually the vodafone S5, that has the slow or no, mobile data problem. Thanks for info. Ill let you know if other sims work better.
    06-10-2016 09:14 AM
  10. Connoian's Avatar
    This my third used S5 off ebay that has the slow or no, mobile data, ive noticed 2 of the phones have had their blue antenna wire replaced, plus they were on vodafone, their must be an issue with vodafone or its bad luck, they never said anything about it in listing.
    06-10-2016 09:21 AM
  11. yobil's Avatar
    I have a G900F and didn't notice until now that I have the same issue. Is there a way to validate that my poor data connection was due to this and not due to limited network coverage? I also saw that the phone that I have came from Vodafone although I got it from Smart Telecommunications here in the Philippines.

    Posted via the Android Central App
    06-10-2016 10:52 AM

Similar Threads

  1. Replies: 2
    Last Post: 09-20-2016, 08:53 PM
  2. No facebook live video option
    By T68 in forum Nexus 6P
    Replies: 5
    Last Post: 08-14-2016, 05:59 AM
  3. Replies: 3
    Last Post: 06-05-2016, 01:06 AM
  4. Replies: 3
    Last Post: 06-04-2016, 08:23 PM
  5. HELP -Galaxy S5 Locked by Samsung
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-04-2016, 06:13 PM
LINK TO POST COPIED TO CLIPBOARD