1. Rammanjeff's Avatar
    Just noticed this a few days ago and can't seem to find a working solution.

    I am not sure what changed in the last couple days but all of a sudden when my S5 connects to my home wifi, it will cause the router to reset. It does connect and get assigned an IP but as soon as it does, router drops and resets. No other issues with other wireless electronics. I have tried numerous solutions posted around and nothing has worked. I have an older D-Link DIR-628 router that has worked fine until now. Updated to Marshmallow on June 3 so it is possible it is related to the update and I just never noticed until a few days ago.

    So far I have tried:

    resetting device cache
    resetting network settings
    forgot wireless network and reconnected
    tried numerous setting changes in router
    Wifi on during sleep = always
    Smart network switch = unchecked
    Assigned static IP for phone
    tried using lollipop legacy DHCP assign instead of Android DHCP assign

    Any other solutions are welcome. Data usage climbing rapidly without wifi and nearing my max 2gb limit.

    Jeff
    06-17-2016 03:17 PM
  2. SpookDroid's Avatar
    You might have to update your router. I had similar issues with a Tab S on an ISP-provided D-Link and as soon as that tablet connected, everything went to hell. Slow transfers, random reboots, devices not connecting... As soon as I disconnected the tablet, it all worked fine. Changed my router and I didn't have the issue anymore. In your case I hope it's not as drastic as having to change the router (I didn't try to update the ISP one because I was gonna change it anyway to avoid the rent fee), so maybe flashing an update will help.
    06-17-2016 03:34 PM
  3. RebelVampire's Avatar
    You are not alone. I have also been having this issue with two S5 phones and my router. It is also something that only started a few days ago for me too as the phones have been on my network with no issues before this. The difference for me is my router is a dlink dir-655. I have yet to find a solution, and even tried a full factory reset of the router to no avail. Between the phones there has been no system new system updates and only one in common recent app update, so I'm baffled why the sudden change in function myself.
    06-19-2016 03:24 PM
  4. khadabra's Avatar
    Same issue for me. Started a few days ago. My phone is an Galaxy S4, and my router is the dir-655.

    Don't have the issue at work, but not sure what router that is.

    What app did you update?
    06-20-2016 02:02 AM
  5. RebelVampire's Avatar
    What app did you update?
    Each phone had a few app updates in recent history, but the only one they had in common that I could find was Verizon messaging. I tried uninstalling the updates for it on one of the phones (may have disabled the app too), but that had 0 effect on the problem. Later on today I will probably attempt reviewing the apps again more fully and seeing if any of them are the culprit.
    06-20-2016 05:31 AM
  6. RebelVampire's Avatar
    As an update to my personal situation, I've managed to get both phones connected to the router without causing a constant reboot. While researching androids in general crashing routers, someone recommended setting up a guest zone and setting the cipher on the guest zone to TKIP only; apparently androids can have trouble with the AES cipher. The guest zone also forces the phones to use only the G band, as similarly the N band can also create issues in phones. Doing this seems to have ceased my problems so far. One phone has been on the router for 10+ hours now and the router has not reboot itself since. Fingers crossed this solution holds.
    06-20-2016 10:54 PM
  7. fLaPjAk's Avatar
    Did you ever figure this one out? I myself have the same issue; happened around June 16 and no matter what i do it resets. I also have the DIR-655 v1.37 revision A. I'm trying to go through all the apps too, though unlike my iPhone i can't seem to organize the apps by last updated.

    Neither G only, TKIP, etc all the other tips are working.

    For now I just keep it off my router; and the routers been going strong for 10 days plus.

    EDIT1: Here are the latest updated apps from June 10th onwards, though I doubt it's anything from June 20 onwards... so that narrows it down to possibly 5 apps...:
    - Barcode Scanner - June 13
    - Duolingo - June 15
    - BaconReader - June 17
    - shomi - June 17
    - Authenticator - June 19
    - Company Portal (Microsoft inTune) - June 20
    - Adobe Acrobat - June 23
    - Yammer - June 23
    - SwiftKey Keyboard - June 23
    - Outlook - June 25
    - Whatsapp - June 25

    EDIT2: Tracing my steps backwards I've narrowed it down to the 15th, 16th, and 17th, which leaves:
    - Duolingo
    - BaconReader
    - shomi

    There's an update to Duolingo that says "bug fixes and improvements" which I'll try tonight to see if it stabilizes. Otherwise I can remove shomi and then BaconReader to see if that helps...

    EDIT3: Duolingo update did not fix. Router reset immediately. Uninstalling shomi now...
    EDIT4:shomi did not fix it. Router reset again. Resetting phone.
    EDIT5:went further and uninstalled barcode scanner and authenticator; no fix.
    07-06-2016 03:13 PM
  8. SpookDroid's Avatar
    I don't think it's the apps... in my case whenever that happened it was always the router or the router's firmware.
    dd1994 likes this.
    07-11-2016 05:03 PM
  9. fLaPjAk's Avatar
    Ya none of the apps did squat. There's a new system upgrade let's see if it fixes it - installing now.

    Edit: still restarting the router. I've given up and have just banned all s5 use on my home network lol
    dd1994 likes this.
    07-28-2016 05:57 PM
  10. fLaPjAk's Avatar
    Does anyone here have an XBOX ONE and/or PS4 that could be IP conflicting this? OP - what's your situation - still happening???
    08-02-2016 02:40 PM

Similar Threads

  1. Galaxy S5 all incoming calls being forwarded to voicemail
    By AC Question in forum Ask a Question
    Replies: 5
    Last Post: 06-24-2016, 12:34 AM
  2. Restrict certain wifi networks
    By Ramakrishnan V G in forum General Help and How To
    Replies: 6
    Last Post: 06-20-2016, 09:03 AM
  3. program won't work when there is no wifi connection to phone
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 06-17-2016, 03:00 PM
  4. Replies: 0
    Last Post: 06-17-2016, 01:34 PM
  5. My Moto G Reset Itself and Now I cant use it???
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-17-2016, 12:20 PM
LINK TO POST COPIED TO CLIPBOARD