1. Oscar G's Avatar
    Hi guys, I'm new to this forum so I hope this is the right place for my question. First off alĺ I have a Samsung Galaxy S5 neo.

    (Sorry for my bad english.)

    This is what happend: I'm in Spain for two weeks with some friends yesterday evening (the second day of our vacation) we had some fun and we decided to jump in the pool with our clothes on. But of course I forgot to take out my phone of my pants. When we got out of the pool I noticed it. I took my phone, but it didn't react: no screen, no vibrations, no notifacation light. I took off the back cover (it was a little bit wet inside) Then I took out the battery, the sd and sim card and I putted it in the sun (we don't had rice).After 3 hours it was getting dark and I decided to try my phone. And I was happy, because he worked 😃. I tried some things like camera, wifi, bluetooth and it was all good. So I turned it off and putted my sd and sim card back in and turned it on again. It asked my pin code so far so good, but then my phone said their was no service and the icon that show you if you have a good mobile network connection changed in something weird.







    I turned the phone on and off several times, took the battery out while it was on, tried 2 other sim cards, but it doesn't change (the sd card is working).
    I hope someone can help we with this problem en maybe know a solution or something.
    07-21-2016 04:40 PM
  2. mhinc's Avatar
    Hi guys, I'm new to this forum so I hope this is the right place for my question. First off alĺ I have a Samsung Galaxy S5 neo.

    (Sorry for my bad english.)

    This is what happend: I'm in Spain for two weeks with some friends yesterday evening (the second day of our vacation) we had some fun and we decided to jump in the pool with our clothes on. But of course I forgot to take out my phone of my pants. When we got out of the pool I noticed it. I took my phone, but it didn't react: no screen, no vibrations, no notifacation light. I took off the back cover (it was a little bit wet inside) Then I took out the battery, the sd and sim card and I putted it in the sun (we don't had rice).After 3 hours it was getting dark and I decided to try my phone. And I was happy, because he worked . I tried some things like camera, wifi, bluetooth and it was all good. So I turned it off and putted my sd and sim card back in and turned it on again. It asked my pin code so far so good, but then my phone said their was no service and the icon that show you if you have a good mobile network connection changed in something weird.

    https://gyazo.com/db8ecf6234525c930ddd9b900355917f

    https://gyazo.com/eb8ca0cc72bc32fd71b20dc0cf71f052

    https://gyazo.com/dd46fdaf0016619a12dc3f6725231081

    I turned the phone on and off several times, took the battery out while it was on, tried 2 other sim cards, but it doesn't change (the sd card is working).
    I hope someone can help we with this problem en maybe know a solution or something.
    Hey there, based on your images it's basically saying no service. Since you have tried 3 SIM cards and none work, it sounds like something to do with the SIM card port in the phone. May have got wet and caused some damage.
    When you don't have a SIM card in the phone does it say NO SIM?
    Wondering if maybe the radio is damaged as well for cell service in general.
    07-21-2016 10:40 PM
  3. jljecj's Avatar
    The circle with the lone through it is your do not disturb icon.
    07-22-2016 07:30 PM
  4. mhinc's Avatar
    The circle with the lone through it is your do not disturb icon.
    No it's actually not. It means NO SERVICE in this case because it's not detecting the SIM card
    07-22-2016 09:58 PM
  5. jljecj's Avatar
    My apologies then.
    07-22-2016 10:25 PM

Similar Threads

  1. Moderator, please delete this my post
    By developerAndroid in forum Tablet Apps
    Replies: 2
    Last Post: 08-22-2016, 05:47 AM
  2. Pokemon No Go - HTC Desire 320
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 07-26-2016, 04:39 PM
  3. No longer can access SnapTo files via USB
    By phonebr in forum More Huawei Phones
    Replies: 1
    Last Post: 07-24-2016, 05:11 PM
  4. No sound on Bose Bluetooth Speaker Paired with Galaxy Note 5
    By jenb9375 in forum Samsung Galaxy Note 5
    Replies: 1
    Last Post: 07-22-2016, 06:52 PM
  5. Replies: 0
    Last Post: 07-21-2016, 03:07 PM
LINK TO POST COPIED TO CLIPBOARD