1. SteveGPickering's Avatar
    Having used the S Health app on the S5 for 2 years now, I have been very happy about logging my food intake. Only today, it has stopped finding the food I search for. No Network Connection, it states. All other apps working fine. Several reboots, no avail. Any one else having this problem and what to do about it?
    01-11-2017 12:39 PM
  2. can3gxw's Avatar
    I have never used the app for tracking my food, only for my steps. It must have broken in a recent update if you've been able to use it up until recently. I just tried mine to add a can of diet coke. Diet coke came up in the list so I tapped on it. It spun for a few seconds then gave the same error "no network connection".

    No resolution, but at least it's not just you.
    01-11-2017 02:37 PM
  3. Sid_sid3's Avatar
    I am having similar issues with the s7 edge. It has been working fine up until today. Hopefully it's just a glitch they will fix asap.

    Update:- I've had an email from customer support saying;

    1. First, sync your information with your Samsung Account to make sure no data is lost. To do so, go to S Health > More/three vertical dots > Settings > Account > Tap on Sync Now.
    Afterwards, please go to Settings ->* Application manager -> All -> Tap on S Health -> Clear cache.

    2. If the issue persists, also tap on Clear Data (Settings > Application Manager > All > S Health >
    01-11-2017 03:48 PM

Similar Threads

  1. Replies: 1
    Last Post: 03-28-2017, 01:25 PM
  2. Replies: 3
    Last Post: 01-28-2017, 11:28 AM
  3. Replies: 2
    Last Post: 01-22-2017, 10:54 AM
  4. S Health Issue
    By Tmel14 in forum Samsung Galaxy Gear
    Replies: 3
    Last Post: 01-21-2017, 03:17 PM
  5. Replies: 7
    Last Post: 01-16-2017, 11:06 PM