1. Androidjake79's Avatar
    Hey Android Nation! New here. I typically consider myself at least somewhat technically inclined. But today I made a stupid decision that I fear cannot be reversed...

    I'm on a Samsung Galaxy S5 (whatever its current OS is I imagine) and was SICK of the endless update notices for my phone that won't leave till you comply. So I got Package Disabler Pro. It worked great! Thing is, while messing around I turned off Settings, and the Play Store. No prob, they can be turned back on via Package Disabler Pro I thought. I had stuff to do though, and promptly forgot. Later on I needed memory for an app so I deleted PDP by dropping the app into the trash bin via the Android home screen. It asked to confirm the uninstall, which I did. What I didn't realize was that apparently the only way to truly delete PDP was to uninstall via the actual PDP app. So now I'm stuck with disabled Settings and Playstore, and a hidden PDP app somewhere in my phone, making it so they don't appear. (I do however have the PDP Engine app that came with PDP, but that crashes on startup without PDP.)

    I'm really nervous about this... My phone isn't rooted, and I can't acess settings without the PDP app that was (at least on a surface level) deleted. Again, I realize this was really stupid on my end. Appreciate it if no one would rub that in haha.

    So far I've tried:

    1. Redownloading the PDP APK via the Chrome browser. (Thought maybe I could make the app appear again?) Problem is, you have to let apps with uknown sources through to install them. Which requires acess to the settings app, which is disabled due to PDP...

    2. Checking if these disabled apps were in the "show hidden apps" section on the homescreen. They weren't... Apparently PDP is still there somewhere holding my Settings and Play Store apps hostage.

    ANY help would be appreciated. This is not only embaressing, but frankly terrifying to someone who relies on his phone this much... Sad really lol.

    Hope all is well,

    - Jake
    06-23-2017 11:22 PM
  2. Androidjake79's Avatar
    I also emailed the creators, but I have more faith in groups like you. X)
    06-24-2017 12:06 AM
  3. Androidjake79's Avatar
    Thanks for the thought. I hope they do. If you know anyone or another way to help I'm open for anything. My phone's basically dead till I can acess Settings and Playstore. Or accessing PDP to fix this. Still waiting for them to respond. Did he use a special email? Or just the one on PDP's playstore page (one I tried)?
    06-25-2017 04:37 PM
  4. PJRed2008's Avatar
    FWIW, the reason you can't just delete apps like PDP is the required Administrative permission they have to do what they do. You had to approve that when it was installed. That permission needs to be removed in able to completely delete the app.
    06-25-2017 05:14 PM
  5. smvim's Avatar
    If all you did initially was delete the PDP icon from your screen the app itself should still be listed in your Apps menu. But iIt does sound like you were a little overzealous in disabling things on your phone. Reading through your initial posting I'd also be worried if you disabled other vital-to-Android services. You might want to give thought to just re-flashing the stock ROM, that's the only way to fully restore any Android OS components that you may or may not have disabled and/or removed. If you do things correctly and there are no other significant problems re-flashing a Samsung stock ROM won't delete your personal files (those are stored in their own dedicated, separate /data partition) but as you still have a semi-functional phone it is really important to back up your data. Flashing a stock ROM does not require rooting (custom ROMs do, along with installing a custom Recovery) but ROMs are specific to each model so there isn't any mix-and-matching involved. You need to use the ROM specific to your model and your carrier. What model of S4 do you have and which carrier?
    PJRed2008 and Androidjake79 like this.
    06-25-2017 06:54 PM
  6. Androidjake79's Avatar
    I believe I have the Samsung Galaxy S5 LTE. My carrier is Verizon.

    Overzealous haha. You're very kind at letting me know. I know for sure I disabled whatever file bugs you about the system updates (LOVE that you can't offload app storage onto the SD card) and the Playstore, and Settings. I do agree to your comment though haha. I'll definitely be more careful next time. But I truely appreciate all the help! Need to figure out how to do a full backup... Can you tell I'm new?

    The company that developed PDP got back and is trying to have me use ADB through terminal on my Mac. I believe my USB Debugging has to be on though, so I don't think that'll work. Also hesitant to run stuff throught terminal for fear I'll screw up my Mac.
    06-25-2017 10:14 PM
  7. Rockfordrd's Avatar
    Package disabler pro +,samsung galaxy S5 unlocked verizon hav diff carrier now can I disable all verizon apps without damaging ph ,tks
    09-02-2018 06:52 PM

Similar Threads

  1. LG G5 power button issue
    By Shadowhunta in forum LG G5
    Replies: 3
    Last Post: 06-26-2017, 11:34 AM
  2. Replies: 3
    Last Post: 06-25-2017, 12:07 PM
  3. Intermittent reception issues, not related to bars/connection
    By garybeckvt in forum Samsung Galaxy S5
    Replies: 3
    Last Post: 06-23-2017, 10:07 PM
  4. LG G5 power button issue
    By Shadowhunta in forum Ask a Question
    Replies: 0
    Last Post: 06-23-2017, 04:38 PM
  5. Replies: 0
    Last Post: 06-23-2017, 03:19 PM
LINK TO POST COPIED TO CLIPBOARD