1. Jmrec's Avatar
    Samsung s5 connected fine with old frontier wifi, Frontier bought verizon wifi in our area. Computer speeds slow. Terrible wifi. But cell worked ok. Now new Spectrum wifi. Computers better but cells are terrible. Get one and two bars. Any help?
    05-20-2018 12:46 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Is this a public wi-fi network covering the whole town, or are you talking about a home wi-fi network you set up using Spectrum as your ISP?
    05-20-2018 01:56 AM
  3. Jmrec's Avatar
    It's my home network. Just started with spectrum two weeks ago. Wondering if the newer router/modem and my Galaxy S5 is too old for the modem. I really don't want to spend the $ for new phone. I'm happy with my S5 and don't caRe about any of the newer features on new phones.
    05-20-2018 11:23 AM
  4. Rukbat's Avatar
    Signal strength has nothing to do with the age of the technology. Even an 802.11b modem would give you a strong signal, just a slow one.

    Make sure the router is set to 2.4GHz, not 5GHz.

    Get close to the router (a few feet) and see if the signal improves.

    Is the new router i the same place as the old one was?

    Are you working on different levels? A router upstairs and the phone in the basement, almost under the router?

    You're going to have to do some of the diagnosis, since we're not there to do it, and it has to be done there.
    Laura Knotek and B. Diddy like this.
    05-20-2018 12:53 PM
  5. B. Diddy's Avatar
    The first thing I'd do is reboot the router by unplugging its power for about 30 seconds, then plugging back in. See this guide for more ideas: http://forums.androidcentral.com/amb...-problems.html
    05-21-2018 02:29 AM
  6. Jmrec's Avatar
    Tried that and same thing. Called Spectrum and they said because it's an old phone. Does that make sense?
    05-21-2018 09:59 AM
  7. B. Diddy's Avatar
    I don't think the age of the phone should matter for this. Is it still slow if you boot into Safe Mode? https://support.t-mobile.com/docs/DOC-28456
    05-21-2018 11:29 AM
  8. Cosima1's Avatar
    Same situation. I set my phone to 2.4GHz, not 5GHz and that solved the problem.
    So happy to not have to get a new phone!
    I had previously tried wipe cache partition and a factory reset to no avail.
    Thanks for the help!
    06-17-2018 06:26 AM

Similar Threads

  1. Samsung Gear Sport wont turn on.
    By Android Central Question in forum Samsung Gear Sport
    Replies: 3
    Last Post: 05-20-2018, 06:12 PM
  2. Replies: 1
    Last Post: 05-20-2018, 02:22 AM
  3. Replies: 1
    Last Post: 05-20-2018, 02:09 AM
  4. It's a note 5, whats up with that?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 05-20-2018, 02:02 AM
  5. Need to remove Alarm Icon From Status too bar
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 05-20-2018, 01:58 AM
LINK TO POST COPIED TO CLIPBOARD