1. anon(36625)'s Avatar
    Edge Plus 6 on Verizon network. Since updating to Marshmallow last week, I have not been able to download or update apps while on my home network. Other apps works fine on my home network (browser, facebook, instagram). Youtube and Netflix have been problems though. My home network is working, as I am on it now as I type this. Its simply been the app store. I tried searching all over and found a thread that the S3 had a similar issue, but none of those resolutions solved my problem. Any thoughts?
    04-19-2016 08:43 PM
  2. anon(36625)'s Avatar
    Here's a caveat I just found. I can install an app to my phone if I select the app from the play store on my PC. If I use the app store on the phone, that still won't work. WTF?
    04-19-2016 09:09 PM
  3. Rastahfareye's Avatar
    Edge Plus 6 on Verizon network. Since updating to Marshmallow last week, I have not been able to download or update apps while on my home network. Other apps works fine on my home network (browser, facebook, instagram). Youtube and Netflix have been problems though. My home network is working, as I am on it now as I type this. Its simply been the app store. I tried searching all over and found a thread that the S3 had a similar issue, but none of those resolutions solved my problem. Any thoughts?
    I'm having the same issue after marshmallow update. I've tried factory reset and still no luck. After clearing cache and data from Google play services and Google play store in applications, play store will load app icons but still won't download. Play Music and Youtube don't work either.
    04-20-2016 09:27 AM
  4. jessm1378's Avatar
    I had the same issues...Here was the fix I found.


    Google "Google Play Services" from your logged in Google search bar on your phone, then select the Google App, and hit update! Easy peasy!
    04-20-2016 01:27 PM
  5. anon(36625)'s Avatar
    I had the same issues...Here was the fix I found.


    Google "Google Play Services" from your logged in Google search bar on your phone, then select the Google App, and hit update! Easy peasy!
    Unfortunately that didn't do the trick. The issue is only when on wifi. Using the mobile network works fine. It's got to be some wireless security setting, I just can't figure out what.
    04-21-2016 07:13 AM
  6. FlipJman's Avatar
    Edge Plus 6 on Verizon network. Since updating to Marshmallow last week, I have not been able to download or update apps while on my home network. Other apps works fine on my home network (browser, facebook, instagram). Youtube and Netflix have been problems though. My home network is working, as I am on it now as I type this. Its simply been the app store. I tried searching all over and found a thread that the S3 had a similar issue, but none of those resolutions solved my problem. Any thoughts?
    Thank God I'm not the only one having this same problem! YouTube won't load videos and the Google play store doesn't download updates at all. Ive done a master reset (power off the device, press and hold Volume Up + Home Key + Power Button all at the same time, release on andriod loading screen, then select master rest option) that did not resolve the issue.

    I know my home WiFi connection is not the problem as all my other devices work flawlessly (MacBook Air, iPad, Windows PC Laptop, Xbox One, etc.)

    Please tell me you have found a solution for this issue. (Verizon Wireless 32GB Samsung Galaxy S6 Edge +).
    04-23-2016 05:54 PM
  7. LanceAllan's Avatar
    I have heard alot of marshmallow users are having issues with their routers using ipv6, seems disabling ipv6 in router settings and just using ipv4 has fixed alot of issues.... Worth a try...?

    Sent from my Adamantium™ S7 edge
    tube517 likes this.
    04-23-2016 06:08 PM
  8. nelbert10's Avatar
    Im having the same issue on my home wifi with my Note5. The issue seem to have started a couple of days ago, well after upgrading to 6.0

    Posted via the Android Central App
    04-24-2016 02:55 PM
  9. nelbert10's Avatar
    I disabled IPv6 on my router and that seem to have resolved my issue.

    Posted via the Android Central App
    tube517 likes this.
    04-24-2016 09:16 PM
  10. LanceAllan's Avatar
    Sweet! Good to hear

    Sent from my Adamantium™ S7 edge
    04-24-2016 09:22 PM
  11. Moko1010's Avatar
    Didn't work on my end...the crazy thing is I can download apps from the Galaxy Apps app (like Google Playstore) on home wifi but nothing from GPS...I can go to Starbucks and use there wifi and works fine but at home the GPS dosent work but surfing and everything else does....So frustrating
    04-25-2016 05:24 AM
  12. ssam0007's Avatar
    I had this problem and it traced back to IPv6 addressing. My cable modem apparently cannot interface properly with the cable internet's IPv6 assignment. What ends up happening is the phone requests an IPv6 address and the router either hands out some bogus crap or nothing based on what it thinks the cable modem is telling it. It messes up the phone's ability to talk to Google or YouTube since they have IPv6 addressing implemented. Shutting off IPv6 address assignment on my router fixed this issue.
    LanceAllan likes this.
    06-12-2016 09:31 PM
  13. mshafib's Avatar
    I have the same problem in my samsung galaxy a5. After upgrading to marshmallow i can't download apps from play store and also all other google related services are not connecting through my wifi home network. But able to download through other wifi connections and mobile network. Other phones and tabs are working fine on same network. I factory restored both modem and phone but still the same problem exist. Pls tell me if anybody knows a solution.
    01-11-2017 12:28 PM
  14. anon(10298843)'s Avatar
    Tell you what, guys. I came on here for the same issue, but nothing seemed right. So, I went to 'update all' manual button and got the dreaded "there's no room left" message. So checked my storage and had over 1.6Gb of cached memory, so cleared that and all 14 apps downloaded no bother.
    Just a thought, might be the issue for some of you, as the IPv6 isn't the solution for some and it certainly wasn't for me.
    08-18-2017 07:02 AM
  15. Grivian Verrel's Avatar
    this might be late, but i'm just leaving this comment for those that are still experiencing this problem, disabling the IPv6 from my access point works like a charm. Hope that'll be a fix for you guys too and a big thanks to LanceAllan for the solution!
    12-19-2017 05:33 AM
  16. saxxman's Avatar
    Looks like an old thread, but I found i9t via search and turning off the IPv6 worked for me.
    06-05-2020 09:58 AM

Similar Threads

  1. Replies: 3
    Last Post: 04-22-2016, 10:43 PM
  2. s6 won't connect to my wifi but all other devices do
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-20-2016, 01:33 AM
  3. Mobile data not working after reset
    By Enriko kiko in forum Ask a Question
    Replies: 0
    Last Post: 04-19-2016, 08:42 PM
  4. Replies: 0
    Last Post: 04-19-2016, 07:53 PM
  5. S6 camera protruding. Not flush with the phones back cover.
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-19-2016, 07:23 PM
LINK TO POST COPIED TO CLIPBOARD