Save big + get 3 months free! Sign up for ExpressVPN today

  1. nadoxq8's Avatar
    i got at&t samsung edge and i lose 1% every 3 minutes, and only wifi and bluetooth are on. is this normal or should i return it ?
    04-16-2015 11:10 PM
  2. shadow82x's Avatar
    Is that on-screen time? 3 * 300 / 60 = 5 hours screen-time which isn't bad. If that includes standby/idle time, that isn't too good.
    04-16-2015 11:31 PM
  3. skinneejay's Avatar
    Do yourself a favor and do a factory reset/wipe from the recovery mode. I did it after the update and things have gotten much better. Also disable any apps that came pre-installed your not using.
    04-17-2015 11:59 AM
  4. mariuspg6's Avatar
    i got at&t samsung edge and i lose 1% every 3 minutes, and only wifi and bluetooth are on. is this normal or should i return it ?
    Settings, quick settings, data usage, mobile data, turn off enhanced LTE services.

    This is what fixed it for me. This is only for Att
    04-17-2015 12:28 PM
  5. michaelsalter92's Avatar
    Just isnt good enough my 6plus would still have around 40% by now. This is not good enough. I screenshottes that image attached 18:47 it is now 18.51 and look at the battery lol

    Posted via the Android Central App
    Attached Thumbnails insane battery drain-780.jpg   insane battery drain-781.jpg  
    04-17-2015 12:52 PM
  6. TheGeekNextDoor's Avatar
    Doing the full factory reset is the best route to go. I had similar issue. Had to charge 3 times a day to make it through the day with limited use.

    I reset last night and now have 88% battery after 5 hours with 27 minutes of phone calls and 5-10 minutes of light use on the phone.

    Not sure I can hope for much better right now.

    Anyone having crazy battery drain issues should just reset. It is almost as if the carriers screwed something up and the reset fixes it.
    04-17-2015 01:10 PM
  7. Jon_Doh's Avatar
    Turn off enhanced LTE and wifi scanning. Disable all Samsung apps that sync.
    04-17-2015 02:10 PM
  8. erasat's Avatar
    Just isnt good enough my 6plus would still have around 40% by now. This is not good enough. I screenshottes that image attached 18:47 it is now 18.51 and look at the battery lol

    Posted via the Android Central App
    You seem to have the Google Play Service Lollipop Bug, look for my Thread on the regular S6 forum to read about it and to learn what you can do to at least try to stop the service from keep draining your battery.

    Also, your Email Sync doesn't look normal, check your Email Account and Sync settings, something is getting stuck there.
    04-17-2015 02:21 PM
  9. nadoxq8's Avatar
    i turned off the enhanced LTE, and see how it does. then i will try resetting my phone.
    04-17-2015 02:43 PM
  10. michaelsalter92's Avatar
    I cant find the s6 thread i am on my phone i searched. I just did a full factory reset but seems to be dying quick still. What should i do about gmail sync ? I use the email app for my hotmail and gmail ?

    Posted via the Android Central App
    04-17-2015 03:39 PM
  11. nadoxq8's Avatar
    Update: since my last post(10 hours ago), i lost 40% only while bluetooth, lte , wifi, auto brightness is on. turning off lte enhanced fixed it !!!!

    thanks !
    04-18-2015 12:55 AM
  12. sfla99's Avatar
    I have done the same as above but where do I find the WiFi scanning option?

    Sent from my SAMSUNG-SM-G925A using Tapatalk
    04-18-2015 08:34 AM
  13. sydneycooper1979's Avatar
    open up wifi, then click more>>advanced>>uncheck always scanning
    04-18-2015 08:45 AM

Similar Threads

  1. Gear S battery issue
    By hichem jerbi in forum Samsung Gear S
    Replies: 35
    Last Post: 11-01-2016, 07:37 PM
  2. Replies: 6
    Last Post: 08-30-2016, 08:10 AM
  3. Battery Drain Fixed by Samsung!!!
    By Techno-guy in forum Samsung Galaxy S6
    Replies: 208
    Last Post: 04-19-2015, 09:54 AM
  4. Google Play Services drain bug
    By erasat in forum Samsung Galaxy S6
    Replies: 11
    Last Post: 04-17-2015, 07:24 AM
  5. Battery on 5.1 drains too fast
    By damansh in forum Google Nexus 5
    Replies: 2
    Last Post: 04-17-2015, 06:29 AM
LINK TO POST COPIED TO CLIPBOARD