Sign up now for Disney+
  1. nikelegends's Avatar
    Hi first post and with my first android phone, galaxy s6 edge. Still trying to figure out a few things but there's one thing driving me insane, notifications on whatsapp. I have the settings within the app to show no popup notification. However I noticed this morning if I had the screen on anything other than whatsapp. I'd get an icon as a heads up notification of whoever sent me the message then when that disappeared a little whatsapp logo would appear on the top bar. Then later on today the person or group icon has now changed so it shows me the message as a heads up notification even though I have popup settings set to off within the app. Now these heads up display notifications are annoying because you either go to the app or dismiss it completely and hope to remember it later. Any ideas guys. I managed to get screenshots but hopefully someone will be able to help first. I also noticed that my phone and keyboard stopped making sounds even though all settings where set to on and my phone was on loud? Help would be much appreciated. Thanks
    04-26-2015 12:17 PM
  2. nikelegends's Avatar
    Here are a couple of screenshots to show. The happens even with popup set to off within app settings and priority isn't turn on either. Also I have no idea how it changed from an icon to an icon with message..
    Attached Thumbnails Annoying Whatsapp notifications.-1430065841782.jpg   Annoying Whatsapp notifications.-1430065860990.jpg  
    04-26-2015 12:32 PM
  3. GWaLL13's Avatar
    What are your notification settings within the app? Are popups enabled?

    Via the Android Central App on my S6 Edge
    04-26-2015 02:25 PM
  4. nikelegends's Avatar
    Popups set to off. Have deleted and installed several times but still get those notifications.
    Attached Thumbnails Annoying Whatsapp notifications.-1430076747554.jpg  
    04-26-2015 03:33 PM
  5. GWaLL13's Avatar
    So after digging I've learned it's a feature in lollipop. I found this suggestion :

    It's part of Lollipop's new notification cards. If you don't want them to show up in other apps, you can use the Settings > Sound & notifications > Interruptions to turn them off. Use the When calls and notifications arrive setting to change to Always interrupt / Allow only priority interruptions / Don't interrupt.

    Via the Android Central App on my S6 Edge
    nikelegends and uktivo like this.
    04-26-2015 04:25 PM
  6. nikelegends's Avatar
    Thanks. I presume from interruptions you mean do not disturb? Will give it a try anyway! Until the release android 5.1 where you can swipe them up but keep notifications or if it's a bug with whatsapp? The other thing I've noticed is when the screen is off and a notification comes in it doesn't light the screen up to show it apart from calls and sms
    04-26-2015 04:39 PM
  7. nikelegends's Avatar
    BTW heads up notifications are still showing on do not disturb mode and can only be swiped to dismiss
    04-26-2015 04:42 PM
  8. GWaLL13's Avatar
    That's weird, I've never seen those notifications before.

    Via the Android Central App on my S6 edge
    04-26-2015 05:13 PM
  9. nikelegends's Avatar
    I might try a factory reset. That's the only thing I can think of now. I don't know how it changed from just the icon to ones with the message but I can't put it back again now 😑
    04-26-2015 05:51 PM
  10. Mairtin Sherlock's Avatar
    any joy on this ? ? i have the same issue very annoying
    05-14-2015 08:47 AM
  11. sn3s's Avatar
    Same here!
    05-14-2015 01:04 PM
  12. GWaLL13's Avatar
    I researched this further. Apparently it is lollipop that causes this notification annoyance and the only option is to cancel app notifications for those apps all together in the app manager. You'll still see a notification dot on the app icon itself but the phone won't vibrate or ring or even give you anything in pull down notifications.

    Via the Android Central App on my S6 edge
    05-15-2015 01:09 AM
  13. ilordvader's Avatar
    So after digging I've learned it's a feature in lollipop. I found this suggestion :

    It's part of Lollipop's new notification cards. If you don't want them to show up in other apps, you can use the Settings > Sound & notifications > Interruptions to turn them off. Use the When calls and notifications arrive setting to change to Always interrupt / Allow only priority interruptions / Don't interrupt.

    Via the Android Central App on my S6 Edge
    I don't see this Option - Interruptions to turn them off ?
    05-17-2015 02:27 PM
  14. GWaLL13's Avatar
    I don't see this Option - Interruptions to turn them off ?
    Go to app notifications and then find whatsapp, and turn off the notifications for whatsapp

    Via the Android Central App on my S6 edge
    05-19-2015 11:23 PM
  15. luedges's Avatar
    Do you solve the te problem?

    please tell me how
    05-26-2015 02:37 PM
  16. HushDev's Avatar
    Shameless plug and a request for your help!

    I wrote Hush.Ninja to solve the problem of annoying WhatsApp notifications. HOWEVER... I am an independent developer so don't have access to lovely new devices like the Galaxy S6 Edge. If anyone would be prepared to help me test and see if it solves this problem, I'd be super-grateful.

    You can find Hush.Ninja in the Google Play store.
    07-27-2015 05:03 AM
  17. t23augusto's Avatar
    Guys is there any way to go back to the old top bar notifications and not the big ones that drops down over the content as shown in the PrintScreen up here?
    07-30-2015 04:58 PM
  18. Mabohlokoa's Avatar
    I am not happy with being the second party reading my whatsapp as it pops up on the screen whenever I receive the message. How can I do to prevent this?
    11-03-2016 03:55 AM
  19. 4577's Avatar
    Nike.... I really want to hug you....... I really face this problem...... Worst thing from a famous app.... This is high time to go for an another option.... wahtsapp decline

    Meanwhile i watch youtube this ******* notificatioN cover my screen...... I got angry and hitted my mobile on the wall!
    05-01-2017 02:33 PM
  20. mujtaba1's Avatar
    Android Lollipop, introduced an array of new features and aesthetics that pleased many loyal users. One of those additions being the new heads-up notifications. Taking subtle inspiration from iOS, these notifications are visually appealing and can be easily dismissed or expanded, but they do require that you take an action before they go away immediately. Of course, you can always wait 10 seconds for them to disappear, but that can be really annoying if you're in the middle of a game or editing a photo.



    Unfortunately, there's no setting that lets you dictate how notifications will come in. On an iPhone, you can choose either Alerts, Banners, or None, but in Android Lollipop, it's heads-up or no notifications at all.

    But this is Android we're talking about, so when Google misses a beat, a developer is usually there to fix it, which is exactly what Jawomo's new app does. Lollipop users can still receive their notifications without the interruption of obtrusive heads-up alerts, much like the old-style ticker notifications we had on KitKat. And unlike other methods of disabling these notifications, Jawomo's app doesn't require root-level access.


    Do tell me after its done>
    09-17-2017 01:45 PM
  21. Thomastursh's Avatar
    Whatsapp Calls Constantly Disturb us at times that are inappropriate, even unsafe such as Driving, please sign this petition to make sure Whatsapp honours the Do Not Disturb option on our Mobile phones or it introduces its own Do Not Disturb option

    Petition Link: http://chng.it/7TsfdP8S
    04-10-2019 07:50 AM

Similar Threads

  1. Unable to remove Voicemail icon in notification bar.
    By tinman9898 in forum Samsung Galaxy Ace
    Replies: 2
    Last Post: 07-12-2015, 09:30 AM
  2. How can I get status bar notifications only?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-27-2015, 02:13 AM
  3. How do I set up voicemail notifications on my Android phone?
    By AC Question in forum Misc. Android Phones
    Replies: 1
    Last Post: 04-26-2015, 05:42 PM
  4. Replies: 0
    Last Post: 04-26-2015, 05:13 AM
  5. Replies: 0
    Last Post: 04-26-2015, 04:11 AM
LINK TO POST COPIED TO CLIPBOARD