1. RCLO's Avatar
    When I use the USB cable to connect my S6 Edge to my Win7 PC, Windows says it's an unrecognized device. Device Manager shows an unknown device under the USB Controllers, for which I checked for an updated driver, but the current driver is indicated as the best. I tried downloading the Mobile USB Composite driver, but it doesn't install or fix the problem. How can this be resolved?
    05-08-2015 11:38 PM
  2. moheeb's Avatar
    did you download the usb driver from Samsung website?
    Download Center: Download Software, Firmware, Drivers & Manuals | Samsung

    if this is the case, try to delete all unknown devices and restart your machine.
    05-09-2015 12:38 AM
  3. nukexxx's Avatar
    Yes, the driver was downloaded from the Samsung website. I just noticed that the phone connected properly on my other Win7 PC with no issues, so it's something in the first PC's configuration. Can I simply uninstall USB drivers, like the USB Composite Device driver, and let Windows rediscover the devices?
    05-09-2015 02:35 PM
  4. RCLO's Avatar
    I don't understand why my GS6 connected seamlessly to one of my Win7 laptops, but not the other. The GS6 connects to the 2nd laptop via Bluetooth, but not USB.

    Is there a safe (and easy) way to clean up whatever corruption is causing the laptop to not recognize the GS6?
    05-09-2015 08:17 PM
  5. pmokover's Avatar
    I had the same problem with a S4 and S5 on one of my Win7 PCs. It turned out to be the security settings (permissions) for the C: drive in this one PC. Once I relaxed them a bit the problem disappeared. I did not have to make any changes on the phone itself.
    05-12-2015 04:59 PM
  6. barondebxl's Avatar
    What do you mean man?

    Posted via the Android Central App
    07-03-2015 11:54 PM
  7. Charlie Brown11's Avatar
    go to device manager, click on the banged out s6, and then select to update drivers automatically
    07-23-2015 09:32 PM
  8. k1ll5w1tch's Avatar
    I've downloaded the driver multiple times. Removed the yellow signed universal serial bus (USB) controller from my device manager, restarted, then downloaded again. Same thing; no driver found. Device driver software was not successfully installed.
    08-12-2015 05:55 PM
  9. roy_geejay's Avatar
    I fell that you better first connect your phone then check for any changes in the device manager. If it happens try to target the device in the list and uninstall the drivers. Then remove your device and reinsert and check if it installs the drivers automatically

    Posted via the Android Central App
    08-12-2015 10:44 PM
  10. Romuald D's Avatar
    Seems to be the orignial samsung USB cable... try with any others and it might works... I use the one of my digital camera and it works perfectly
    10-02-2015 07:08 AM
  11. voodoochile333's Avatar
    The solution I had was:

    Assuming you have enabled developer optios/usb debugging
    1. Download Smart Switch to PC software - not the smart switch normal version (this is just for android to android)
    2. Load Smart Switch to PC software and hit more (in top right)
    3. Select Reinstall device driver
    4. Connect the original white Samsung USB cable - doesn't seem to work with other cables I have.
    10-03-2015 06:30 AM
  12. theloligarchy's Avatar
    I just switched the USB cable to the one that came with the phone and it worked.
    07-30-2016 03:18 PM
  13. Nedney19's Avatar
    I registered, because I've been having this issue for awhile, I've tried all suggestions, but nothing is working. When I first got the phone, (a little over a year ago), I connected to my laptop (Windows 7) with no issues - transferred pictures and music. A short time later, I'm not exactly sure when it stopped connecting, but it was long before the last update, the laptop just stopped recognizing my phone.
    I've changed the setting to MTP in Developer Options. I've tried both USB ports on the laptop. The phone will light up when I connect to the laptop, but nothing else. Even when I have it set to "Charge", it will light up, but will not charge. I've updated my drivers. I've tried Smart Switch. Nothing is working.
    I feel like this is a simple setting issue, but any and all suggestions are appreciated. Thanks in advance.
    08-13-2016 11:47 AM
  14. Larson Anonimowy's Avatar
    I have something similar to your problem so try this .
    --->go to settings --->developer options-->and check your" Usb conifiguration" I had changed for charging insted of MTP (Media transfer Protocol)
    Mark MTP and try to connect a cable
    After that my laptop and Pc connect with the S6
    Good luck
    09-14-2016 09:56 PM

Similar Threads

  1. Help 5.0.1 Note 4 edge
    By Shane Loniewski in forum Android 5.0 Lollipop
    Replies: 1
    Last Post: 05-17-2015, 11:40 AM
  2. Why won't my Galaxy S4 update?
    By AC Question in forum Ask a Question
    Replies: 3
    Last Post: 05-10-2015, 07:26 PM
  3. Replies: 1
    Last Post: 05-10-2015, 12:03 AM
  4. Samsung Galaxy reboots when USB plugged in, why does it do this?
    By AC Question in forum Samsung Galaxy S3
    Replies: 1
    Last Post: 05-09-2015, 11:57 PM
  5. Cannot Upgrade to ICS via OTA or LG Tool
    By mel2000 in forum LG Spectrum
    Replies: 1
    Last Post: 05-09-2015, 03:32 PM
LINK TO POST COPIED TO CLIPBOARD