1. suecalt's Avatar
    When I try to add one of my contacts to "My People" it goes to my contacts but says "No Contacts" even though I have hundreds of contacts. Why won't my contacts link to "My People"? It is frustrating not to be able to use this feature.
    Khaled Alkayed likes this.
    07-10-2015 08:56 PM
  2. Khaled Alkayed's Avatar
    I have same problem after last update
    07-26-2015 02:05 AM
  3. suecalt's Avatar
    Are you on a microsoft exchange server? That is the problem for me. After a response from someone on another forum, I was able to add people that were saved to my device, or through google and samsung contacts. Try that and see if it works for you too.
    07-29-2015 01:20 AM
  4. suecalt's Avatar
    Unfortunately, it is a deeper problem than that.
    07-29-2015 01:21 AM
  5. Real U3's Avatar
    I have the same problem with contacts from Microsoft EAS. Do you have more details about how to fix the problem? I've been trying to deal with it for months. Thank you in Advance.

    Ahmed.
    07-29-2015 09:14 PM
  6. suecalt's Avatar
    I don't think there is a way to fix it other than to wait for an android update where hopefully they will fix the problem. In the meantime, when you go to enter a new contact you have the option at the top where to save it - SIM card, Device, Google, Microsoft Exchange, Samsung…if you save it anywhere but the Microsoft exchange, you will be able to add it to My People
    07-30-2015 08:22 PM
  7. Real U3's Avatar
    Actually not. Last night I copied some contacts to the device using SmartSwitch, and I'm still not seeing any on People Edge. It is Samsung, not Google, who need to fix it. It's a Samsung feature. Ever sine I switched to Android (3 months ago), I'm regretting my choice of Samsung!
    07-30-2015 10:00 PM
  8. Audalicious's Avatar
    I had the same problem, but i fixed it quite easily by going into Contacts - More - Settings - Import/Export Contacts - Export to SIM card.

    When you have done this, "My People" will be able to find your contacts straight away, granted you now have doubles of them all.
    -- BUT FEAR NOT--
    This can easily be resolved by simply going back to your Contacts - More - Settings - Contacts to Display - Here you just choose the right account you
    would like to use.

    (Exporting to the SIM card is so you can exclude any online servers and communication errors, when you are searching for contacts through My People)

    This worked for me and the few friends i have whom i shared this fix with.
    Hope it works for you too. Its easy and takes maximum 1 minute.
    08-08-2015 09:48 AM

Similar Threads

  1. My youtube isn't working
    By Angelica Cortez in forum Ask a Question
    Replies: 5
    Last Post: 07-24-2016, 09:50 PM
  2. Replies: 2
    Last Post: 07-11-2015, 11:07 AM
  3. Replies: 4
    Last Post: 07-10-2015, 09:48 PM
  4. Replies: 1
    Last Post: 07-10-2015, 08:52 PM
  5. How can I use my LG G3 through my computer via USB?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-10-2015, 08:40 PM
LINK TO POST COPIED TO CLIPBOARD