06-10-2019 05:33 AM
33 12
tools
  1. Tim Caldwell's Avatar
    I have notification sounds turned on for various APPS (e.g., email, FB). When the screen is off, it seems like more often than not I don't receive an alert when I receive emails/FB updates. Only when I wake the screen up & swipe my fingerprint that "location" shows up & I suddenly get my alert notification sound that I have email. Kind of useless since I have to open up my device to see if I have any notifications.

    Anyone else seeing this? or know of a fix for this? I honestly think this has SOMETHING to do with Location services, but not sure.

    Thanks in advance.
    06-07-2015 09:08 AM
  2. jskinvest's Avatar
    This happens with me also. I figured out that it only happens when WIFI is on. When wifi is off notifications do show up while screen is off. Also this does not happen with all wifi locations. In my home it works fine. But, for example, when I am somewhere else and on another wifi network notifications fail to show up while screen is off. So I would conclude that it has something to do with the wifi network you are on. Try disabling wifi and let me know if your notifications start appearing in sleep mode.
    06-07-2015 09:59 AM
  3. Tim Caldwell's Avatar
    Thanks ... I'll try that and let you know.
    06-07-2015 10:04 AM
  4. Tim Caldwell's Avatar
    So I just tested this .... and you're right -- when WiFi is ON, I no longer seem to get notifications. It behaves like it doesn't even CHECK or acknowledge email(s) coming thru when it's in Sleep mode. With WiFi turned OFF, I get those notifications instantaneously. A "bug" now doubt.

    Thanks
    06-07-2015 10:34 AM
  5. jskinvest's Avatar
    I also experienced that on my old galaxy s4 running kitkat. So I think it is an issue with a specific wifi frequency. Still, google or Samsung should be able to fix it given that this has been going on for quite some time.
    06-07-2015 10:37 AM
  6. Javier P's Avatar
    Just in case. Check in the WiFi advanced settings that you have "always" selected for the WiFi while sleep option.
    06-07-2015 10:42 AM
  7. jskinvest's Avatar
    Yes I always have that checked. Does not make a difference.
    06-07-2015 10:44 AM
  8. Javier P's Avatar
    That's a funny bug. There are some reports of S6 having some problems with WiFi. They are not exactly the same as yours but you could try some of the fixes. Check your power saving options in the settings. Also, some carriers have a feature called Smart WiFi and some people fixed their problem after disabling it. Another cause for WiFi problems was the Smart network switch.
    06-07-2015 11:37 AM
  9. Tim Caldwell's Avatar
    FYI, I already had the "Always" set in option for WiFi ... very strange issue.
    06-08-2015 08:42 AM
  10. gsheremeta's Avatar
    Happens to me too. Definitely a widespread issue. I'm stock on AT&T, 5.0.2 I have a black 64. Anyone here use a wireless charger? I typically let my phone sit in a wireless dock at my computer.

    Lots of threads out there about this. I posted one on reddit (/r/galaxys6) before finding this one. One of the xda threads has a Samsung case number in there. Please call Samsung, because I don't think they know how widespread this issue is!
    06-21-2015 07:51 AM
  11. gsheremeta's Avatar
    Who can we ask to make this sticky, because it's widespread but has no awareness.
    06-21-2015 08:11 AM
  12. joe_fresh's Avatar
    Who can we ask to make this sticky, because it's widespread but has no awareness.
    How is it "widespread" when I only see a couple of people on this thread who have the problem? I don't have this problem.

    Posted via Android Central App nexus 7
    06-21-2015 08:20 AM
  13. felloffthetruck's Avatar
    I exchanged 2 Verizon S6's over this problem and finally got one that works.

    One of the first things you can do to help the problem is uninstall Facebook and never look back. Facebook is one of the worst apps that will screw up notifications on the S6 every time. Just what I think.
    06-21-2015 08:37 AM
  14. gsheremeta's Avatar
    One of the first things you can do to help the problem is uninstall Facebook and never look back. Facebook is one of the worst apps that will screw up notifications on the S6 every time. Just what I think.
    Yeah, but my wife's S6 is working fine with Facebook. This appears to be an OS issue.

    And you're the first person I've heard about with it on Verizon. Everyone else suffering from this is on AT&T.
    06-21-2015 08:40 AM
  15. Tim Caldwell's Avatar
    FYI, I was experiencing this immediately after getting the phone (S6). While FB was pre-installed, I had yet to set it up - and was getting this issue (no EMAIL notifications when screen is off). On VERIZON btw.

    and to be clear, it's only the EMAIL notifications that are now coming thru ... Notifications for Timers, Text msgs, Calendar, etc are all working fine .... It's just EMAIL msgs (on several email accounts - not just 1).
    06-21-2015 08:51 AM
  16. gsheremeta's Avatar
    and to be clear, it's only the EMAIL notifications that are now coming thru ... Notifications for Timers, Text msgs, Calendar, etc are all working fine .... It's just EMAIL msgs (on several email accounts - not just 1).
    Because those are the ones using push (GCM). Texts are SMS and not related to GCM. Calendar notifications are cached locally.

    If you have Google Hangouts, you'll see that those notifications are also affected by this bug. My wife and I use that for text, so if I'm the store and she needs something extra, sorry honey!
    06-21-2015 09:40 AM
  17. pst23's Avatar
    was there ever a solution to this? Same issue on the Note 5
    08-27-2015 05:26 AM
  18. bharath1001's Avatar
    I have an S5 and an S6 and they both are AT&T and they both have the same issue. No notifications from any apps when the screen is off. Facebook, whatsapp,hangout... With powersaving mode on and off. Checked the advanced WiFi settings and it says always. But with WiFi turned off it sems to work.
    09-05-2015 11:01 AM
  19. tracker2208's Avatar
    I have a Sprint S4 that only did this on certain routers. I found 2 solutions. 1st is turn Wifi off while sleeping, but that is not ideal. The second is, if you have a rooted phone, installing "[ROOT] Disable IPv6" from the app store. Now works perfectly.
    10-29-2015 11:16 AM
  20. dwight spencer's Avatar
    This is relatively new behavior on my galaxy s6. I'd say it was during a recent fb.messenger update, but that seems to update nearly daily as of late. I believe this also affects google hangouts. For example, I had a facebook messenger message instantly notify early this morning, but during the afternoon, messages did not notify, until I woke the phone up.

    I'll mention that it seems to happen regardless of whether i'm no cellular data or wifi. wifi settings / advanced, during sleep is "always on".
    11-23-2015 11:03 AM
  21. BaasFrancois's Avatar
    Hi, I had the same problem with my samsung S6, after 10 mins of an off screen my notifications stopped coming through. I then went to settings - data usage and set all the apps to not have a data restriction, especialy the samsung push service, rebooted my phone and then i always received notifications didnt mater how long my screen was off for. Hope this will help some people.
    11-24-2015 06:13 AM
  22. welchkristina's Avatar
    Did anyone figure this out? I have the exact sam problem on my S5 - but only since it installed a new update
    12-02-2015 09:26 PM
  23. Jandieg's Avatar
    Same here, when app is left in foreground and screen off. The push arrives but no sound, no nothing...
    12-14-2015 02:58 AM
  24. d4005's Avatar
    I had this issue, where whatsapp stopped receiving messages and whatsapp web couldn't communicate when the phone had slept for a certain number of minutes, and the only way to get it working again was to wake up the phone (and/or open whatsapp).

    The solution I found was to go into Settings -> Battery -> Power Saving / Ultra Power Saving. Either disable it completely, or disable it only for Whatsapp. After looking through the list of apps that were "being power-saved" I decided to disable the whole thing. I never currently reach a low battery status in my daily usage so I doubt it's an issue. If it's an issue for you, maybe you'll want to selectively disable it per app.
    lucianus_luciferus likes this.
    09-06-2016 06:33 AM
  25. kevinf28's Avatar
    i just solved the problem. there is a setting under lock screen "automatically lock after sleep". set to "immediately". i had mine as 5 minutes so i wouldn't have to keep unlocking phone.. until the lock screen app takes focus, hangouts thinks it's still open, even though the screen is off. that's why there is no notification
    09-20-2016 06:51 PM
33 12

Similar Threads

  1. Replies: 10
    Last Post: 06-13-2015, 12:49 AM
  2. My S Pen stopped working, how can I fix it?
    By Hikaru Hitachine in forum Samsung Galaxy Note 3
    Replies: 1
    Last Post: 06-11-2015, 07:13 AM
  3. Major Samsung Galaxy s5 Screen Damage?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-11-2015, 06:58 AM
  4. Replies: 2
    Last Post: 06-07-2015, 12:48 PM
  5. How do I fix my Droid Mini screen after it got wet?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-07-2015, 11:01 AM
LINK TO POST COPIED TO CLIPBOARD