1. KelseyRo4's Avatar
    Whenever I go to type in a contact to send a text message to, a whole bunch of contacts show up. I'm talking like every single email address I have ever sent an email to, and names and numbers I haven't even used in a LONG time. However, in my phone's contacts list I only have the contacts I actually use. Why is it that when I go to type in a recipient in a text message, all these past contacts show up instead of just the contacts I have saved in my phone?

    Posted via the Android Central App
    06-11-2015 05:23 AM
  2. MPSecuritylabs's Avatar
    You must be sync-d all the contacts before, go to setting - accounts - un-sync the accounts which are required.

    Go-to People app or contact app - say display only Sim or phone contact what ever you wanted.

    Make it easy mate..
    06-11-2015 05:37 AM
  3. KelseyRo4's Avatar
    You must be sync-d all the contacts before, go to setting - accounts - un-sync the accounts which are required.

    Go-to People app or contact app - say display only Sim or phone contact what ever you wanted.

    Make it easy mate..
    Did both of those and still didn't work. My contacts app only shows the contacts I want. The problem is when I send a text message it shows hundreds of emails and old contacts

    Posted via the Android Central App
    06-11-2015 07:22 AM
  4. kjjb0204's Avatar
    Try clearing cache on contacts app in app manager settings? Sounds like it's caching your recently used email addresses.

    Posted via the Android Central App
    06-11-2015 08:22 AM
  5. KelseyRo4's Avatar
    Try clearing cache on contacts app in app manager settings? Sounds like it's caching your recently used email addresses.

    Posted via the Android Central App
    Tried it. Still nothing

    Posted via the Android Central App
    06-11-2015 05:44 PM
  6. KelseyRo4's Avatar
    I'm going to try going on google from my computer later and manually deleting all these contacts from there. I think that's what's causing it. All 490 of them x_x

    Posted via the Android Central App
    06-11-2015 05:54 PM
  7. makaroni's Avatar
    Go to contacts and hit "more" in the right upper corner. Then hit the settings. Then hit contacts to display and just hit Google. Then only the contacts in Google will show. Not all the other ones and email addresses. Try that

    Galaxy S6 Gang
    06-11-2015 06:01 PM
  8. erasat's Avatar
    Whenever I go to type in a contact to send a text message to, a whole bunch of contacts show up. I'm talking like every single email address I have ever sent an email to, and names and numbers I haven't even used in a LONG time. However, in my phone's contacts list I only have the contacts I actually use. Why is it that when I go to type in a recipient in a text message, all these past contacts show up instead of just the contacts I have saved in my phone?

    Posted via the Android Central App
    Try with what has been suggested but I think it will still show all your Contacts, not just Google's when using the default messaging app, at least that's what I remember it did before I disabled it and stayed with Textra for good.

    I've been using Textra since last year but decided to give it the Default app a try, but this was one of the things that I experienced that push me to even disable it and go back to Textra. So try the suggestions that has been given here if it works for you also, great, but I think your only option will be a third party app and one of the best is Textra, they just began charging $1 for it, but worth every cent and more.
    06-11-2015 07:27 PM
  9. KelseyRo4's Avatar
    Go to contacts and hit "more" in the right upper corner. Then hit the settings. Then hit contacts to display and just hit Google. Then only the contacts in Google will show. Not all the other ones and email addresses. Try that

    Galaxy S6 Gang
    This is all that comes up

    Posted via the Android Central App
    Attached Thumbnails need help with contacts-4907.jpg  
    06-11-2015 09:33 PM
  10. erasat's Avatar
    This is all that comes up

    Posted via the Android Central App
    It's strange that you don't have the different accounts there, what options do you have when you click customize? If you see Google there it will have the same effect so just select Google from there.
    06-11-2015 10:01 PM
  11. KelseyRo4's Avatar
    This comes up when I click customize

    Posted via the Android Central App
    Attached Thumbnails need help with contacts-4922.jpg  
    06-12-2015 09:54 PM
  12. makaroni's Avatar
    alright I got it. when you open a new text message in the stock messaging app on the S6, tap on the contact icon, hit the drop down in the top left corner. tap "groups". scroll down and all the groups of contacts will show. tap the google account and only those contacts will show. If you have more than one google account set up, just ap on the one you want and the contacts saved to that specific account will show. You'll have the option to pick from all the groups of contacts. That should do it.
    06-14-2015 09:43 PM

Similar Threads

  1. Best priced off-contract phone in the US
    By AC Question in forum General Help and How To
    Replies: 2
    Last Post: 06-11-2015, 10:37 PM
  2. Do you need newsletters to get mobile view?
    By AC Question in forum General Help and How To
    Replies: 2
    Last Post: 06-11-2015, 01:18 PM
  3. How can I connect my phone to my computer?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 06-11-2015, 04:47 AM
  4. Replies: 0
    Last Post: 06-11-2015, 04:20 AM
LINK TO POST COPIED TO CLIPBOARD