1. Vintila Cristian's Avatar
    Hello everyone,

    I am running a stock rom on my GS6 and since yesterday, when I had to call someone I noticed that I have duplicate phone numbers for each contact, but only when I type a contact's name using the T9 function of dialer. If I go to contacts, everything is fine.

    I noticed that the issue is solved after uninstalling whatsapp. When I reinstalled whatsapp from the play store, it installed version 2.12.176, but I instantly got the update for 2.12.242 which was the version I had before. The issue came back after 30 minutes of use...

    Any help would be greatly appreciated.

    Duplicate numbers in dialer-11249297_1091837747508012_1379690367_o.jpg
    Duplicate numbers in dialer-11899331_1091837727508014_1471894099_o.jpg
    Duplicate numbers in dialer-uploadfromtaptalk1439978650357.jpg
    Duplicate numbers in dialer-11871745_1091837740841346_927943860_o.jpg
    08-20-2015 05:09 AM
  2. Aly Khalifa1's Avatar
    Im having the same exact issue it duplicates in the dialer but in contact everything is perfect...... its killing me im not sure if its related to the katest whats app update but this recently startted happening to me it wasnt like that be4.... using gs6 edge..... please let me know if you were able to fix this
    08-26-2015 05:30 PM
  3. Serbanescu Bogdan's Avatar
    Same problem here as well. I have no idea why..
    08-29-2015 01:37 PM
  4. Bathyon's Avatar
    Okey, so I had the exact same problem and I think I might have found a way to fix this. The problem is it's contact by contact and not bulk.

    1. Go to your contacts in your S6. Search for a contact that you know have duplicate numbers in the dialer.
    2. You will now see that there is just one number added to the contact.
    3. Click the "show more" link in the bottom of the contact card (above your recent activity)
    4. This expanded view now shows you more contact info. Look for the "Connected by" field with a link symbol on the right.
    5. This field will show you what services link contact info to this contact. Click it and press the "-" by the connected app to split it from this contact.
    6. Now if you search for this contact again you will find two contacts. The original one and the one you just broke free.
    7. Click the unwanted one and press "more" in the top right and select "delete". It will warn you that you cant delete read only stuff but proceed anyway.
    8. Voila! Now you don't have duplicate numbers in your dialer.

    As I said this is a bit tedious, but it works. I have done it to my most frequent contacts and thats good enough for now. There is an option in the contact app where you can choose what sources to show in your contacts but that doesn't seem to work or doesn't apply to the dialer.

    Hope this helps
    .- Alex
    09-03-2015 10:30 AM
  5. VelvetAssassin's Avatar
    Okey, so I had the exact same problem and I think I might have found a way to fix this. The problem is it's contact by contact and not bulk.

    1. Go to your contacts in your S6. Search for a contact that you know have duplicate numbers in the dialer.
    2. You will now see that there is just one number added to the contact.
    3. Click the "show more" link in the bottom of the contact card (above your recent activity)
    4. This expanded view now shows you more contact info. Look for the "Connected by" field with a link symbol on the right.
    5. This field will show you what services link contact info to this contact. Click it and press the "-" by the connected app to split it from this contact.
    6. Now if you search for this contact again you will find two contacts. The original one and the one you just broke free.
    7. Click the unwanted one and press "more" in the top right and select "delete". It will warn you that you cant delete read only stuff but proceed anyway.
    8. Voila! Now you don't have duplicate numbers in your dialer.

    As I said this is a bit tedious, but it works. I have done it to my most frequent contacts and thats good enough for now. There is an option in the contact app where you can choose what sources to show in your contacts but that doesn't seem to work or doesn't apply to the dialer.

    Hope this helps
    .- Alex

    Hey bro, thanks a ton your solution worked out perfectly. Although it needs to be done individually, I suppose we can do it for the most frequently used contacts.

    I made the mistake of synchronizing contacts from many places: WhatsApp, emails, etc. Now unchecked Contracts synchronization from all those.

    Thanks a lot for pointing this out!
    12-03-2015 01:03 AM

Similar Threads

  1. Replies: 1
    Last Post: 08-28-2015, 01:10 AM
  2. Replies: 1
    Last Post: 08-21-2015, 09:27 AM
  3. Replies: 1
    Last Post: 08-20-2015, 01:13 PM
  4. Replies: 2
    Last Post: 08-20-2015, 01:10 PM
  5. Replies: 1
    Last Post: 08-20-2015, 03:32 AM
LINK TO POST COPIED TO CLIPBOARD