Save big + get 3 months free! Sign up for ExpressVPN today

  1. AC Question's Avatar
    I have a Samsung Galaxy S6 and I live in the Czech Republic.

    Recently the keyboard keeps defaulting back to the Samsung keyboard, rather than the Google keyboard which is my preferred option. I've reset the default in Settings repeatedly.

    Any ideas?
    10-11-2015 12:40 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Try going to the App Manager, selecting Samsung Keyboard, and tapping Disable.
    10-11-2015 05:15 PM
  3. kanezo's Avatar
    Disable is not an option.
    11-27-2015 02:41 AM
  4. AlphaTango414's Avatar
    Try wiping system cache via recovery.
    11-27-2015 04:15 AM
  5. chezm's Avatar
    Make sure you disable Samsung as an option for keyboard where ever possible in language and input settings

    Posted via the Android Central App
    Attached Thumbnails Why does my default keyboard always default back to Samsung?-2124.jpg  
    11-27-2015 04:18 AM
  6. chezm's Avatar
    Never mind I'm having the same issue now, this must be recent. I also can't disable Samsung's keyboard.

    Update

    OK found out with a quick search it's related to auto stopping due to optimization under battery. I have set it to be disabled for SwiftKey let's see if it sticks.
    Android3Lover likes this.
    11-28-2015 07:30 AM
  7. DAN_LOVES_ANDROID93's Avatar
    YOU ROCK!!
    02-15-2016 06:18 PM
  8. harry redknapp's Avatar
    @chezm You are my hero!!!!! This has been driving me nuts but it's all fixed now. Thanks so much
    03-28-2016 07:50 PM
  9. PsychDoc's Avatar
    Can you provide a step by step guide to doing this in battery optimization? Not sure how to do it.
    05-27-2016 11:27 AM
  10. Android3Lover's Avatar
    You ROCK!!! This has been killing me for months!!!
    Here's a step by step:
    Go to settings -> Battery -> Detail
    Select the apps you don't want to be included in Auto-optimise program such as "Swiftkey" , "Solo Launcher" etc...
    Choose: Disable.

    Voila! It's done!
    06-25-2016 10:35 AM
  11. Linda99's Avatar
    I don't see any of that on my phone
    04-21-2017 09:33 PM
  12. Garrett450's Avatar
    Consider looking into you app/cache cleaner. It may be killing your keyboard.
    03-03-2021 11:55 AM

Similar Threads

  1. Replies: 2
    Last Post: 06-24-2016, 12:49 AM
  2. Why is my Samsung Galaxy A5 switching on/OFF all the time?
    By AC Question in forum Samsung Galaxy A5
    Replies: 1
    Last Post: 10-11-2015, 05:34 PM
  3. Replies: 1
    Last Post: 10-11-2015, 05:20 PM
  4. Replies: 1
    Last Post: 10-11-2015, 11:50 AM
  5. Replies: 0
    Last Post: 10-11-2015, 10:38 AM
LINK TO POST COPIED TO CLIPBOARD