1. AC Question's Avatar
    It is unable to detect Ok Google when I open the Google app. I tried to train it in the settings but it's stuck at the first out of three Ok Google training. I don't think it is detecting anything from the mic. I tried disabling S Voice as well but still nothing. Please help!
    11-11-2015 12:12 PM
  2. AlphaTango414's Avatar
    Take a short video or voice memo to verify that your mic is indeed working.

    Next wipe Google app cache. Still nothing, wipe app data.

    Next clear system cache via recovery.
    11-11-2015 06:01 PM
  3. Shashwat Gangwar's Avatar
    My mic is working fine.
    I have to manually click the mic in google search to activate google voice search. It doesn't recognise 'Ok google'.
    I tried deleting the cache but still nothing.
    11-11-2015 10:56 PM
  4. AlphaTango414's Avatar
    You done both app data and system cache?
    11-12-2015 03:52 AM
  5. Shashwat Gangwar's Avatar
    I just deleted both again. Wow it detected Ok Google for the first time i opened google app. The second time it has again gone back to its sleep.
    I deleted cache again. And again it only detects ok google for the first time i use voice search. Second time onwards no response. Surprisingly, when I manually click the mic icon, it listens properly everytime irrespective of whether I have deleted cache or not.
    11-12-2015 02:05 PM
  6. AlphaTango414's Avatar
    Have you tried checking your "ok google" settings via the Google setting app? Try toggling it off then back on right after a cache wipe.
    11-12-2015 02:14 PM
  7. Shashwat Gangwar's Avatar
    Wow now it works for two times before becoming irresponsive for the third.
    11-12-2015 02:27 PM
  8. Shashwat Gangwar's Avatar
    After trying numerous times now, it has started working now! I've been able to successfully train Ok Google for 3 times in the settings as well. However it is very buggy and refuses to hear me on some occasions. Is this like with most android phones?

    Thanks a lot for the help!

    Edit: I left my phone idle for 15min. I've tried saying Ok google over 10 times now but Google refuses to respond now. Only when I open the google app does it start responding.
    11-12-2015 02:38 PM
  9. AlphaTango414's Avatar
    Did you try the settings like I suggested?
    11-12-2015 03:21 PM
  10. Fathertime's Avatar
    The same thing is happening on most of the other phones.
    11-12-2015 07:44 PM
  11. Shashwat Gangwar's Avatar
    Yeah it works for some time. But after I leave it idle for an hour and then say Ok google, nothing happens. I have to repeat all the steps you suggested again to make it work again. What pain X(
    11-14-2015 02:20 AM

Similar Threads

  1. Did I fall off the Verizon update train?
    By Mike Majeski in forum Google Nexus 6
    Replies: 27
    Last Post: 12-16-2015, 02:31 PM
  2. Squirrel Run- Jungle Adventure / My First Game On Google Play
    By the reskinner in forum Android Games
    Replies: 0
    Last Post: 11-11-2015, 12:03 PM
  3. Anyone experiencing haptic feedback when using S-Pen in Drive Apps?
    By AC Question in forum Samsung Galaxy Note 4
    Replies: 0
    Last Post: 11-11-2015, 12:02 PM
  4. Why is my Samsung Galaxy S3 not letting me download apps?
    By AC Question in forum Samsung Galaxy S3
    Replies: 0
    Last Post: 11-11-2015, 12:01 PM
  5. How to get it off from Being locked?
    By AC Question in forum General Help and How To
    Replies: 0
    Last Post: 11-11-2015, 11:59 AM
LINK TO POST COPIED TO CLIPBOARD