1. AC Question's Avatar
    Hi! I recently bought Samsung Galaxy s6. My provider is WIND (Greece). Previously, I has a Jiayu and always (home, work) was showing 4G. Now, I always see (same sim, same provider, same places) H+.
    Why does it happen? Is it a problem of the device or a problem of provider?
    Thank you!
    11-29-2015 10:37 AM
  2. anon8380037's Avatar
    Can you look at Settings - More Networks - Mobile Networks - Preferred Network Type and ensure it's at 4G/LTE.

    Or you may have a 3G version of the S6, not sure if they exist but previous Samsung models had different regional variations.
    Can you search your particular model code online or on the Sammobile site for full specifications?
    11-29-2015 11:20 AM
  3. MaxKittens's Avatar
    It could be a problem with either bad connection or your device is not compatible with 4G/LTE which i dont think exists on the s6. You could also have to set your apn settings. You can do this by getting the apn details online by simply searching it up. Then you go to settings>mobile networks>Access Point Names. Then create or modify the apn to where it is set to 4G/LTE. For example with t mobile there is fast.tmobile.com (4G/LTE) or epc.tmobile.com (3G/H+)
    11-29-2015 04:12 PM

Similar Threads

  1. I broke my Galaxy S5, how can I fix it?
    By Bnar Falah in forum Samsung Galaxy S5
    Replies: 3
    Last Post: 12-09-2015, 08:41 AM
  2. Replies: 1
    Last Post: 11-30-2015, 04:29 AM
  3. Why is my Samsung Galaxy Young showing an error message
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 11-30-2015, 02:11 AM
  4. I have problems by logging in on instagram, how can I fix that?
    By AC Question in forum General Help and How To
    Replies: 0
    Last Post: 11-29-2015, 09:57 AM
  5. Replies: 0
    Last Post: 11-29-2015, 09:55 AM