1. denhearn's Avatar
    I am getting "Unknown Device" when I connect my Samsung Galaxy S6 (5.1.1) to my 2016 Honda Accord using "Android Auto". Honda tells me that no one else is getting this S6 error message. But it appears on the monitor every time I connect to the USB cable. (btw, my S6 is an unlocked, international version)

    Is anyone else having problems being recognized by Android Auto?

    Thanks in advance!

    Den
    12-01-2015 03:23 PM
  2. lucianus_luciferus's Avatar
    have you tried a different cable?
    or a different android phone?
    or maybe ask the honda dealer to let you connect your s6 to one of their cars
    12-01-2015 03:55 PM
  3. denhearn's Avatar
    All good ideas. I just got back from the dealer & tried my s6 in another Accord with the same result. The Honda guy said that's because when I plug it in (each time) the car needs to communicate with the phone and until it does, the device is "unknown". I expected that once I register the s6 with the car, that the message would change to the name of the phone (or maybe the model) The cars continues to say "Devices Unknown" each time I plug it in. Does anyone have a 2016 Accord that has connected an s6 to the USB port? This technology is so new that I'm sure even the dealer does not fully understand it yet.

    Thanks for the thoughts tho!
    12-01-2015 06:43 PM
  4. emmert9's Avatar
    Have you found a solution yet? I just purchased a 2016 Accord Touring and am having the exact same problem with note 5. I'm wondering if the AA version installed on the car is too old to talk to these new phones?

    Thanks...
    12-13-2015 07:13 PM
  5. emmert9's Avatar
    actually just solved the issue. It was the cable. I guess the phone requires the high speed OEM cable it came with. An after market standard cable will not work.
    12-13-2015 08:54 PM
  6. denhearn's Avatar
    Thanks for the reply. I stopped looking at replies to this issue after a couple of weeks.

    Did the high speed cable fix the "Devices Unknown" problem? I have used many cables (including the one I got with the phone) to fix this problem. No success yet. I assumed it's an update to the auto system. (not available yet)

    Another problem that I can't seem to figure out is using Pandora over Bluetooth in my 2016 Accord Touring. (Pandora works using Android Auto, but does not unless I connect via USB cable and use AA)
    djm1947 likes this.
    02-11-2016 12:43 PM
  7. claykin's Avatar
    Either use the cable that was supplied with your phone or purchase a USB charge and sync cable. Monoprice.com has good options for reasonable prices.

    Posted via the Android Central App
    02-12-2016 06:42 PM
  8. tariq_one's Avatar
    Either use the cable that was supplied with your phone or purchase a USB charge and sync cable. Monoprice.com has good options for reasonable prices.

    Posted via the Android Central App
    Just type *#0808# on.you phone and select the adp + mdb option.. Solved my issue
    denhearn likes this.
    04-21-2016 04:56 PM
  9. tariq_one's Avatar
    Thanks for the reply. I stopped looking at replies to this issue after a couple of weeks.

    Did the high speed cable fix the "Devices Unknown" problem? I have used many cables (including the one I got with the phone) to fix this problem. No success yet. I assumed it's an update to the auto system. (not available yet)

    Another problem that I can't seem to figure out is using Pandora over Bluetooth in my 2016 Accord Touring. (Pandora works using Android Auto, but does not unless I connect via USB cable and use AA)
    Solved.. Same issue on Note 5..
    *#0808# change usb cable.mode mtp +adb and should work..
    04-21-2016 04:59 PM
  10. Kathryn Govert's Avatar
    I might be having the same issue... I connect with an off brand USB cord. But ... it will connect for a few seconds. Then read device not connected. I unplug and plug back in same thing... connects then disconnects. Did you have the same problem.?
    07-22-2016 10:54 AM
  11. edklar's Avatar
    I have a Samsung Note 3. How/where do you enter the*#0808# ? When I dial it, I get Verizon telling me that it can't complete as dialed. Also, is the Note 3 too old, even if it has Android 5.0? Thanks.
    08-04-2016 07:58 PM
  12. denhearn's Avatar
    When I type *#0808# (that's splat, pound, "0", "8", "0", "8", pound) on my phone keypad, I do get into USBSettings. I have "AP" selected at the top and "MTP + ADB" selected at the bottom. But my car and Android Auto still do not recognize my phone. I get "Devices Unknown". I have had my 2016 Honda Accord Touring for a year and a half and no update for the cars firmware yet. It seems that Honda and Android Auto are only half baked to me.
    03-27-2017 04:44 PM

Similar Threads

  1. Replies: 3
    Last Post: 12-08-2015, 12:29 PM
LINK TO POST COPIED TO CLIPBOARD