1. Himeko7's Avatar
    Related to Tethering doesn't work, no data on connected devices (either USB/Wifi) - Android Forums at AndroidCentral.com

    I have a weird issue sharing my mobile connection, exactly the same on S5 and S6, but works fine with a Nexus4 with the same card:

    * Plug phone to laptop
    * Enable USB tethering
    * Inet works fine on laptop (using shared wifi received on phone from my home inet)

    * Disable wifi on phone, to share mobile data connection instead: no more data received on laptop (pinging any address times out)

    Same test with another phone (Nexus4) works fine (just dc for a moment while switching to mobile data, then ping responding again after a couple seconds).

    Both phones (s5/6) were bought from Spanish Amazon, imported from Germany (initial setup and bloatware is all German), carrier-free, using a Spanish sim card.

    Any ideas? (s6 was received just yesterday, and I tried factory reset on s5, the issue is there from day 1).
    12-10-2015 04:48 AM
  2. anon(632115)'s Avatar
    It could be a USB cable problem. Make sure you use the one provided by Samsung as they are wired differently. You could also achieve this wirelessly
    12-10-2015 04:56 AM
  3. Himeko7's Avatar
    Same issue over wifi.
    12-10-2015 05:10 AM
  4. Himeko7's Avatar
    Fixed it..

    The culprit: "APN Type" setting. Carrier's auto-config set it to "default", while on the Nexus4 that field was empty since it didn't support auto-config via a text message, I had manually set it up.

    Basically. "APN Type"
    "default" = tethering not working
    "default,dun" = works
    "" (empty) = works
    anon(632115) and benex like this.
    12-10-2015 05:40 AM
  5. LHwlen's Avatar
    Thankyou very much!!!
    it just solve my struggling problem !!
    thank you!!!
    11-21-2016 01:26 AM
  6. benex's Avatar
    Went to three Vodafone store. Employees clueless. Thank you!!! That's a hidden gem.
    06-04-2017 07:06 AM
  7. Bryce Wade's Avatar
    Fixed it..

    The culprit: "APN Type" setting. Carrier's auto-config set it to "default", while on the Nexus4 that field was empty since it didn't support auto-config via a text message, I had manually set it up.

    Basically. "APN Type"
    "default" = tethering not working
    "default,dun" = works
    "" (empty) = works

    I just wanted to tell you a huge THANK YOU from Paris. I struggled for days to fix this **** and even my network provider couldn't help me. You made somebody very happy

    But i'm curious though, could you explan me real quick what was the problem and what does that "dun" means?

    Cheers!!
    07-05-2017 12:07 PM
  8. moltra's Avatar
    I just wanted to tell you a huge THANK YOU from Paris. I struggled for days to fix this **** and even my network provider couldn't help me. You made somebody very happy

    But i'm curious though, could you explan me real quick what was the problem and what does that "dun" means?

    Cheers!!
    I think that it refers to Dial Up Networking.
    Amber Helstrip likes this.
    01-10-2018 10:58 AM
  9. Deny11's Avatar
    Where do you find this "APN Type"?
    I have this problem, any device can't connect to my phone's tethering.
    USB is fine but wireless is not.
    I think it happened after my phone ran out of battery.
    01-13-2018 12:49 PM
  10. Himeko7's Avatar
    Where do you find this "APN Type"?
    I have this problem, any device can't connect to my phone's tethering.
    USB is fine but wireless is not.
    I think it happened after my phone ran out of battery.
    Go to Settings, Mobile Networks, Access Point Names there you must edit the current internet profile and edit the APN Type as "default,dun" or "dun" or simply empty
    01-14-2018 10:49 AM
  11. MissMenita's Avatar
    Go to Settings, Mobile Networks, Access Point Names there you must edit the current internet profile and edit the APN Type as "default,dun" or "dun" or simply empty
    You're a genius. I was lost trying to use my Samsung A5 and fiddled around with the 'Mobile virtual network operator type' and yes: switching it from nothing to 'IMSI' did the trick!
    I have absolutely no clue what all of this means, but am very happy: thanks!
    10-30-2018 11:54 AM
  12. PineappleKush's Avatar
    I tried to modify these settings (Samsung Galaxy S9+):
    This has now been solved. Solution that worked for me at the bottom of this post!

    • Go to settings
    • Then connections
    • Then 'Mobile Networks'
    • Tapped 'Access Point Names'
    • Tapped the profile in use
    • Scrolled down and changed the setting 'APN Type' (Not 'APN') to 'default,dun' without the quotes as suggested by OP.
    • Also tried modifying to 'default,supl,mms,dun' as suggested here
    • Scrolled down and changed the setting 'Mobile virtual network operator type' to 'IMSI' as suggested above by MissMenita
    • Tried all combinations of secure/unsecure, hidden/unhidden, allowed devices (with the MAC-address of my laptop) on and off, 'Use 5 Ghz band when available' option, in the WiFi hotspot settings.
    • Tried restarting phone and also forgetting the network completely on my laptop
    • Tried choosing "Yes" and "No" on the prompt about home/public networks when connecting on my laptop
    • All of the three last points in every order imaginable


    None of these things changed the fact that my laptop can connect, but not get internet.

    The USB Tethering option works fine, and connecting to a "normal" WiFi with my laptop is no issue, so I'm still certain it's an issue with the phone.

    PS! My 'WiFi Hotspot' setting does not list my laptop as a connected device even though my laptop shows it's connected, but without internet access.

    EDIT (Solved): After a while, I right clicked the WiFi-icon on my laptop and clicked 'Troubleshoot problems'. Windows (10 pro) suggested that I needed to enable 'DHCP for "Wi-Fi"' (which requires admin rights on the PC), so I did. Then it worked instantly!
    11-30-2018 11:45 AM
  13. Jessicaav's Avatar
    Hi there,
    I recently purchased a Samsung and I'm having the same problem. I went to 'apn type' and tried to make those changes however it wont let me save. It says I cant leave a empty field even though it's not empty.

    Need help please. We used hotspot for the household internet.
    02-27-2019 03:58 PM

Similar Threads

  1. Replies: 64
    Last Post: 10-26-2016, 09:44 AM
  2. Replies: 1
    Last Post: 12-10-2015, 05:16 PM
  3. Replies: 1
    Last Post: 12-10-2015, 01:27 PM
  4. Replies: 2
    Last Post: 12-10-2015, 04:08 AM
  5. Will a Note 5 work on T-Mobile $30 prepaid plan?
    By AC Question in forum Samsung Galaxy Note 5
    Replies: 1
    Last Post: 12-10-2015, 12:05 AM
LINK TO POST COPIED TO CLIPBOARD