09-16-2017 10:45 AM
27 12
tools
  1. captnpenguin's Avatar
    I'll start off with saying I'm still very new to android so if this is an easy fix that I should know about my apologies. I've noticed that when I start typing text for anything it often times wants to predict an email address from my gmail account. The real crazy thing is that most of the time it is an email that was utilized for 1, maybe 2 emails from over 5 years ago. Is there a way to disable this? I'm afraid that one day I'll accidentally send someone a message that contains a "random" persons email instead of a word that I wanted. It's starting to get really annoying/frustrating...
    03-15-2016 11:29 AM
  2. nedenlinger's Avatar
    you can disable by
    Taping on any text field, such as a search box, e-mail body, or a browser address bar to summon the keyboard.
    and Tap the gear in the bottom left of the keyboard, beside the Sym button.
    lastly Tap Predictive text to turn it off and on.
    03-15-2016 11:48 AM
  3. captnpenguin's Avatar
    I don't have the gear next to my sym button. If I disable predictive doesn't that disable all and not just the stupid emails?
    03-15-2016 12:05 PM
  4. sydneycooper1979's Avatar
    When the email pops up in the autocorrect, long press and it will give you the option to remove it from autocorrect
    lucianus_luciferus likes this.
    03-15-2016 12:35 PM
  5. i108's Avatar
    Looks like no one has given a sufficient response yet.

    I am having this same problem.

    Gmail e-mails I've sent or received from, even erased messages, are pulling into auto-complete. If I am typing Hello, I don't need (email address removed by Moderator) showing up. Obviously, predictive text is pulling from a google account database or portion thereof it shouldn't be.

    I am surprised more haven't noticed this, or maybe it's only happening for some people.

    Please help find a solution, I wasted my time with Verizon tech support, and the Samsung tech support guy just had me clear google text to speech and messaging data, and stop the google app so Samsuck text to speech was on, as I suspected, did nothing. Then he said to boot into safe mode. Was hard to understand his voice, and he is an a$$hole since he hardly looked into it, and got me off the phone before I was done saying to do safe mode then call back.

    We need a way to turn this off.

    The answer above about long pressing each e-mail, is incorrect, shortsighted, and misleading. No good answer has been given thus far.
    04-03-2016 09:56 PM
  6. dpham00's Avatar
    Mod Note, please do not post your email address on this public forum
    04-03-2016 10:05 PM
  7. i108's Avatar
    Anyone? I find it hard to believe no one has found a solution to this.
    04-14-2016 12:30 AM
  8. i108's Avatar
    dpham00, dude, that was a completely fake e-mail address.
    04-14-2016 12:30 AM
  9. captnpenguin's Avatar
    I wonder is this with all android or just samsung?
    04-14-2016 12:34 AM
  10. AngieL65's Avatar
    Long pressing on the email works for me on both swift key and the default samsung keyboard.
    04-14-2016 09:24 AM
  11. captnpenguin's Avatar
    I've tried that with mixed results. Certain emails keep showing up no matter what and they aren't even emails I send to ever.
    04-14-2016 09:36 AM
  12. nsanders's Avatar
    I am also interested in a solution to this problem.
    04-14-2016 06:09 PM
  13. Jimmy Le1's Avatar
    Ha ... for the life of me ... I could not duplicate what you say ...
    Even if I type @ ...still did not show up any Email ...
    I'm using Samsung stock key board ..

    Maybe i'm the lucky one ..

    Cheers..
    04-14-2016 06:28 PM
  14. CelticRain's Avatar
    Anyone? I find it hard to believe no one has found a solution to this.
    For what it's worth, I not only have the email input issue (frequently), but since recent updates (including to marshmallow) my phone decides what I'm typing is wrong and replaces it with nonsensical autocorrects.
    NeedMoDro likes this.
    04-18-2016 11:17 AM
  15. Glinesgirl3's Avatar
    Great idea except I have thousands of email addresses in my contacts. Typing JC and had to hold and remove 5+ email addresses.

    Samsung - fix this!
    NeedMoDro likes this.
    05-05-2016 07:16 PM
  16. NeedMoDro's Avatar
    For what it's worth, I not only have the email input issue (frequently), but since recent updates (including to marshmallow) my phone decides what I'm typing is wrong and replaces it with nonsensical autocorrects.
    Yeah. I had the email problem for a long time. But after updating to marshmallow I've almost smashed my s6edge+ a few times.

    The email thing got 10x worse and my autocorrect/fill is constantly changing words. I type "that", and changes it to "thay" I type "dont" and it changes to "do this" and there are tons of other examples.

    They keyboard also gets really slow and unresponsive and I have to limit text threads and frequently delete my dictionary data. And for a time it's better, but then slowly goes retarded again.

    Please help me before I destroy my phone in rage.
    05-09-2016 01:34 AM
  17. lucianus_luciferus's Avatar
    try a different keyboard. there are many in play store. eg swiftkey
    05-09-2016 04:20 PM
  18. i108's Avatar
    I shouldn't NEED a different keyboard. The built-in one works with my themes, but yes, I've thought of switching for the inaccuracy of the Samsung one vs my old HTC One keyboard. It often puts in completely different words, can't seem to guess words if you get even a single letter off, etc. Also, THOUSANDS of e-mails, so long pressing and deleting is a ridiculous comment. It's a BEHAVIOR we are talking about.

    Samsung support was of 0 help, some eastern european dude who I could barely understand and said to boot in safe mode.

    Wiping ALL keyboard data temporarily works but it wipes all the stuff I saved too, and then it ALL comes back within a day.

    Someone should get Samsung to acknowledge and fix this, guess it's yet another thing I have to spend time on, I seem to notice and care more than most.
    05-10-2016 11:40 PM
  19. i108's Avatar
    Google keyboard works ok, I want it to show numbers though, not sure if it can, I told my friend to try it. I am sure it logs EVEN MORE than android.
    Swiftkey, does it do swype? Might be ok. What's the best keyboard?

    Anyone? Bueler?
    05-10-2016 11:41 PM
  20. joemontana's Avatar
    I like the Swype keyboard

    Joe
    Verizon s6, marshmallow
    05-11-2016 01:17 AM
  21. DLeoLion's Avatar
    I posted this solution yesterday in another forum.

    For anyone still have trouble finding a way to delete autofill addresses on Android, this is what worked for me.
    None of the addresses that showed up for me when I typed a letter in the To: field on my Android appeared in ANY Contact list on either my phone or in Other Contacts when I signed into Gmail on my computer. I also had no way once the address appeared in the To: field to press and delete the address. The problem has nothing at all to do with the keyboard you are using on your Android. If you've made sure that the addresses don't appear in any group on your phone or computer, then try this...(phone instructions are using Lollipop on Samsung Galaxy S5):

    On the computer, sign into your Goggle account. Open Gmail. Click the Gear icon to get to Settings, General Tab, scroll down to "Create contacts for auto-complete", Check "I'll add contacts myself". Apply. Do this for any/all Gmail accounts that you have that download/sync to your phone. Doing this makes sure that any addresses you reply to in the future are not 'saved' as auto fill possibilities.

    Now remove your Gmail account(s) from your phone. Swipe down from top of phone to access Settings, Accounts, Google, Click on the account to remove (the one or ones you have the autofill addresses you want to get rid of), Click Menu (three vertical dots), Remove Account.

    Once account is removed, click the Gmail icon, Menu (three vertical lines), Settings, Add account, Check Google, Enter email address, Enter Password. Account will be re-added. Click the Gmail icon again and compose a new message. Enter a letter into the To: field and the nuisance addresses should be gone.
    05-11-2016 11:34 AM
  22. Vaping Android Head's Avatar
    Looks like no one has given a sufficient response yet.

    I am having this same problem.

    Gmail e-mails I've sent or received from, even erased messages, are pulling into auto-complete. If I am typing Hello, I don't need (email address removed by Moderator) showing up. Obviously, predictive text is pulling from a google account database or portion thereof it shouldn't be.

    I am surprised more haven't noticed this, or maybe it's only happening for some people.

    Please help find a solution, I wasted my time with Verizon tech support, and the Samsung tech support guy just had me clear google text to speech and messaging data, and stop the google app so Samsuck text to speech was on, as I suspected, did nothing. Then he said to boot into safe mode. Was hard to understand his voice, and he is an a$$hole since he hardly looked into it, and got me off the phone before I was done saying to do safe mode then call back.

    We need a way to turn this off.

    The answer above about long pressing each e-mail, is incorrect, shortsighted, and misleading. No good answer has been given thus far.
    On my LG with lollipop there was an option to turn of the email bit, but on SG6 Marshmallow there appears to be nothing and it is not acceptable. Since many people are having this issue
    06-29-2016 09:27 AM
  23. Yvette Franz's Avatar
    I just did this and it did not work for me. it was also a pain in the neck to do.

    I suppose it was worth a shot -- I'd be interested if anyone else tried this, and if it worked for you.
    07-13-2016 12:26 PM
  24. Josh Ween's Avatar
    I just did this and it did not work for me. it was also a pain in the neck to do.

    I suppose it was worth a shot -- I'd be interested if anyone else tried this, and if it worked for you.

    HI had the same problem. So.annoying. anyhow fI ally fixed it. As mentioned earlier someone suggested going to the Gmail email app. Go there and start typing an email. Then click on the "gear button"

    Scroll right to the bottom on the menu and click reset.settings. reset. Both the options
    And you should be back in business
    07-16-2016 06:20 AM
  25. fixpedal's Avatar
    I had this problem for the past two months and it too drove me crazy. I finally got steered in the right direction in a couple other threads.

    Go to Settings>Application>Application manager>More>Show system apps>Samsung keyboard>Permissions and deselect "Contacts"

    Then go to Language and input>Keyboard>Clear personalized data


    This will solve it and your phone's keyboard will no longer have permission to contacts, thus won't add obscure emails.
    12-08-2016 10:22 PM
27 12

Similar Threads

  1. S7 and Google Messenger instead of Messages?
    By oceanclub in forum Samsung Galaxy S7 edge
    Replies: 24
    Last Post: 02-28-2017, 02:21 AM
  2. Replies: 2
    Last Post: 03-16-2016, 05:17 PM
  3. Replies: 1
    Last Post: 03-15-2016, 01:07 PM
  4. Bush Spira C1 5"Smartphone won't write media to "SD Card" by default
    By Simon Belfield 1965 in forum Ask a Question
    Replies: 1
    Last Post: 03-15-2016, 11:59 AM
  5. Doze - Is this a feature in the UK?
    By Andy Bell in forum Samsung Galaxy S6
    Replies: 3
    Last Post: 03-15-2016, 11:07 AM
LINK TO POST COPIED TO CLIPBOARD