04-27-2018 03:17 AM
44 12
tools
  1. barneytoe's Avatar
    I had problems before MM update with trusted places, so figured I'd re-test and sadly it still doesn't work. Phone continues to remain locked even when I'm at a trusted place.

    So I attempted to start from scratch after MM update: From Settings->Lock screen & security -> Secure Lock settings -> Smart Lock -> Trusted Places, I've gone in and disabled HOME and removed all other addresses. So there's nothing turned on.

    Restart phone and am surprised to see 2 addresses enabled again even though I just deleted or disabled them. The 2 addresses that are active again are HOME and an address from my saved addresses.

    So there are really 2 problems here: trusted places doesn't work AND I can't seem to remove the addresses.

    My Location method is set to "High accuracy" and I'm using screen lock type = "pattern".

    Any ideas ?

    thanks,
    chris
    04-05-2016 03:11 PM
  2. coldfilter's Avatar
    The smartlock features on my phone don't work either. I assumed it was because I use the fingerprint scanner disabled them for some reason.

    Posted via the Android Central App
    04-06-2016 02:39 AM
  3. B. Diddy's Avatar
    When you say you're using swipe to unlock, is that the actual screen lock method? Or is this a separate setting that determines if you have to swipe away an initial screen in order to get to the password entry screen? If the latter, then turn off the swipe option

    When you're at home, open Maps and make sure it is in fact locating you precisely at home, and not a few hundred yards off. It should be precise with High Accuracy, but if something is wrong with the GPS signal, it might have trouble pinpointing your exact location.
    04-07-2016 02:39 PM
  4. barneytoe's Avatar
    Yes, actual screen lock method. I never enter pwd anywhere, only swipe my pattern.

    Google maps is very precise, the blue dot is inside my house
    04-09-2016 09:03 AM
  5. B. Diddy's Avatar
    Try going to Settings>Security>Clear Credentials.
    04-09-2016 09:22 PM
  6. stang6790's Avatar
    Swipe is not an actual lock method that keeps someone from accessing your phone, smart lock will not disable it. If you use any of the other lock methods (pattern, pin, password or fingerprint) it will bypass it but you will still have to swipe.
    04-09-2016 10:02 PM
  7. B. Diddy's Avatar
    I was actually wondering about that, because I was a little confused by the OP's posts. Are you using a simple Swipe to Unlock, or an actual Pattern Unlock?
    04-09-2016 11:53 PM
  8. barneytoe's Avatar
    Sorry for ambiguity, I'm using screen lock type = "pattern". It's worth noting that if screen lock type = "swype", one cannot even get to trusted places setting.

    I don't see a clear credentials anywhere under security (MM OS).
    04-10-2016 09:46 AM
  9. B. Diddy's Avatar
    I don't see a clear credentials anywhere under security (MM OS).
    Sorry, Samsung's different from what I'm used to. I believe it's in Settings>Lockscreen & Security>Other Security Settings.
    04-10-2016 01:32 PM
  10. barneytoe's Avatar
    Found it. "Clear credentials" is greyed out, so instead I went into View security certs and disabled them 1 by 1. We'll see if this helps.
    04-11-2016 11:04 AM
  11. JustSpecial's Avatar
    My wife's S6 suddenly started having problems with trusted locations today.

    With her phone, I tried to used the Smart Lock utility to determine my current location as a trusted place, it could not find my home address and just say "location unknown", or something similar to that. It would try to use a location just behind my house that is school yard. This would happen, even when I had GPS set to High Accuracy and Wifi set to "Always allow scanning".

    Originally, WiFi was turned off on her phone, once turned on, everything started working properly. I assumed if WiFi was set to "Always allow scanning", that Smart Lock would also be able to use the Wifi to determine then current location, even it is off.

    I hope this helps.
    04-11-2016 06:52 PM
  12. barneytoe's Avatar
    Well that escalated quickly. None of my apps worked after cert disabling, so I just reversed what I did.
    04-11-2016 10:58 PM
  13. B. Diddy's Avatar
    Hmm, sorry about that. I'm afraid I don't know what else to suggest right now ...
    04-12-2016 02:25 AM
  14. AND6300's Avatar
    I have a Moto X PURE (2015) which has a GPS built in, I shouldn't need to have DATA or WiFi on for Smart locks to work properly, I think Google Developers rushed this out without thoroughly testing it. Or, they can care less about this feature that sounds cool, but is absolutely worthless.
    05-21-2016 01:17 PM
  15. RK928's Avatar
    Anyone find a good answer to this problem? I've searched all over the internet and tried every suggestion, but the trusted places still doesn't work. It used to work fine until a few weeks ago, I don't know what happened, it knows exactly where I am, high accuracy settings, etc. and it still doesn't work. PIA actually, I have to enter my 8-digit PIN every time at home. Like I said, it was working no problem before. Phone is a nearly new Moto X Pure.
    07-15-2016 08:54 AM
  16. Hjalte N's Avatar
    I had problems before MM update with trusted places, so figured I'd re-test and sadly it still doesn't work. Phone continues to remain locked even when I'm at a trusted place.

    So I attempted to start from scratch after MM update: From Settings->Lock screen & security -> Secure Lock settings -> Smart Lock -> Trusted Places, I've gone in and disabled HOME and removed all other addresses. So there's nothing turned on.

    Restart phone and am surprised to see 2 addresses enabled again even though I just deleted or disabled them. The 2 addresses that are active again are HOME and an address from my saved addresses.

    So there are really 2 problems here: trusted places doesn't work AND I can't seem to remove the addresses.

    My Location method is set to "High accuracy" and I'm using screen lock type = "pattern".

    Any ideas ?

    thanks,
    chris
    PLAUSIBLE SOLUTION.
    I've encountered the same problem with my android phone over the past few weeks and I think I've found a solution. I think it has something to do with Qualcomms location service. A few weeks ago I turned it on for some days as an experiment but today I connected it with the smart lock issue. It seams that even though Qualcomms izat is tuned off under locating settings the process is still running if you go to the running apps tab. If I kill the process called "com.qualcomm.location.xt" smart lock suddenly works again. A restart of the phone annoyingly starts the process again. Sometimes the running process is listed under cashed apps and then it doesn't always help, but a reboot seams to solve that .
    07-19-2016 04:31 PM
  17. Hjalte N's Avatar
    UPDATE
    I've now tested further and this works. Even though I turned off Qualcomms izat technology the process kept starting and kept running. To stop this I did the following:
    - Make sure Qualcomms izat technology is turned off (Samsung may call it by different name)
    - clear the Google play services app
    - reboot
    - go to smart lock and create you safe locations (everything gets cleared when resetting Google play services)
    Thats it. And then never turn on izat again.
    You may have to reenter data again in apps relying on Google play services ie. Google fit.
    07-23-2016 08:09 AM
  18. danhenley1's Avatar
    UPDATE
    I've now tested further and this works. Even though I turned off Qualcomms izat technology the process kept starting and kept running. To stop this I did the following:
    - Make sure Qualcomms izat technology is turned off (Samsung may call it by different name)
    - clear the Google play services app
    My god. This is why people buy iPhones.
    08-01-2016 03:37 PM
  19. NotFromHere's Avatar
    My god. This is why people buy iPhones.
    No kidding.

    I don't have com.qualcomm.location.xt running on my phone at all, but I've been having this same problem. My home is set as my trusted place, and it used to work fine to simply swipe up to unlock my phone at home. Now it doesn't. Seems like every now and then it will work (seems to help to open Google Maps to wake up the GPS or something like that), but I can't get consistent results with anything that I try. Most of the time it simply doesn't work at this point.
    08-04-2016 06:04 PM
  20. laurelnaiad's Avatar
    I've now tested further and this works. Even though I turned off Qualcomms izat technology the process kept starting and kept running. To stop this I did the following:
    - Make sure Qualcomms izat technology is turned off (Samsung may call it by different name)
    - clear the Google play services app
    That put me on to what worked for me -- just switching location services from high accuracy, to battery saving, and back to high accuracy fixed my Moto X Pure trusted places.
    08-10-2016 08:33 PM
  21. OrangeSquirrel's Avatar
    That put me on to what worked for me -- just switching location services from high accuracy, to battery saving, and back to high accuracy fixed my Moto X Pure trusted places.
    Magic! Worked for me on a Moto G4 too.
    08-15-2016 03:26 AM
  22. Andrew Malcolmson's Avatar
    Changing location accuracy did NOT work for me on my Nexus 5.

    com.qualcomm.location.xt is not running on this phone.

    Damn, must keep Googling.
    09-05-2016 04:00 PM
  23. Westiemom's Avatar
    When I first got my S6 last December, trusted locations never worked. I had on high accuracy and wifi and all that has been mentioned. After a month of using my phone trusted places just started working. I had not changed any settings. Now it works 99% of the time. Occasionally when I first come home it doesn't work one time, and then it's good. After reading all the comments it seems like it is an issue with location services not working 100% of the time? Maybe depends too on your cell service, the carrier, or other things that might affect service. Just uneducated speculation, but whatever it is, trusted places is working at home for me now the vast majority of the time.
    09-07-2016 08:06 AM
  24. Quantum Mania's Avatar
    All great suggestions. Thanks put me on to location accuracy. S7 edge, left on high but turned off use Bluetooth. So far so good
    09-23-2016 04:50 AM
  25. Quantum Mania's Avatar
    And it failed after a few goes. However going to lock screen and security>other security setting>trusted agents toggle smart lock off then on and it's been ok for an hour or so.
    09-23-2016 05:30 AM
44 12

Similar Threads

  1. Lock Screen Pattern not working on my Samsung Galaxy S7
    By AC Question in forum Ask a Question
    Replies: 27
    Last Post: 09-16-2017, 07:25 AM
  2. Replies: 6
    Last Post: 04-05-2016, 06:34 PM
  3. S pen on Note 3 not working after factory reset
    By singhcharanjot in forum Samsung Galaxy Note 3 Rooting, ROMs, & Hacks
    Replies: 0
    Last Post: 04-05-2016, 02:44 PM
  4. Replies: 0
    Last Post: 04-05-2016, 02:41 PM
  5. Replies: 1
    Last Post: 04-05-2016, 02:32 PM
LINK TO POST COPIED TO CLIPBOARD