1. AC Question's Avatar
    My wife and I both have identical Samsung Galaxy S6 phones. A week and a half ago we both updated our phones to 6.0.1 Marshmallow. After the update, our phones have limited to no internet on WIFI. In other words, Netflix doesn't work, Vidangel doesn't work, even Google Maps doesn't work among other things. The Google Playstore doesn't work either.

    There's nothing wrong with my WIFI and nothing has changed in the settings on my phone and my phone still connects just fine to WIFI, there's just no internet.

    I've checked for 3rd party software's already. I went into safe mode and there's still no internet on WIFI. I reset my network settings and there's still no internet on WIFI. I reset my router and modem and there's still no internet on WIFI. I "forgot" both the 2.4 and 5 versions of my WIFI and there's still no internet on WIFI. I have done everything I can think of besides a factory reset which I'm trying to avoid because I don't want to lose a bunch of stuff. What else can I do?
    04-14-2016 12:42 PM
  2. jmw_man's Avatar
    bump since there's no response.

    I'm just curious if android is working on a fix for this. I see that this problem is quite common. Is there another area I should be posting?
    04-15-2016 02:26 PM
  3. beagle82's Avatar
    Have you checked for an ip address conflict? Possible that your phone is using the same ip as the default gateway. Check the ip addresses on each device to make sure that there are no duplicates.
    04-15-2016 03:07 PM
  4. jmw_man's Avatar
    It is most definitely not an IP address conflict. My phone connects to 192.168.0.22 according to the android's WIFI IP settings which is confirmed when I run an IP scanner on my desktop computer. When I turn my phone's WIFI off, that IP address becomes unused and is available for use by other devices. My wife's phone is the same deal but her IP address is 26 instead of 22 and 26 becomes available when I disconnect her phone from the WIFI.

    My question is, when are people going to start asking Android for a fix instead of assuming that every single user who has this problem is incompetent. I've read dozens and dozens of threads from people who are experiencing this problem and it's the same thing over and over and over.

    Who do I need to contact because I paid full price for both of my phones for the convenience of carrier flexibility and that's a lot of dough for a device that doesn't work properly.
    04-15-2016 04:11 PM
  5. Rukbat's Avatar
    Contact the seller if you really want to push for a refund. From the reports we're seeing here and elsewhere, that update of Android isn't wifi-capable (due to a bug, of course). Or you can wait for the fix update. Yelling louder or with more voices isn't going to make the developers working on the problem find it faster.
    04-15-2016 06:56 PM
  6. jmw_man's Avatar
    It seems the problem I am having is related to the security protocols between my access point and my Galaxy S6. The recent Android update to 6.0.1 brought out this problem. I've learned that my phone works perfectly fine on some other WIFI's but not my own, meanwhile, my other devices and other phones work perfectly fine on my WIFI. Additionally, my modem/router offers a guest network (no security) my Galaxy S6 works perfectly fine. So, the issue is security related and to my router. My phone worked on the secure WIFI of the local Best Buy store.

    I've found many many forums from people with similar problems. More specifically, I've even found people who have this problem when they are using TWC and the Netgear C6300 router, which is what I'm using. The firmware is up to date according to TWC.

    I've tried turning security off on my router but the problem still exists.

    Oh, yesterday, I had my phone reflashed at Best Buy.

    I wish I knew what the Marshmallow update changed on my phone
    04-26-2016 12:29 PM
  7. jmw_man's Avatar
    Okay, I read on the Netgear forums from a post 10 months ago that Netgear is aware of an issue. Although, I will add that Netgear isn't the only router make that people are having this issue with, there are other router brands that are used and WIFI doesn't work and then they go to another brand and it does work.

    In any case, I found a workaround for my specific case. I disabled SSID broadcast and turned on the guest network and connected to it manually, of course, while I don't have security, the network is supposedly invisible with SSID broadcast turned off.
    04-26-2016 12:52 PM
  8. B. Diddy's Avatar
    I'm moving this to the S6 forum, since there have been quite a few issues raised about wi-fi connectivity after the MM update for the S6 line.
    04-26-2016 02:54 PM

Similar Threads

  1. Does the HTC 10 have IR and FM radio?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-21-2016, 05:35 AM
  2. "Backup" apps to auto-install from Play Store?
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 04-15-2016, 07:06 PM
  3. Why do I have no internet while connected to WIFI?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-15-2016, 07:03 PM
  4. Replies: 1
    Last Post: 04-15-2016, 06:59 PM
  5. How can your replace system camera to an external WIFI camera
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 04-14-2016, 12:30 PM
LINK TO POST COPIED TO CLIPBOARD