1. doedoeent's Avatar
    I have the strange issue I can not resolve. I have xfinity WiFi XB3 router and a Galaxy S6. Every time I am on my home WiFi my Netflix, Facebook, Direct TV take a long time to load. I get over 30Mb download, I reset my router, cleared the cache on my device, used 2.5 and 5ghz. Other devices at my house don't have an issue on the WiFi. When I switch to my mobile network then all my apps work. I have no idea why only my S6 device on my home WiFi is not working.. any ideas?
    09-14-2016 12:01 AM
  2. mhinc's Avatar
    I have the strange issue I can not resolve. I have xfinity WiFi XB3 router and a Galaxy S6. Every time I am on my home WiFi my Netflix, Facebook, Direct TV take a long time to load. I get over 30Mb download, I reset my router, cleared the cache on my device, used 2.5 and 5ghz. Other devices at my house don't have an issue on the WiFi. When I switch to my mobile network then all my apps work. I have no idea why only my S6 device on my home WiFi is not working.. any ideas?
    Your problem is that POS all in one xfinity Comcast junk. Get a separate modem from Comcast, and buy yourself a nice DualBand Wireless N router. Their firmware sucks, and I wouldn't be surprised if they we trickeling certain devices.
    I used to work for Comcast and those combo units were nothing but trouble.
    09-14-2016 02:04 AM
  3. B. Diddy's Avatar
    Welcome to Android Central! Try logging into the modem/router's settings, and look for the option to disable IPv6. Also, try a different wi-fi channel (on 2.4 GHz), in case the current channel is really congested.

    Does the router have a QoS option (Quality of Service)? If so, turn it off. Check with Comcast as well to make sure they're not throttling certain traffic.
    09-14-2016 01:01 PM
  4. mhinc's Avatar
    Welcome to Android Central! Try logging into the modem/router's settings, and look for the option to disable IPv6. Also, try a different wi-fi channel (on 2.4 GHz), in case the current channel is really congested.

    Does the router have a QoS option (Quality of Service)? If so, turn it off. Check with Comcast as well to make sure they're not throttling certain traffic.

    Typically with Comcast all in one combos, they limit your ability to make changes. Maybe things have changed since I worked for them. But I have a feeling this may be a hard thing to do when they own the router
    09-14-2016 10:07 PM
  5. B. Diddy's Avatar
    Typically with Comcast all in one combos, they limit your ability to make changes. Maybe things have changed since I worked for them. But I have a feeling this may be a hard thing to do when they own the router
    I have an Arris modem/router (that I bought used, so at least I'm not paying Comcast endlessly for it!), and I can modify quite a few settings with it. But I know what you're talking about--some of these units are pretty locked down.
    mhinc likes this.
    09-14-2016 10:22 PM
  6. doedoeent's Avatar
    I've changed channels and checked IPv6 and still an issue. It's only on my S6.. do you think its a device setting vs. my router/ISP since it is only happening on my S6? I switch to mobile network and everything works fine.
    09-15-2016 09:38 AM
  7. B. Diddy's Avatar
    Check to see if there are any apps installed that might regulate network connections--especially any carrier-branded apps or battery saver apps.

    Also, make sure your DHCP range is wide enough to account for all devices you use on your wi-fi network.
    09-15-2016 11:41 AM
  8. lucianus_luciferus's Avatar
    if your phone works fine on other wifis then it's definitely the router
    B. Diddy likes this.
    09-15-2016 04:57 PM
  9. mhinc's Avatar
    I've changed channels and checked IPv6 and still an issue. It's only on my S6.. do you think its a device setting vs. my router/ISP since it is only happening on my S6? I switch to mobile network and everything works fine.
    First thing you need to check is just get access to a different WIFI, that isn't the same router, and see if the issue persists.
    If not, it's the modem/router and you can call Comcast and give them some hell. Don't waste your time with tier 1, ask to speak to someone directly in Tier 2
    B. Diddy likes this.
    09-15-2016 10:30 PM
  10. doedoeent's Avatar
    I was out of town and using WIFI at different locations and was fine. I just got back to my home WIFI and same thing. It has to be my WIFI network. Any other ideas?
    09-29-2016 11:28 AM
  11. lucianus_luciferus's Avatar
    it must be a setting on the router
    try changing the wifi security mode
    or change the password
    or disable the 5ghz network if it is a dual band router
    or disable the 2.4ghz
    or restore factory settings on the router
    09-29-2016 02:45 PM

Similar Threads

  1. My home button doesnt work when pressed
    By AC Question in forum Ask a Question
    Replies: 11
    Last Post: 09-16-2016, 10:41 AM
  2. Installed button savior and now touchscreen doesn't work.
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 09-14-2016, 02:59 PM
  3. app on phone will not install on my tablet
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 09-13-2016, 10:32 PM
  4. app on phone will install on my tablet
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 09-13-2016, 10:22 PM
LINK TO POST COPIED TO CLIPBOARD