1. zxci's Avatar
    I'm aware that this scenario has probably been posted before, but I've tried every solution that I've seen suggested and nothing's worked.

    Problem: my Galaxy S6 still absolutely refuses to fast charge. Charge times with a cable are 5-6 hours. It wirelessly charges fine with my qi pad. My battery isn't in too bad of a shape, though admittedly it will die really fast sometimes, the majority of the time it's fine. I don't think the battery is the problem though, because it also REFUSES to even be detected by a computer, though occasionally windows will flash a "USB device has malfunctioned" warning and I don't even know how to trigger it because it seemingly randomly happens every once in a while when I try plugging it in. If it doesn't flash a warning, my computer doesn't even act like anything was plugged in though the phone will charge (at it's normal corded sluggish rate of 5 hours estimated.)

    Things I've tried roughly in order:
    -Used original fast charger and cables
    -Verified the cables work with other phones flawlessly
    -Verified that fast charge is enabled on the phone under settings
    -Verified that the phone's also set for mtp protocol when it's being plugged into a computer
    -Downloaded drivers for interfacing with the phone onto my computer from samsung's website just to be sure
    -Made sure the micro usb port on the phone is clean and free of debris
    -Started applying all those updates I've been putting off all the way up to the most recent version
    -Cleared cache
    -Factory reset
    -Had the entire charge port replaced out of frustration via Foxpaw

    Still nothing. I'm in the same spot I was before, but now with a phone that has nothing on it (couldn't transfer it off anyway, internet can't handle backing the whole thing up) and I'm not keen on sending it to samsung for who knows how long for how much money. Ideas? Is there any way to verify with certainty what the problem is so I can stop wasting time trying to figure it out?
    11-24-2016 03:18 AM
  2. Jamie Stone4's Avatar
    All I can say is to send it to Samsung under warranty and get a new Samsung s6.

    Might not seem like the easiest option, but the phone seems faulty.
    11-24-2016 10:17 AM

Similar Threads

  1. already laggy issues with DTEK60
    By IJKBB10 in forum BlackBerry DTEK60
    Replies: 5
    Last Post: 02-20-2017, 12:49 PM
  2. USB C adapter with flash drive works great on Pixel XL!
    By I800C0LLECT in forum Google Pixel & Pixel XL
    Replies: 16
    Last Post: 01-02-2017, 10:09 AM
  3. Moto X Pure on T-Mobile - voLTE issue with chopped calls?
    By Leblon in forum Moto X Pure Edition
    Replies: 6
    Last Post: 12-21-2016, 09:18 PM
  4. S3 Frontier issues
    By mrkalel in forum Samsung Gear S3
    Replies: 23
    Last Post: 12-08-2016, 07:12 PM
  5. 7.0 issues/thoughts
    By mobrules in forum Moto Z Force
    Replies: 0
    Last Post: 11-23-2016, 10:14 AM
LINK TO POST COPIED TO CLIPBOARD