1. j2xv's Avatar
    Hi everyone,
    I don't usally post alot in forums bc so many bugs have already be covered in other forums, however, this time i really seem to be the only one with this specific problem...

    So when i try to record my screen with any app out there (i tried several apps) i instantly get "system UI has crashed", followed by a reset of the launcher. Note that this only happens when i activate the actual "record" function on the apps, so the apps themselves work fine except for their most important feature.

    I'm having this issue on my Galaxy S6, running 6.0.1 (G920FXXU4DPFY) (stock)

    I already tried:
    Disabling all "apps tha appear on top" except for the actual recorder app

    disabling developer options (i usally have it enabled for having 0.5x scale animations speeds instead of 1x)

    Switching to the regular samsung launcher (since i use trebuchet from Cyanogen)

    taking screenshots works just fine.

    Hopefuly you guys are smart eneugh to help me, i really need this feature for my studies, thanks!
    04-02-2017 06:31 PM
  2. Javier P's Avatar
    Welcome to the forums. I remember reading about a similar issue some time ago. If I remember correctly the problem was related to the gestures to take a screenshot and such. Not sure if this will be your case, but worth a try. Go to settings - motions & gestures - palm swipe to capture - switch it off (and maybe do the same with any other gesture just in case).
    04-02-2017 06:39 PM
  3. Javier P's Avatar
    Also, you could try uninstalling updates for the Google app. This seems to have worked for some users with a similar problem.
    04-02-2017 06:46 PM
  4. j2xv's Avatar
    Hi Javier,
    I tried again after disabling all the motion- and gestures options and deleting the google-app updates, but this did not solve the problem. Do you suggest me to first do a reboot or re-installation of the app?
    Thanks for helping!
    04-02-2017 07:09 PM
  5. Javier P's Avatar
    Yeah, always good to restart the phone after this kind of changes. If the problem persists you can update the Google app since it doesn't seem related to it.

    I searched a little bit and found similar reports, but not a clear solution. Most of them were related to a bug on Lollipop, obviously not your case. It seems that for a few people resetting app preferences did the trick.
    04-02-2017 10:00 PM
  6. j2xv's Avatar
    So i did a reboot and tried again but this had no effect, however i did reset the app preferences and when i than started the record function, the app first asked permission, when i granted the permission it did actually work fine again, so i think the issue indeed had to do with android somehow not giving permission to record the screen, but also not prompting a dialog box asking for it. Resetting the app preferences as you said solved this and i have no idea why i didn't try this earlier haha.

    I'm really glad it works again, thank you!
    Javier P likes this.
    04-03-2017 07:14 AM
  7. Javier P's Avatar
    Great news! That sounds exactly like the old Lollipop bug. It was a permission problem and the SystemUI crashed if you granted the permission AND checked the 'Don't ask me again' box. If you get the same problem again repeat the process and just remember not to click that box (and confirm that it's not checked by default).

    Please, keep us posted, your feedback will be very helpful for other people with a similar issue.
    j2xv likes this.
    04-03-2017 07:28 AM

Similar Threads

  1. Replies: 23
    Last Post: 06-12-2017, 05:01 AM
  2. No "system previews" in the status bar on Samsung Galaxy Note 4?
    By AC Question in forum Samsung Galaxy Note 4
    Replies: 3
    Last Post: 04-04-2017, 04:40 PM
  3. Replies: 1
    Last Post: 04-04-2017, 12:08 AM
  4. Replies: 1
    Last Post: 04-03-2017, 11:51 PM
  5. Replies: 0
    Last Post: 04-02-2017, 04:15 PM
LINK TO POST COPIED TO CLIPBOARD